Package Details: brother-hl2250dn 2.0.4_2-4

Git Clone URL: https://aur.archlinux.org/brother-hl2250dn.git (read-only)
Package Base: brother-hl2250dn
Description: Brother HL-2250DN CUPS Driver
Upstream URL: http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html
Licenses: GPL
Submitter: egon0
Maintainer: egon0
Last Packager: egon0
Votes: 3
Popularity: 0.000000
First Submitted: 2015-08-23 10:04
Last Updated: 2015-08-23 10:05

Latest Comments

lonaowna commented on 2019-09-28 14:13

The newer generic brother-brgenml1 driver also works nicely with the HL-2250DN.

trusiad commented on 2019-09-05 12:25

The printer is now supported with Gutenprint and fommatic ppd files.

sainth commented on 2019-09-05 10:34

It works for me with the current cups version if I use the original PPD file. So the fix should be to remove:

  # Add margin correction (alignmargins output: https://wiki.linuxfoundation.org/en/OpenPrinting/Database/CUPSDocumentation)
  patch "$srcdir/usr/share/cups/model/HL2250DN.ppd" < "$srcdir/../HL2250DN.ppd.patch"

trusiad commented on 2019-08-28 08:12

Worked fine for years. Since a couple of days, the printing didn't worked anymore with an error message : En cours d'impression - "Filter failed" . Try to uninstall and re-install : Impossible d’ajouter l’imprimante : Unable to copy PPD file.

lekin commented on 2019-08-19 20:37

Worked well for years; last printout in June. Now I get the following error: Unable to open PPD file - illegal option keyword string on line 282.

There is just one line printed on paper: <</.HWMargins[17. 12. 17. 12.]>>setpagedevice which looks closely related to the HL2250DN.ppd.patch.

cups 2.2.12-1 cups-filters 1.25.2-1

asyncial commented on 2017-10-26 15:31

Fails to build, but if you remove the '..' in line 45 in the PKGBUILD it works again.

ArthurBorsboom commented on 2017-08-20 22:42

Darn... please ignore my comment. I forgot to enable the multilib repository.

ArthurBorsboom commented on 2017-08-20 22:39

==> Install or build missing dependencies for brother-hl2250dn:
error: target not found: lib32-glibc