Package Details: brother-hl3170cdw 1.1.2-1

Git Clone URL: https://aur.archlinux.org/brother-hl3170cdw.git (read-only)
Package Base: brother-hl3170cdw
Description: LPR and CUPS driver for the Brother HL3170CDW
Upstream URL: http://solutions.brother.com/linux/en_us/
Licenses: custom:brother commercial license
Submitter: philmartella
Maintainer: philmartella
Last Packager: philmartella
Votes: 3
Popularity: 0.003439
First Submitted: 2016-07-27 02:46
Last Updated: 2016-07-27 03:46

Latest Comments

Purgator commented on 2017-05-29 13:28

I have cups installed and proceed to do a lot of bullshit before end up to use this printer. I have no idea what I did wrong, maybe I have problem with every printer, I don't really have much time to check.
If you can't add your printer by GUI as me you can run the following command :

lpadmin -p HL3170CDW -E -v socket://printer-ip

And that all.

Note that you should need the driver installed to get it works.

Voice commented on 2016-09-02 09:50

Upstream CUPS wrapper now 1.1.4-0 while LPR held at 1.1.2. The CUPS wrapper is open-source and could be compiled in the PKGBUILD.

http://support.brother.com/g/b/downloadlist.aspx?c=us&lang=en&prod=hl3170cdw_all&os=127

There's a recent firmware update for this model. The f/w updater needs Windows but WinPE may work with it.

http://support.brother.com/g/b/downloadend.aspx?c=us&lang=en&prod=hl3170cdw_all&os=93&dlid=dlf002976_000&flang=8&type3=375
https://wiki.archlinux.org/index.php/Windows_PE