Package Details: brother-mfc-j480dw 1.0.0-0

Git Clone URL: https://aur.archlinux.org/brother-mfc-j480dw.git (read-only)
Package Base: brother-mfc-j480dw
Description: CUPS and LPR drivers for the Brother MFC-J480DW printer
Upstream URL: https://support.brother.com/g/b/downloadlist.aspx?c=us&lang=en&prod=mfcj480dw_us_eu_as&os=127
Keywords: brother mfc-j480dw printer
Licenses: custom:brother commercial license
Submitter: fallenpixel
Maintainer: stick
Last Packager: stick
Votes: 3
Popularity: 0.000004
First Submitted: 2015-12-15 14:29
Last Updated: 2019-06-12 02:24

Latest Comments

stick commented on 2018-05-02 14:37

@vfrico,

As noted in "Getting Started" of the AUR user documentation, building AUR packages requires the base-devel package, which includes binutils. These utilities are required to build all AUR packages, and are not listed in the dependencies.

https://wiki.archlinux.org/index.php/Arch_User_Repository#Getting_started

vfrico commented on 2018-05-02 14:30

The build has raised me today an error: "strip binary not found".

Installing the package core/binutils (pacman -S binutils) solved the compilation.

Adding binutils as dependency could solve this for further installations.

lmat commented on 2018-03-23 22:26

Got it working. Rather than using a "Discovered Network Printer", I need to specify the address. It's in the wiki: https://wiki.archlinux.org/index.php/CUPS/Printer-specific_problems#Brother under "Network Printers": For network printers, use ipp://printer_ip/ipp/port1 as printer address.

Arch Linux never lets me down!

lmat commented on 2018-03-23 22:08

I got one of these units, and I'm able to install this package. When I go to cups then "Add Printer", it says "Discovered Network Printers", and two of the entries say, "Brother MFC-J480DW (Brother MFC-J480DW)", and one says, "Brother MFC-J480DW (driverless) (Brother MFC-J480DW)". I select one and continue.

In a couple pages, when I'm picking the model, there are two entries that look promising: "Brother MFC-J480DW CUPS (en)" and "Brother MFC-J480DW, driverless, cups-filters 1.17.9 (en)". No matter what I selected on the Discovered Network Printers, the driverless model errs with "Unable to copy PPD file.".

Any other configuration seems to install alright, and I can print jobs to it, but the jobs page in cups says, "Unable to locate printer "BRWD46A6A9E8A8F.local"".

I'm glad you all were able to install the drivers and use them alright, but could you give me a hint? Hopefully I'll have everything worked out before I get a response, but if I haven't responded to this ticket detailing the solution, please take heart and throw a bone; thanks!

stick commented on 2017-09-13 02:59

Dependency issues fixed; thanks to fallenpixel for the package!

fallenpixel commented on 2016-09-27 18:58

Update today should fix the installation issues. Sorry, I don't use the driver anymore so didn't notice the issue. Hope you enjoy.

billyx commented on 2016-09-27 08:15

I can't install the driver

fallenpixel commented on 2016-09-12 21:54

Updated, ty.

pacorrop commented on 2016-09-12 10:43

I'd include ghostscript and a2ps as dependencies, since the /opt/brother/Printers/mfcj480dw/lpd/filtermfcj480dw script make use of them.