Package Details: brother-mfc-l2700dw 3.2.0-1

Git Clone URL: https://aur.archlinux.org/brother-mfc-l2700dw.git (read-only)
Package Base: brother-mfc-l2700dw
Description: LPR and CUPS driver for the Brother MFC-L2700DW
Upstream URL: http://solutions.brother.com/linux/en_us/
Licenses: custom:brother commercial license
Submitter: stefano
Maintainer: stefano
Last Packager: stefano
Votes: 3
Popularity: 0.015297
First Submitted: 2015-06-30 22:00
Last Updated: 2015-12-27 23:15

Latest Comments

hak8or commented on 2018-06-24 18:04

For those who are trying to get the scanner to work on their desktop with this printer networked, I was able to get this working using sane and brscan4. The last post here shows how to get it working (https://forums.linuxmint.com/viewtopic.php?t=187523). I was also able to use it using the hostname of the printer by doing:

brsaneconfig4 -a name=BROTHER model=MFC-L2700DW nodename=BRWD85DE244E1EB

Then a simple (scanimage --format=png > test.png) works with no fuss.

Also, to the package maintainer, I would highly suggest adding brscan4 as an optional dependency so people who are trying to decide which brscan to install will be able to see this model listed as an optional dependancy of of brscan4. For example, adding this should suffice:

brscan4 (optional) – Scanner support

timofonic commented on 2017-09-22 02:01

What's better to install? Custom (brother-mfc-l2700dw) or generic (brother-brgenml1)? I'm confused

See this example...

Comparison to aid in creating a PKGBUILD for the Brother HLL6250DW printer driver
https://gist.github.com/miotatsu/6cf221bcdf047bf6b0c3a514b32ae6a6

Pandino commented on 2017-08-28 16:59

Can someone post the working PKGBUILD for this package? Thanks!

PS: it seems that this PKGBUILD works... don't forget to install the a2ps package!

cpettitt commented on 2017-08-12 20:19

Huge thanks to sakenogawa. I can confirm that his process worked for me as well.

BorisM commented on 2017-03-06 22:05

This package doesn't work at all, can somebody fix it? It doesn't seem like the maintainer will do something about it...

ilfugiuliopascal commented on 2016-09-09 15:37

For me it works only as sakenogawa says: I use the brother-mfc-l2720dw package and I modify sources and md5sum with the one used here.

Please add also brscan4 as dependency for the scanner and the udev-rule:
/etc/udev/rules.d/99-printer.rules
ATTRS{idVendor}=="04f9", ATTRS{idProduct}=="0331", MODE="0664", GROUP="lp", ENV{libsane_matched}="yes"

timofonic commented on 2016-04-28 15:10

Why do we need a wrapper? Wha about x86_64 support? What about direct support in CUPS or a fork of it?

What about Gutenprint and Foomatic? What about brscan-skey?

There are tons of driver packages, some of them have a big bunch of drivers:
- brother-brgenml1
- brother-cups-wrapper-ac
- brother-cups-wrapper-laser
- brother-lpr-drivers-ac
- brother-lpr-drivers-laser
- brother-lpr-drivers-common

Kind regards.

sakenogawa commented on 2015-12-25 11:01

Unfortunately, this package did not work for me, because on x86_64 it does not enforce the installation of lib32-glibc and the PPD and filter files are not copied from the /opt tree to /usr.

I decided to adapt the PKGBUILD from brother-mfc-l2720dw using the source links from this package which worked like a charm. Maybe consider modifying this package accordingly.