Package Details: brother-ql500 1.0.1r0-3

Git Clone URL: (read-only)
Package Base: brother-ql500
Description: LPR and CUPS driver for Brother QL-500 label printer
Upstream URL:
Keywords: brother cups cupswrapper driver filter label lpr ppd printer ql-500
Licenses: custom
Conflicts: brother-ql500-cupswrapper, brother-ql500-cupswrapperinch, brother-ql500-lpr
Provides: brother-ql500-cupswrapper, brother-ql500-cupswrapperinch, brother-ql500-lpr
Submitter: kbabioch
Maintainer: kbabioch
Last Packager: kbabioch
Votes: 5
Popularity: 0.674965
First Submitted: 2016-09-16 09:12
Last Updated: 2016-09-20 16:29

Latest Comments

kbabioch commented on 2018-02-04 21:21

@fortress8197: Do you have a reference to a newer upstream version? The latest I can find is still 1.0.1 (see here). Is it broken only for you, or can other confirm this, too?

I'm afraid there is not much I can do to fix this situation. You should probably report this to Brother (not sure on what channel) and/or to the CUPS project, since I would consider this to be a regression. They know a lot more about PPD files, etc., and can probably help you in debugging this.

fortress8197 commented on 2018-02-04 21:01

This package stopped working for me around a week ago since the new CUPS (2.2.6-4, + cups-filters-1.20.0-1) came out. Weird thing though: reverting back to cups-2.2.6-1 and cups-filters-1.17.9-3 still makes this not work. Job gets sent to printer, printer reports print (i assume), it says printed successfully but the printer did absolutely nothing. The AUR package printer-driver-ptouch works for me but messes up my labels, it's missing the feed option that this package provided and I think that's causing it. Please update this package to make it work again so I can continue to use my printer.

kbabioch commented on 2016-09-20 16:17

Thanks for your feedback. I've taken other brother driver packages as role model, and couldn't find it there, so what is it actually needed for here? Is ghostscript actually needed for this to work, or does a optional dependency make more sense?

I think it makes sense to remove the other cupswrapper and lpr packages, although this is something you have to decide for yourself. I think you have to ask a trusted user for that.

I've added the provides and conflicts statements. I've also changed the versioning scheme a little bit, so you probably want to update.

zoe commented on 2016-09-20 09:03

Thank you for that package ; I am maintainer of brother-ql500-cupswrapper, brother-ql500-lpr and brother-ql500-cupswrapperinch, which, I hope, will be able to be deleted.
I suggest you to add :
as dependency, or optional dependency ?

and, of course, as conflicts :