Package Details: btcd-git autogenerated-2

Git Clone URL: https://aur.archlinux.org/btcd-git.git (read-only, click to copy)
Package Base: btcd-git
Description: An alternative full node Bitcoin implementation written in Go.
Upstream URL: https://github.com/btcsuite/btcd
Licenses: ISC
Conflicts: btcd
Provides: btcd
Submitter: moe_narrow
Maintainer: None
Last Packager: moe_narrow
Votes: 0
Popularity: 0.000000
First Submitted: 2019-04-20 16:29 (UTC)
Last Updated: 2019-04-20 16:44 (UTC)

Latest Comments

pizzaman commented on 2021-06-08 06:43 (UTC)

Won't build with a run 'go mod vendor' to sync error.

==> Making package: btcd-git autogenerated-2 (Tue 08 Jun 2021 04:39:23 PM AEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Cloning btcd git repo...
Cloning into bare repository '/tmp/trizen-pizzaman/btcd-git/btcd'...
remote: Enumerating objects: 39805, done.
remote: Counting objects: 100% (942/942), done.
remote: Compressing objects: 100% (709/709), done.
remote: Total 39805 (delta 500), reused 333 (delta 228), pack-reused 38863
Receiving objects: 100% (39805/39805), 49.36 MiB | 19.16 MiB/s, done.
Resolving deltas: 100% (28796/28796), done.
==> Validating source files with sha256sums...
    btcd ... Skipped
==> Extracting sources...
  -> Creating working copy of btcd git repo...
Cloning into 'btcd'...
done.
Switched to a new branch 'makepkg'
==> Starting prepare()...
Switched to branch 'master'
Your branch is up to date with 'origin/master'.
  -> installing go dependencies
  Locking in v1.0.0 (a8d27c5) for transitive dep github.com/kkdai/bstream
  Using ^1.1.1 as constraint for direct dep github.com/davecgh/go-spew
  Locking in v1.1.1 (8991bc2) for direct dep github.com/davecgh/go-spew
  Locking in master (aa57bab) for transitive dep golang.org/x/sys
  Using master as constraint for direct dep github.com/btcsuite/go-socks
  Locking in master (4720035) for direct dep github.com/btcsuite/go-socks
  Using ^1.0.0 as constraint for direct dep github.com/jrick/logrotate
  Locking in v1.0.0 (a93b200) for direct dep github.com/jrick/logrotate
  Using ^1.0.0 as constraint for direct dep github.com/btcsuite/goleveldb
  Locking in v1.0.0 (3fd0373) for direct dep github.com/btcsuite/goleveldb
  Using master as constraint for direct dep github.com/btcsuite/btclog
  Locking in master (84c8d23) for direct dep github.com/btcsuite/btclog
  Using ^1.0.2 as constraint for direct dep github.com/btcsuite/btcutil
  Locking in v1.0.2 (b2bf7f8) for direct dep github.com/btcsuite/btcutil
  Locking in v1.0.1 (83563a2) for transitive dep github.com/aead/siphash
  Using ^1.0.0 as constraint for direct dep github.com/btcsuite/winsvc
  Locking in v1.0.0 (f8fb11f) for direct dep github.com/btcsuite/winsvc
  Locking in v1.0.0 (b3db38e) for transitive dep github.com/btcsuite/snappy-go
  Using master as constraint for direct dep golang.org/x/crypto
  Locking in master (c07d793) for direct dep golang.org/x/crypto
  Using ^1.5.0 as constraint for direct dep github.com/jessevdk/go-flags
  Locking in v1.5.0 (1878de2) for direct dep github.com/jessevdk/go-flags
  Using master as constraint for direct dep github.com/btcsuite/websocket
  Locking in master (31079b6) for direct dep github.com/btcsuite/websocket
  Using master as constraint for direct dep github.com/decred/dcrd
  Locking in master (70483c8) for direct dep github.com/decred/dcrd
==> Starting pkgver()...
==> Updated version: btcd-git 20210601.3345_63438c6d-1
==> Starting build()...
go: inconsistent vendoring in /tmp/trizen-pizzaman/btcd-git/src/go/src/github.com/btcsuite/btcd:
        github.com/btcsuite/btclog@v0.0.0-20170628155309-84c8d2346e9f: is explicitly required in go.mod, but not marked as explicit in vendor/modules.txt
        github.com/btcsuite/btcutil@v1.0.3-0.20201208143702-a53e38424cce: is explicitly required in go.mod, but not marked as explicit in vendor/modules.txt
        github.com/btcsuite/go-socks@v0.0.0-20170105172521-4720035b7bfd: is explicitly required in go.mod, but not marked as explicit in vendor/modules.txt
        github.com/btcsuite/goleveldb@v1.0.0: is explicitly required in go.mod, but not marked as explicit in vendor/modules.txt
        github.com/btcsuite/websocket@v0.0.0-20150119174127-31079b680792: is explicitly required in go.mod, but not marked as explicit in vendor/modules.txt
        github.com/btcsuite/winsvc@v1.0.0: is explicitly required in go.mod, but not marked as explicit in vendor/modules.txt
        github.com/davecgh/go-spew@v1.1.1: is explicitly required in go.mod, but not marked as explicit in vendor/modules.txt
        github.com/decred/dcrd/lru@v1.0.0: is explicitly required in go.mod, but not marked as explicit in vendor/modules.txt
        github.com/jessevdk/go-flags@v1.4.0: is explicitly required in go.mod, but not marked as explicit in vendor/modules.txt
        github.com/jrick/logrotate@v1.0.0: is explicitly required in go.mod, but not marked as explicit in vendor/modules.txt
        golang.org/x/crypto@v0.0.0-20200510223506-06a226fb4e37: is explicitly required in go.mod, but not marked as explicit in vendor/modules.txt

run 'go mod vendor' to sync, or use -mod=mod or -mod=readonly to ignore the vendor directory
==> ERROR: A failure occurred in build().
    Aborting...
:: Unable to build btcd-git - makepkg exited with code: 4

micwoj92 commented on 2021-03-01 17:33 (UTC)

is dep still needed to build?