Package Details: bugle 0.0.20140104-1

Git Clone URL: (read-only)
Package Base: bugle
Description: An OpenGL debugging tool
Upstream URL:
Licenses: GPL
Submitter: encelo
Maintainer: encelo
Last Packager: encelo
Votes: 13
Popularity: 0.000008
First Submitted: 2006-06-28 02:11
Last Updated: 2015-07-07 21:12

Latest Comments

encelo commented on 2015-08-22 13:20

Updated to 0.0.20150628

mediocregopher commented on 2014-06-15 23:18

Using this build I get an error when running at filter initialization. If I change the build command to 'scons prefix=/usr install' then it installs and runs fine.

encelo commented on 2014-03-24 22:28

Updated to 0.0.20140104

localuser commented on 2014-03-24 17:26

Tagged this out-of-date as it won't even build no more. New version builds fine for me (I had to copy over /usr/local/lib/*bugle* to /usr/lib though as those files are ignored by the prefix=/usr/ when running scons)

Hazematman commented on 2014-01-02 04:53

I get this error when I try to build the package: "KeyError: Function `glDrawRangeElements' already exists with different signature"

jrk commented on 2013-11-23 12:05

I've modified $srcdir/src/SConstruct in line 179:

- ('LIBDIR', r'\"%s\"' % aspects['libdir']),
+ ('LIBDIR', r'\"%s\"' % aspects['pkglibdir']),

This seems to work (for me).

jrk commented on 2013-11-23 11:41

I've built bugle again, using only makepkg, without the yaourt wrapper.
Seems there is a hardcoded path in the bugle library:

$ strings /usr/lib/ | grep '/tmp/bugle'

jrk commented on 2013-11-23 11:33


there's something odd with the installed files:

[ERROR] filters.initialise: failed to open /tmp/yaourt-tmp-jrk/aur-bugle/pkg/bugle/usr/lib/bugle: No such file or directory

I think this has to do something with 'prefix=$pkgdir/usr', but I don't know scons well enough.

Anonymous comment on 2013-05-05 15:17

with version 0.0.20130121, I built and installed successfully with scons but cannot find the resulting gldb-gui. Is there a build setting I missed?

encelo commented on 2013-05-04 14:38

- Updatd to 0.0.20130121-1
- Added "pkglibdir=/usr" to scons build command for gldb-gui to work, thanks to Basique.

Basique commented on 2013-04-28 19:53

You need to add "pkglibdir = /usr" to the scons command in build(). Otherwise, gldb-gui doesn't work.

canurabus commented on 2012-07-08 02:58

I get a seg fault when trying to run gldb-gui

canurabus commented on 2012-07-08 02:57

I get segmentation fault when trying to run gldb-gui.

encelo commented on 2012-04-14 15:24

Updated to 0.0.20120331

Svenstaro commented on 2011-05-05 17:32

Also you should manually copy the libs from filters/.libs to the target positions as the install script doesn't do it properly. In fact you should probably just install the whole thing manually.

Svenstaro commented on 2011-05-05 17:15

Perhaps you should also install doc/examples/ as it doesn't seem to be installed by default.

encelo commented on 2010-06-12 21:09

- Updated to 0.0.20100508
- Added a patch to compile under GCC 4.5 (thanks to idostyle)

Anonymous comment on 2010-06-08 10:04

Quick fix gcc4.5:
Add after configure: patch < $startdir/mvtu.patch

encelo commented on 2010-05-12 20:56

Got the same here. :-(

Zuf commented on 2010-05-12 18:44

I have same error about .tu file.

./ gl.c src/data/gl.tu
No .tu file found! Are you using GCC 3.4 or 4.1+?
make: *** [src/data/gl.tu] Error 1

kasbah commented on 2010-05-06 02:46

This did not build for me with gcc-4.5 (due to .tu file error). Had to compile this with gcc-4.3.