Package Details: buildstream 1.6.1-1

Git Clone URL: https://aur.archlinux.org/buildstream.git (read-only, click to copy)
Package Base: buildstream
Description: A powerful and flexible software integration toolset
Upstream URL: https://buildstream.build
Licenses: LGPL
Submitter: rafaelff
Maintainer: None
Last Packager: rafaelff
Votes: 5
Popularity: 0.040157
First Submitted: 2018-01-03 16:40 (UTC)
Last Updated: 2021-05-31 00:05 (UTC)

Latest Comments

FantasqueX commented on 2022-03-18 06:46 (UTC)

Currently, the most recent stable version(1.6.5) depends on ruamel.yaml < 0.17 which conflicts the one in ArchLinux repository. So packaging is impossible now. Hoping a new version will remove the restriction.

mikezackles commented on 2021-08-16 16:15 (UTC)

FYI the project has moved to github (and there is a new version there): https://github.com/mikezackles/buildstream-PKGBUILD/commit/c21c86b34ecf36fd9e93161df623f9925b95e801

jjardon commented on 2019-09-04 09:57 (UTC)

@rafaelff: FYI, No need for a specific version of ruamel anymore since 1.4.1

rafaelff commented on 2019-01-12 12:34 (UTC)

@jjardon: Fixed, thanks.

jjardon commented on 2019-01-09 13:38 (UTC)

@rafaelff: From setup.py, the ruamel version to use should be:

'ruamel.yaml < 0.15.52'

So python-ruamel-yaml0.15.51 is the maximum version allowed

rafaelff commented on 2018-11-30 12:58 (UTC)

@KerrickStaley: should be solved now. Please try and let me know.

KerrickStaley commented on 2018-11-27 02:58 (UTC)

I'm getting the following error running bst:

$ bst build --track-all sdk/gtk+-3.bst Traceback (most recent call last): File "/usr/bin/bst", line 5, in <module> from buildstream._frontend import cli File "/usr/lib/python3.7/site-packages/buildstream/init.py", line 31, in <module> from .plugin import Plugin File "/usr/lib/python3.7/site-packages/buildstream/plugin.py", line 100, in <module> from . import _yaml File "/usr/lib/python3.7/site-packages/buildstream/_yaml.py", line 27, in <module> from ruamel import yaml ModuleNotFoundError: No module named 'ruamel'

I think python-ruamel-yaml should be added as a dependency.

jjardon commented on 2018-08-23 16:47 (UTC)

@rafaelff: looks good to me, thanks!

rafaelff commented on 2018-08-22 20:37 (UTC)

@jjardon: please take a look at bst-external package and let me know. Then I'll work on the VCS package.

jjardon commented on 2018-08-22 14:24 (UTC)

@rafaelff I wonder if you would have some time to package https://gitlab.com/BuildStream/bst-external, It's needed to some important stuff (like generate flatpak runtimes/apps)

If not let me know and I can create a package myself

rafaelff commented on 2018-07-20 22:56 (UTC)

Thanks, jjardon

jjardon commented on 2018-07-20 01:19 (UTC)

@rafaelff version 1.1.4 has introduced two new dependencies:

jjardon commented on 2018-06-26 17:54 (UTC) (edited on 2018-06-26 17:54 (UTC) by jjardon)

@rafaelff yeah, I'd prefer this to work for everyone out-of-the box more than be completely correct about the dependencies

So I guess we should add as dependencies: - git - patch - lzip

rafaelff commented on 2018-06-10 22:17 (UTC)

@jjardon: It seems to me that all tools verified in tests/testutils/site.py (including lzip) should be added in the depends() array (not optdepends()) to make sure the user of buildstream has all the needed dependencies for all hosts... What is your opinion on that?

jjardon commented on 2018-06-10 20:31 (UTC)

@rafaelff depends on the Source plugins your buidstream project is using, you may need additional host dependencies, see https://gitlab.com/BuildStream/buildstream/issues/353

rafaelff commented on 2018-05-28 10:02 (UTC)

@benwaffle, can you please tell me what were you doing when lzip was necessary?

benwaffle commented on 2018-05-28 03:49 (UTC)

should this depend on lzip?

jjardon commented on 2018-04-17 06:56 (UTC)

buildstream doesn't depend on python-fusepy anymore

rafaelff commented on 2018-02-07 10:42 (UTC)

@dsboger: Indeed. Fixed in 1.0.1-2

dsboger commented on 2018-02-05 18:53 (UTC) (edited on 2018-02-05 21:37 (UTC) by dsboger)

I think this might be missing a dependency on python-jinja. I've had the following error when trying to use bst:

$ bst build --track-all --track-save apps/dconf-editor.bst
Traceback (most recent call last):
  File "/usr/bin/bst", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3147, in <module>
    @_call_aside
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3131, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3160, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 666, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 984, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 870, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'jinja2' distribution was not found and is required by BuildStream

Installing python-jinja fixed it.