Package Details: bundler-exec latest-1

Git Clone URL: https://aur.archlinux.org/bundler-exec.git (read-only)
Package Base: bundler-exec
Description: Automatically run Ruby scripts with bundle exec
Upstream URL: https://github.com/gma/bundler-exec
Licenses: unknown
Submitter: WhyNotHugo
Maintainer: None
Last Packager: WhyNotHugo
Votes: 0
Popularity: 0.000000
First Submitted: 2016-03-07 13:41
Last Updated: 2018-10-02 04:47

Dependencies (1)

Required by (0)

Sources (1)

Latest Comments

WhyNotHugo commented on 2018-10-02 04:48

Package updated to work around this.

I'm not using this package any more, so feel free to adopt it if you do.

gjb commented on 2018-10-02 04:44

The Gnome login issue (described on 2016-04-15 08:52) still exists for Gnome 3.30

ltorvalds024 commented on 2016-04-16 07:51

I tried to report there (https://github.com/gma/bundler-exec/blob/master/bundler-exec.sh) but the maintainer there said to report here (to you)

WhyNotHugo commented on 2016-04-16 06:40

This seems to be an upstream issue. Can you report it there?

https://github.com/gma/bundler-exec/blob/master/bundler-exec.sh

Oddly, this works for me, though my user's shell is zsh, so that might be related.

ltorvalds024 commented on 2016-04-15 08:52

Your package `bundler-exec` (version latest-1) provides a fault script `/etc/profile.d/bundler-exec.sh` because of which I was not able to login to GNOME 3.20 on Arch Linux. More details: https://bbs.archlinux.org/viewtopic.php?id=211284
You must know that all the scripts in `/etc/profile.d` directory are run by `sh` at the time of login in GDM (usually because bash or zsh are default shell). sh shell does not allow `-` in the name of identifiers, so I get this error

Apr 13 14:36:59 ArchLinux /usr/lib/gdm/gdm-x-session[2719]: /etc/profile.d/bundler-exec.sh: line 12: `bundler-installed': not a valid identifier

Fixing it requires to remove `-` from all identifiers.