Package Details: butterflow 0.2.3-1

Git Clone URL: https://aur.archlinux.org/butterflow.git (read-only)
Package Base: butterflow
Description: Make slow motion and motion interpolated videos from the command line
Upstream URL: https://github.com/dthpham/butterflow
Keywords: interpolation motion
Licenses: custom
Conflicts: butterflow
Provides: butterflow
Submitter: dthpham
Maintainer: dthpham
Last Packager: dthpham
Votes: 7
Popularity: 0.000002
First Submitted: 2014-09-25 21:43
Last Updated: 2017-04-10 22:41

Latest Comments

1 2 3 4 Next › Last »

Patricol commented on 2019-03-08 19:02

@dthpham Sorry, my intention was to point out that the source link being dead means that the PKGBUILD now fails.

dthpham commented on 2019-03-08 03:37

@Patricol Source packages are now hosted on Github: https://github.com/dthpham/butterflow/releases/tag/v0.2.3

Patricol commented on 2019-03-08 03:30

Source link is dead (http://srv.dthpham.me/butterflow/releases/butterflow-0.2.3.tar.gz)

enihcam commented on 2018-12-12 23:25

Please depend on 'opencl-driver', instead of specified optional opencl drivers.

sicariusnoctis commented on 2018-09-08 08:55

See here for reasonably easy method on using opencv2-opt to prevent conflicts with opencv (3):

https://github.com/dthpham/butterflow/issues/55

Then run:

sudo ln -s /usr/lib/python2.7/site-packages/numpy/core/include/numpy /usr/local/include/numpy
makepkg -si
sudo rm /usr/local/include/numpy

nemethdani commented on 2018-07-13 16:52

please make sure it does this before compilation: ln -s /usr/lib/python2.7/site-packages/numpy/core/include/numpy /usr/local/include/numpy

dthpham commented on 2017-01-12 17:22

@tkoham The plan is to always use the latest version of opencv, but I need to do more research on how opencl works in opencv3 before I make the switch because the last time I checked the main function that interpolation depends on only works with nvidia GPUs. If I switched, people only using an Intel device, like most OSX users, wouldn't be able to use this app otherwise.

tkoham commented on 2017-01-12 11:38

Are there any plans to package this so it can coexist on installations that depend on opencv3 for other applications? It hardly seems worth it to edit both PATH and the package or set up a chroot just to interpolate videos

julianmb commented on 2016-06-29 16:18

I know how to fix it. Opencv has been updated to version 3.1, so you need to replace opencv for opencv2 in the PKGBUILD, so it uses a legacy version

sagir33 commented on 2016-06-16 16:45

Not working for me. Anyone know how to fix?

/tmp/yaourt-tmp-arch/aur-butterflow/src/butterflow-0.2.0/butterflow/motion.cpp:6:31: fatal error: opencv2/ocl/ocl.hpp: No such file or directory
#include <opencv2/ocl/ocl.hpp>
^
compilation terminated.
error: command 'gcc' failed with exit status 1