Package Details: bwsyncandshare 11.8.0-1

Git Clone URL: https://aur.archlinux.org/bwsyncandshare.git (read-only)
Package Base: bwsyncandshare
Description: file sync and share client
Upstream URL: https://bwsyncandshare.kit.edu
Licenses: custom
Submitter: wilga
Maintainer: biosin
Last Packager: biosin
Votes: 2
Popularity: 0.000000
First Submitted: 2016-02-26 10:36
Last Updated: 2019-03-20 11:20

Latest Comments

wilga commented on 2018-08-22 12:07

I am no longer able to maintain this package since I will lose access to the service soon. Anyone please feel free to take over.

biosin commented on 2018-07-15 07:42

Is there a problem with the newest version or is the maintainer just too busy to upgrade?

wilga commented on 2017-09-27 19:29

Current upstream version appears to require Oracle jre8. Nothing we can do about that - the software is closed source. I will however change the dependency from jre (now 9) to jre8 to fix the installation problem.

biosin commented on 2017-09-26 11:17

Since java 9, the script doesn't work anymore. And unfortunately it seems like the software doesn't run with java 9 at all.

wilga commented on 2016-11-07 09:13

No worries, my mistake. The idea was to get rid of the hard dependency on oracle jre 8 so one could try other oracle java versions. I reverted the dependency and RUN_CMD so this app will always launch with oracle jre regardless of archlinux-java default.

gdkags commented on 2016-11-06 12:34

@wilga, thank you for changing it, but I was unaware that oracles jre/jdk was mandatory.

I guess I will have to ask you to revert the changes, since I don't see any sane solution that will not result in either having you work around this or having other users of the package suffer from it.

I will just work around the issues I have for myself, I guess that would be way easier for everybody involved.
The only problem I had was, that I did not want to download the jre, when I already have the jdk installed, but that is way easier to fix for me, than others having to work around this.

I'm sorry for the inconvenience!

biosin commented on 2016-11-02 13:09

Why did you change the RUN_CMD? Now it executes with java-8-openjdk which is my default archlinux-java, and an error comes up that it's not compatible with openjdk.

What should I do now to launch it with oracle jre?

wilga commented on 2016-11-01 18:06

@gdkags:

1. changed to java-runtime - but the app still requires oracle jre to run. it does a runtime check and exits with an error if you're using openjdk. can't fix this since it is closed source.
2. done

gdkags commented on 2016-10-26 11:33

I have two requests:

1. change jre dependency to java-runtime-common
2. change the patch file to RUN_CMD=/usr/bin/java …

thank you!

fabian commented on 2016-08-21 11:54

A while ago I used Fedora with Gnome 3, where I could use bwsyncandshare through their rpm-package.
Now on arch also with Gnome 3 I was happy to find this package, but it doesn't seem to integrate as fine.
There's a constant syncing-icon on the top left and a black square in the legacy icon bar. I guess there's not much to be done by users as it uses gtk2 or am I wrong there?
I'm relatively new to Arch including makepkg and the AUR and want to learn about how everything works and how I can contribute. Can you please describe how you created this package or which documentation you used to create it?

Regards