Package Details: cabal-static 3.4.0.0-2

Git Clone URL: https://aur.archlinux.org/cabal-static.git (read-only, click to copy)
Package Base: cabal-static
Description: The command-line interface for Cabal and Hackage. Statically linked.
Upstream URL: https://hackage.haskell.org/package/cabal-install
Licenses: custom:BSD3
Conflicts: cabal-install
Provides: cabal-install
Submitter: nshepperd
Maintainer: nshepperd
Last Packager: nshepperd
Votes: 6
Popularity: 0.000066
First Submitted: 2017-10-28 15:43 (UTC)
Last Updated: 2021-07-06 16:51 (UTC)

Required by (36)

Sources (4)

Latest Comments

1 2 3 Next › Last »

pogmat commented on 2022-02-20 13:03 (UTC)

When installing with an AUR helper or manually I got

  error: missing package metadata in cabal-install-3.4.0.0.tar.gz
  error: 'cabal-install-3.4.0.0.tar.gz': invalid or corrupted package

mipi commented on 2021-10-29 04:28 (UTC)

A build plan for GHC 9.0.1 would be nice, indeed.

favonia commented on 2021-10-21 14:57 (UTC)

A build plan for GHC 9.0.1 would be nice.

nshepperd commented on 2020-05-15 21:40 (UTC)

I pushed a release update to patch 3.2.0.0 for ghc-8.8 and 8.10. It builds on my ghc-8.10 machine now.

nshepperd commented on 2020-05-15 20:13 (UTC)

@xuanruiqi: Hm, I couldn't reproduce that earlier, but I do get that same error now. It looks like the bootstrap script hardcodes HTTP_VER="4000.3.12". I'll try manually updating that and maybe patching the script...

Now that arch has ghc 8.10 we also have a problem that cabal-install has upper bound of base <4.14. Looks like there might be some patches needed for that too.

xuanruiqi commented on 2020-05-03 13:50 (UTC)

@nshepperd: would you mind checking and confirming that this package indeed builds properly? I'm still having the same bug with HTTP, even when building in a clean chroot.

xuanruiqi commented on 2020-04-11 09:09 (UTC)

I still get the same bug with HTTP. Seems it somehow just wants me to install HTTP-4000.3.12.

nshepperd commented on 2020-04-08 21:50 (UTC)

Updated to 3.2.0.0 which should be compatible with ghc-8.8.

yodaembedding commented on 2020-03-16 10:44 (UTC) (edited on 2020-03-16 10:45 (UTC) by yodaembedding)

I tried installing in a clean chroot. But according to https://github.com/haskell/cabal/issues/6327, it looks like cabal 3.0.0.0 is currently incompatible with the latest ghc (8.8.3) and requires an older version like 8.6.5.

Configuring HTTP-4000.3.12...
Setup: Encountered missing or private dependencies:
base >=4.3.0.0 && <4.13


Error during cabal-install bootstrap:
Configuring the HTTP package failed.
==> ERROR: Build failed, check /mnt/data/tmp/chroot64/mulhaq/build

nshepperd commented on 2020-01-31 17:02 (UTC)

Pushed EXTRA_CONFIGURE_OPTS="" as per @watashi, plus some build() code to detect environment file and optionally rename it.