Package Details: caelum 0.6.1-4

Git Clone URL: https://aur.archlinux.org/caelum.git (read-only)
Package Base: caelum
Description: Library for OGRE targeted to help create nice-looking atmospheric effects.
Upstream URL: http://www.ogre3d.org/tikiwiki/Caelum
Licenses: LGPL
Provides: caelum
Submitter: jose1711
Maintainer: None
Last Packager: skybon
Votes: 14
Popularity: 0.000145
First Submitted: 2010-08-05 20:50
Last Updated: 2015-08-23 15:41

Required by (0)

Sources (3)

Latest Comments

ArnaudNux commented on 2015-04-19 00:55

/tmp/src/caelum-0.6.1/main/src/CaelumPlugin.cpp:135:66: erreur: ‘class Caelum::PropScriptResourceManager’ has no member named ‘getByName’
Ogre::ResourcePtr res = getPropScriptResourceManager ()->getByName (objectName, groupName);
^
main/CMakeFiles/Caelum.dir/build.make:54 : la recette pour la cible « main/CMakeFiles/Caelum.dir/src/CaelumPlugin.o » a échouée
make[2]: *** [main/CMakeFiles/Caelum.dir/src/CaelumPlugin.o] Erreur 1
CMakeFiles/Makefile2:137 : la recette pour la cible « main/CMakeFiles/Caelum.dir/all » a échouée
make[1]: *** [main/CMakeFiles/Caelum.dir/all] Erreur 2
Makefile:136 : la recette pour la cible « all » a échouée
make: *** [all] Erreur 2
==> ERREUR : Une erreur s’est produite dans build().
Abandon...

jose1711 commented on 2014-01-04 07:53

disowned

maveric7911 commented on 2014-01-04 01:29

Orphan the project so a someone can fix it since your to busy to do so. Otherwise we will nominate it for removal along with caelum-hg.

jose1711 commented on 2013-12-14 05:22

ymmv, also discussed here: https://mailman.archlinux.org/pipermail/aur-general/2011-January/013142.html

maveric7911 commented on 2013-12-14 00:48

So it doesn't work but because the code is up to date the build isn't out of date... Please... Update the package because it is out of date reguardless of the code.

jose1711 commented on 2013-12-13 20:26

please report upstream (also please do not flag this as out of date as 0.6.1 is the latest version)

maveric7911 commented on 2013-12-01 15:45

WIll not compile

/home/ricec/Downloads/caelum-0.6.1/main/src/CaelumPlugin.cpp: In static member function ‘static Caelum::CaelumPlugin& Caelum::CaelumPlugin::getSingleton()’:
/home/ricec/Downloads/caelum-0.6.1/main/src/CaelumPlugin.cpp:35:5: warning: control reaches end of non-void function [-Wreturn-type]
}
^
main/CMakeFiles/Caelum.dir/build.make:126: recipe for target 'main/CMakeFiles/Caelum.dir/src/CaelumPlugin.o' failed
make[2]: *** [main/CMakeFiles/Caelum.dir/src/CaelumPlugin.o] Error 1
CMakeFiles/Makefile2:140: recipe for target 'main/CMakeFiles/Caelum.dir/all' failed
make[1]: *** [main/CMakeFiles/Caelum.dir/all] Error 2
Makefile:136: recipe for target 'all' failed
make: *** [all] Error 2

jose1711 commented on 2013-01-13 14:03

@egore911: thanks, applied

egore911 commented on 2012-12-28 10:51

To actually have a useful Caelum.pc file you need to apply the following patch:

--- CMakeLists.txt 2012-01-05 16:05:50.000000000 +0100
+++ CMakeLists.txt 2012-12-28 11:12:39.382587068 +0100
@@ -81,6 +81,7 @@
SET(includedir "\${prefix}/include")^M
SET(PACKAGE_NAME "Caelum")^M
SET(PACKAGE_VERSION "${LIB_VERSION}")^M
+SET(LIBNAME "Caelum")^M
^M
# configuration of the config.h and PkgConfig^M
CONFIGURE_FILE(^M

See https://code.google.com/p/caelum/issues/detail?id=12 for details

egore911 commented on 2012-12-28 10:30

To actually have a useful Caelum.pc file you need to apply the following patch:

--- CMakeLists.txt 2012-01-05 16:05:50.000000000 +0100
+++ CMakeLists.txt 2012-12-28 11:12:39.382587068 +0100
@@ -81,6 +81,7 @@
SET(includedir "\${prefix}/include")^M
SET(PACKAGE_NAME "Caelum")^M
SET(PACKAGE_VERSION "${LIB_VERSION}")^M
+SET(LIBNAME "Caelumn")^M
^M
# configuration of the config.h and PkgConfig^M
CONFIGURE_FILE(^M

See https://code.google.com/p/caelum/issues/detail?id=12 for details

jose1711 commented on 2012-03-10 20:44

cannot build:

/home/jose/tarballs/caelum/caelum-0.6.1/main/src/CaelumPlugin.cpp: In static member function ‘static Caelum::CaelumPlugin* Caelum::CaelumPlugin::getSingletonPtr()’:
/home/jose/tarballs/caelum/caelum-0.6.1/main/src/CaelumPlugin.cpp:30:5: warning: control reaches end of non-void function [-Wreturn-type]
make[2]: *** [main/CMakeFiles/Caelum.dir/src/CaelumPlugin.o] Error 1
make[1]: *** [main/CMakeFiles/Caelum.dir/all] Error 2
make: *** [all] Error 2

if anyone has an idea (or can build successfully), please share. otherwise i will report upstream. jose

Svenstaro commented on 2012-03-08 18:29

Please change the dependency to cegui as cegui-ogre was deleted and cegui now ships the appropriate modules.

Svenstaro commented on 2012-03-08 16:39

False: http://code.google.com/p/caelum/downloads/list

Also it has a new upstream maintainer (tdev) by the rigsofrods project.

ZauberParacelsus commented on 2012-03-08 16:38

Caelum hasn't been updated since 2009. Can pretty much consider it a dead project, especially since it's been deprecated by SkyX.

Svenstaro commented on 2012-03-08 16:34

Are you going to update this? If not, please orphan the package.

jose1711 commented on 2011-03-05 12:57

@Synthead: error message will go away as soon as you compile cegui from abs with ogre installed. i will probably create a new pkgbuild - modification of cegui which will contain ogre as a mandatory dependency.

Synthead commented on 2011-03-05 01:53

Please add cegui to the $depends array

Package CEGUI was not found in the pkg-config search path.
Perhaps you should add the directory containing `CEGUI.pc'
to the PKG_CONFIG_PATH environment variable
No package 'CEGUI' found

Synthead commented on 2011-03-05 01:53

Please add cegui to the $depends array

jose1711 commented on 2011-01-30 19:42

@Falcata: modified based on your suggestion, thank you

jose1711 commented on 2011-01-30 19:42

@Falcata: modified based on your suggestion, thank you

ZauberParacelsus commented on 2011-01-30 18:59

I got it to compile by going into the SConstruct file and commenting out these two lines, found near the bottom of the file:

if ceguiDemoEnv:
ceguiDemoEnv.Program('CaelumLab', 'samples/src/CaelumLab.cpp')

ZauberParacelsus commented on 2011-01-30 18:52

According to Caelum's sourceforge page, it was last updated in 2009, so it quite possibly is no longer compatible with the current CEGUI version.

http://sourceforge.net/projects/caelum/

ZauberParacelsus commented on 2011-01-30 18:49

If I had to guess, I'd say that Caelum is expecting a different version of CEGUI, and the current version has a different API.

jose1711 commented on 2011-01-29 16:07

i can reproduce the problem and already asked for help author of caelum. so far, no reply

ZauberParacelsus commented on 2011-01-28 21:55

I attempted to compile it manually from source, and the build still failed, claiming that CEGUI's headers could not be found.

ZauberParacelsus commented on 2011-01-28 14:41

When I attempted to install this, it was claiming it could not find cegui despite cegui being installed.

stativ commented on 2010-11-21 10:31

Please add arch x86_64