Package Details: cairo-compmgr-git 1:0.3.1.57.g416ae1a-3

Git Clone URL: https://aur.archlinux.org/cairo-compmgr-git.git (read-only, click to copy)
Package Base: cairo-compmgr-git
Description: Cairo based composite manager - Git version
Upstream URL: http://cairo-compmgr.tuxfamily.org/
Licenses: LGPL3
Conflicts: cairo-compmgr
Provides: cairo-compmgr
Submitter: None
Maintainer: bidulock
Last Packager: bidulock
Votes: 112
Popularity: 0.000000
First Submitted: 2009-09-11 20:11
Last Updated: 2015-10-21 03:04

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

hplgonzo commented on 2012-10-28 10:04

not working with vala-git (libvala-0.20.so) anymore since last update.
missing possibility to change version in the PKGCONFIG's sed commands from 16 to 20.

cgirard commented on 2012-10-15 21:52

@benjiprod: the git url is already set to: git://git.tuxfamily.org/gitroot/ccm/cairocompmgr.git

benjiprod commented on 2012-10-15 21:46

Doesn't work because the good git name is :

name_git : cairo-compmgr
git://git.tuxfamily.org/gitroot/ccm/cairocompmgr.git

cgirard commented on 2012-05-01 17:14

@buergi: yes right.
@sleepforlife: Could you please run: "LANG=C makepkg -s" and post the output?
@donniezazen: Just remove cairo-compmgr-git before building it.

buergi commented on 2012-05-01 16:46

Note to compile it with vala-git(which provides libvala-0.18.so) just change the version in the PKGCONFIG's sed commands from 16 to 18 and fix the depends-line.

donniezazen commented on 2012-05-01 16:09

Install or build missing dependencies for cairo-compmgr-git:
resolving dependencies...
looking for inter-conflicts...
:: vala and vala-git are in conflict. Remove vala-git? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: cairo-compmgr-git: requires vala-git

sleepforlife commented on 2012-05-01 15:58

cm-timeline.c:1105:8: error: stray '\260' in program
ccm-timeline.c:1105:15: error: expected ';' before 'MEL'
ccm-timeline.c:1105:15: error: stray '\304' in program
ccm-timeline.c:1105:15: error: stray '\260' in program
make[1]: *** [ccm-timeline.lo] Hata 1
make[1]: `/tmp/yaourt-tmp-sleepforlife/aur-cairo-compmgr-git/src/cairocompmgr-build/lib' dizininden çıkılıyor
make: *** [all-recursive] Hata 1
==> HATA: build() içinde bir hata oluştu.
Çıkılıyor...
==> ERROR: Makepkg was unable to build cairo-compmgr-git.
==> Restart building cairo-compmgr-git ? [y/N]
==> ------------------------------------------

cgirard commented on 2012-04-25 15:08

I've read your comments and will update the PKGBUILD ASAP. Switching back to extra/vala seems a good idea.

ewaller commented on 2012-04-25 15:03

I can confirm that on my system, a 64 bit system with testing repositories enabled, that cairo-compmgr does not pkgbuild "Out of the box"

On my system, I used aur/vala-git rather than extra/vala. To link, I required Kulpae's 19 April 12 patch to the PKGBUILD.

Works dandy.

Anonymous comment on 2012-04-24 10:33

Seems to build okay with vala 0.16.0-1 that is in extra now. I changed the sed lines in the PKGBUILD to 0.16 instead of 0.18 and the depends line to vala>=0.16 instead of vala-git.

Also had to make the change to LIBS as suggested by kulpae below, in the PKGBUILD file.