Package Details: cairo-dock-plug-ins-git 3.4.1.r27.a0d3415c2-1

Git Clone URL: https://aur.archlinux.org/cairo-dock-plug-ins-git.git (read-only, click to copy)
Package Base: cairo-dock-plug-ins-git
Description: Plugins for Cairo-Dock
Upstream URL: https://glx-dock.org
Licenses: GPL
Conflicts: cairo-dock-plug-ins
Provides: cairo-dock-plug-ins
Submitter: alucryd
Maintainer: None
Last Packager: haawda
Votes: 38
Popularity: 0.001109
First Submitted: 2015-05-15 11:55 (UTC)
Last Updated: 2020-12-30 15:39 (UTC)

Latest Comments

wolfyrion commented on 2020-11-19 12:06 (UTC)

the weather plugin is not working.

There is a weather folder in the cairo-dock plugins folder but I cannot choose to add it in cairo-dock panel.

fsyy commented on 2020-09-27 10:33 (UTC)

what does this do? mv "${pkgdir}"/usr/lib/{cli,mono}

this line prevents package creation as it says cli/mono not found.

LothaireFR commented on 2019-12-13 08:56 (UTC)

This package hasn't been updated for a long time now...

Techman35 commented on 2015-11-04 00:23 (UTC) (edited on 2015-11-04 00:25 (UTC) by Techman35)

Cant compile - Detecting CXX compile features -- Detecting CXX compile features - done -- checking for module 'gldi=3.4.99.alpha1' -- package 'gldi=3.4.99.alpha1' not found CMake Error at /usr/share/cmake-3.3/Modules/FindPkgConfig.cmake:340 (message): A required package was not found Call Stack (most recent call first): /usr/share/cmake-3.3/Modules/FindPkgConfig.cmake:502 (_pkg_check_modules_internal) CMakeLists.txt:52 (pkg_check_modules) -- Configuring incomplete, errors occurred! See also "/home/arch/Documentos/Descargas/cairo-dock-plug-ins-git/src/cairo-dock-plug-ins/build/CMakeFiles/CMakeOutput.log". ==> ERROR: Se produjo un fallo en build(). Cancelando... Is asking for gldi=3.4.99.alpha1 but i cant find it nowhere

alucryd commented on 2015-05-16 09:00 (UTC)

I should know, I am the maintainer of cairo-dock in [community] :P I changed the optdeps when I changed the package name.

lylambda commented on 2015-05-15 18:48 (UTC)

Well, it's just an "i" ;) Maybe you know, but some depends change recently : ndesk is replaced - dev's message : http://glx-dock.org/bg_topic.php?t=8249&pos=0#mess_84984 - PKGBUILD : https://projects.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/cairo-dock-plug-ins

alucryd commented on 2015-05-15 11:52 (UTC)

Oh god, horrible typo, I'll correct that. Thx for reporting.

lylambda commented on 2015-05-15 11:46 (UTC)

Ok I understand. I ask also that because all package's name use "cairo-dock-plug-ins-..." and this one "cairo-dock-plug[i]-ins" (2 "i"). In fact, it's not really important ^^ Otherwise, thanks for your work !

alucryd commented on 2015-05-06 07:10 (UTC)

No error there, I just didn't have time to merge plugins into plug-ins (to mirror what I did in [community].

lylambda commented on 2015-05-05 23:57 (UTC)

"cairo-dock-plugi-ins-git 3.4.1.r7.88ae103-1" VS "cairo-dock-plugins-git 3.4.0.r9.d54aa04-1" !! Wich one will win the fight ? ;) So I assume it's mistake during a Pkgbuild update ?

lylambda commented on 2015-05-05 23:56 (UTC)

"cairo-dock-plugi-ins-git 3.4.1.r7.88ae103-1" VS "cairo-dock-plugins-git 3.4.0.r9.d54aa04-1" !! Wich one will win the fight ? ;) So I assume it's mistake during a Pkgbuild update ?

alucryd commented on 2015-05-05 08:41 (UTC)

Yup, changed in [community] but forgot to change it here.

lylambda commented on 2015-05-02 18:18 (UTC)

Compilation error : ndesk-dbus-glib is necessary but can't doesn't exist now in Aur or Community. PKGBUILD need to be update with the name of the new package, isn't ?

alucryd commented on 2014-12-24 17:23 (UTC)

Cairo-dock switched to github not long ago. Merging into the git package.

matttbe commented on 2014-05-20 19:13 (UTC)

@zeromemory @hplgonzo: I didn't see this problem, it should not fixed ;-) => rev 3083: https://bazaar.launchpad.net/~cairo-dock-team/cairo-dock-plug-ins/plug-ins/revision/3083 PS: feel free to report any bugs/compilation errors/ideas on Launchpad ;-) => https://bugs.launchpad.net/cairo-dock/+filebug

zeromemory commented on 2014-05-05 14:02 (UTC)

have the same error as hplgonzo. The error is just a warning threated as an error, so we can get rid of it by selecting gcc arguments. Here are the steps: 1) download PKGBUILD file and modify it adding the line gedit ../CMakeLists.txt just before the call to cmake in build() procedure. Currently it's line 55. So you have something like $ mkdir build && cd build $ gedit ../CMakeLists.txt # <--- added line $ cmake .. -DCMAKE_INSTALL_PREFIX=/usr $ make (you can use whatever editor you want in place of gedit) 2) open terminal where PKGBUILD is downloaded and run $ makepkg -i 3) now when the source tree is downloaded, but just before compiling, gedit will popup with CMakeLists.txt open. Locate the statement add_definitions (-std=c99 -Wall -Werror=implicit-function-declaration) # -Wextra (...) and remove '-Werror=implicit-function-declaration', so you have add_definitions (-std=c99 -Wall) # -Wextra (...) save and close. the compilation will start and everything will be fine. Note that this is just an (inelegant) way to get things done, but the real solution is to modify logout applet source code (I think...) Sorry for my bad english :)

hplgonzo commented on 2014-05-01 12:22 (UTC)

Yes, I did Mautz. Also manually checked "Check dependencies" section in stdout for missing modules and built them ... it still fails at building the logout applet, with the same error as linked below.

Mautz commented on 2014-04-30 09:52 (UTC)

It builds fine here...have you tried it again?

hplgonzo commented on 2014-04-27 21:42 (UTC)

Building fails http://pastebin.com/VZukA6RD

lesebas commented on 2013-08-28 19:19 (UTC)

The PKGBUILD is out of date as it don't manage the package version with the pkver function as recommended in VCS PKGBUILD Guideline (https://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines#The_pkgver.28.29_function) Plus, you are using old libs which are not necessary so long and you did not take in charge the session management. Please update or visit this following thread on the official website of cairo-dock : http://www.glx-dock.org/bg_topic.php?t=7069&pos=52

DasMoeh commented on 2012-10-02 02:55 (UTC)

Same problem. http://chakra.sourceforge.net/ccr/diff_view.php?p=cairo-dock-plug-ins&d=applet-host-ias.patch helped.

kalantir commented on 2012-09-26 17:00 (UTC)

I have the same exact problem as nicord. In the file applet-host-ias.c:242 it gives an error about 'cTitle' being undeclared. The original declaration is wrapped inside an #ifdef

einseenai commented on 2012-09-11 11:52 (UTC)

Can't build - http://pastebin.com/aSnNDxhM Also depends on libetpan for me.

commented on 2012-05-25 06:38 (UTC)

[ 77%] Building C object Status-Notifier/src/CMakeFiles/cd-status-notifier.dir/applet-config.c.o [ 77%] Building C object Status-Notifier/src/CMakeFiles/cd-status-notifier.dir/applet-host.c.o [ 78%] Building C object Status-Notifier/src/CMakeFiles/cd-status-notifier.dir/applet-host-kde.c.o [ 78%] Building C object Status-Notifier/src/CMakeFiles/cd-status-notifier.dir/applet-host-ias.c.o /tmp/yaourt-tmp-nicolasrd/aur-cairo-dock-plugins-bzr/src/cairo-dock-plug-ins-build/Status-Notifier/src/applet-host-ias.c: In function ‘on_new_application’: /tmp/yaourt-tmp-nicolasrd/aur-cairo-dock-plugins-bzr/src/cairo-dock-plug-ins-build/Status-Notifier/src/applet-host-ias.c:242:3: erreur: ‘cTitle’ undeclared (first use in this function) /tmp/yaourt-tmp-nicolasrd/aur-cairo-dock-plugins-bzr/src/cairo-dock-plug-ins-build/Status-Notifier/src/applet-host-ias.c:242:3: note: each undeclared identifier is reported only once for each function it appears in make[2]: *** [Status-Notifier/src/CMakeFiles/cd-status-notifier.dir/applet-host-ias.c.o] Erreur 1 make[1]: *** [Status-Notifier/src/CMakeFiles/cd-status-notifier.dir/all] Erreur 2 make: *** [all] Erreur 2

haawda commented on 2011-12-26 21:22 (UTC)

The stable version of this package is named cairo-dock-plug-ins. So I think cairo-dock-plug-ins-bzr would be the correct name of this package. I accidentely uploaded a package of that name to the AUR. Please consider to let some TU merge this packages into cairo-dock-plug-ins-bzr. You can do so by sending a merge request to the aur-general mailing list. The belowmentioned python-patch can also be made by a sed-command. See my PKGBUILD.

Shanto commented on 2011-06-08 20:18 (UTC)

python2.patch: http://pastebin.com/4Y0U0kwR

gaougalos commented on 2011-04-22 10:13 (UTC)

[ 22%] Building C object dialog-rendering/src/CMakeFiles/cd-dialog-rendering.dir/applet-decorator-curly.c.o In file included from /usr/include/gtk-2.0/gtk/gtk.h:233:0, from /usr/include/cairo-dock/cairo-dock/cairo-dock-struct.h:26, from /usr/include/cairo-dock/cairo-dock.h:34, from /home/alex/Downloads/cairo-dock-plugins-bzr/src/cairo-dock-plug-ins-build/dialog-rendering/src/applet-decorator-3Dplane.c:22: /usr/include/gtk-2.0/gtk/gtkitemfactory.h:47:1: warning: function declaration isn’t a prototype [-Wstrict-prototypes] In file included from /usr/include/gtk-2.0/gtk/gtk.h:233:0, from /usr/include/cairo-dock/cairo-dock/cairo-dock-struct.h:26, from /usr/include/cairo-dock/cairo-dock.h:34, from /home/alex/Downloads/cairo-dock-plugins-bzr/src/cairo-dock-plug-ins-build/dialog-rendering/src/applet-decorator-tooltip.c:22: /usr/include/gtk-2.0/gtk/gtkitemfactory.h:47:1: warning: function declaration isn’t a prototype [-Wstrict-prototypes] In file included from /usr/include/gtk-2.0/gtk/gtk.h:233:0, from /usr/include/cairo-dock/cairo-dock/cairo-dock-struct.h:26, from /usr/include/cairo-dock/cairo-dock.h:34, from /home/alex/Downloads/cairo-dock-plugins-bzr/src/cairo-dock-plug-ins-build/dialog-rendering/src/applet-decorator-curly.c:22: /usr/include/gtk-2.0/gtk/gtkitemfactory.h:47:1: warning: function declaration isn’t a prototype [-Wstrict-prototypes] Linking C shared library libcd-dialog-rendering.so [ 22%] Built target cd-dialog-rendering make: *** [all] Error 2 ==> ERROR: A failure occurred in build(). Aborting...

johanbcn commented on 2011-01-30 12:26 (UTC)

Finally figured it out: The status notifier plugin is disabled by default. To enable it, just add the required flag to the cmake command in the AUR file. Example: cmake .. -DCMAKE_INSTALL_PREFIX=/usr -Denable-network-monitor=yes -Denable-doncky=yes -Denable-scooby-do=yes -Denable-status-notifier=yes -Denable-folders=yes || return 1

johanbcn commented on 2011-01-11 21:39 (UTC)

Does anybody know what dependencies are required to build the status-notifier (enhanced systray) plugin? I can't make heads or tails of the CMakeLists file...

samoturk commented on 2010-11-18 11:46 (UTC)

I get this error: In file included from /usr/include/gtk-2.0/gtk/gtk.h:233:0, from /usr/include/cairo-dock/cairo-dock/cairo-dock-struct.h:26, from /usr/include/cairo-dock/cairo-dock.h:34, from /tmp/yaourt-tmp-samo/aur-cairo-dock-plugins-bzr/src/cairo-dock-plug-ins-build/musicPlayer/src/applet-xmms2.c:24: /usr/include/gtk-2.0/gtk/gtkitemfactory.h:47:1: warning: function declaration isn’t a prototype Linking C shared library libcd-musicPlayer.so [ 58%] Built target cd-musicPlayer make: *** [all] Error 2 Aborting...

commented on 2010-11-17 13:09 (UTC)

It's stopped working again: In file included from /usr/include/gtk-2.0/gtk/gtk.h:233:0, from /usr/include/cairo-dock/cairo-dock/cairo-dock-struct.h:26, from /usr/include/cairo-dock/cairo-dock.h:34, from /tmp/yaourt-tmp-liam/aur-cairo-dock-plugins-bzr/src/cairo-dock-plug-ins-build/Animated-icons/src/applet-config.c:21: /usr/include/gtk-2.0/gtk/gtkitemfactory.h:47:1: warning: function declaration isn’t a prototype /tmp/yaourt-tmp-liam/aur-cairo-dock-plugins-bzr/src/cairo-dock-plug-ins-build/Animated-icons/src/applet-config.c: In function ‘read_conf_file’: /tmp/yaourt-tmp-liam/aur-cairo-dock-plugins-bzr/src/cairo-dock-plug-ins-build/Animated-icons/src/applet-config.c:34:18: error: ‘CAIRO_DOCK_NB_GROUPS’ undeclared (first use in this function) /tmp/yaourt-tmp-liam/aur-cairo-dock-plugins-bzr/src/cairo-dock-plug-ins-build/Animated-icons/src/applet-config.c:34:18: note: each undeclared identifier is reported only once for each function it appears in make[2]: *** [Animated-icons/src/CMakeFiles/cd-Animated-icons.dir/applet-config.c.o] Error 1 make[1]: *** [Animated-icons/src/CMakeFiles/cd-Animated-icons.dir/all] Error 2 make: *** [all] Error 2 Aborting... ==> ERROR: Makepkg was unable to build cairo-dock-plugins-bzr.

commented on 2010-10-29 12:28 (UTC)

Connecting server failed :S

zenlord commented on 2010-09-11 15:06 (UTC)

Build succeeded - thx!

Mautz commented on 2010-09-10 13:26 (UTC)

Updated both PKGBUILDS. Thank you ngoone.

Mautz commented on 2010-09-10 13:09 (UTC)

Because i thought the login problems were solved with the changes made to the bzrtrunk variable. I never had any login problems, so i can't verify your problem. But i'll make the changes o the PKGBUILD tomorrow :)

ngoonee commented on 2010-09-10 10:59 (UTC)

Mautz, why aren't you using the PKGBUILD I uploaded for this and cairo-dock-bzr? I still keep getting ssh errors on this current PKGBUILD

Mautz commented on 2010-09-10 08:46 (UTC)

I just got the same error yesterday when building the plugins. Tried it today and everything worked fine.

zenlord commented on 2010-09-10 06:23 (UTC)

Last try for today: build fails at: /usr/include/gtk-2.0/gtk/gtkitemfactory.h:47:1: let op: functie-declaratie is geen prototype Linking C shared library libcd-weather.so Linking C shared library libcd-Toons.so [ 93%] Built target cd-weather [ 93%] Built target cd-Toons make: *** [all] Fout 2 Aborting... error: Build failed

zenlord commented on 2010-09-10 06:22 (UTC)

I guess I should look into disabling some plugins. Now it fails at building cd-weather (94%) before getting to build Xgamma (99%). Looking in the forums of glx-dock, I found this thread: http://www.glx-dock.org/bg_topic.php?t=4613 - the dev suggests using a PKGBUILD that is completely different from this one, and he uses a '.configure' command with switches to disable plugins. I'll try it tomorrow.

hgabreu commented on 2010-09-09 19:06 (UTC)

@Mautz how do I do it? (build without a plugin) Mine is always failing on cd-weather

Mautz commented on 2010-09-09 13:32 (UTC)

Have you tried building the package without the Xgamma plugin? Maybe its broken. I can't check it myself, because i'm on ARCH x86.

zenlord commented on 2010-09-09 06:42 (UTC)

on x64, this package still doesn't build, even after following the advise by megawebmaster (29 july 2010). The package starts building, but fails at 99% with the following error: http://pastebin.com/PuaZ6UTx

ngoonee commented on 2010-08-26 01:28 (UTC)

Sorry, had an error, here's the correct one - http://pastebin.com/zbvsEVEQ

ngoonee commented on 2010-08-26 00:59 (UTC)

The authenticity of host 'bazaar.launchpad.net (91.189.90.11)' can't be established. RSA key fingerprint is 9d:38:3a:63:b1:d5:6f:c4:44:67:53:49:2e:ee:fc:89. Are you sure you want to continue connecting (yes/no)? yes Failed to add the host to the list of known hosts (/root/.ssh/known_hosts). Permission denied (publickey). bzr: ERROR: Connection closed: Unexpected end of message. Please check connectivity and permissions, and report a bug if problems persist. Aborting... ERROR: makepkg exited with an error (512) Need a package() function so that all the bzr operations aren't run as fakeroot. Uploaded a fixed PKGBUILD here http://pastebin.com/BxjWwqJk Based on advise received on cairo-dock forums here http://www.glx-dock.org/bg_topic.php?t=4613

commented on 2010-07-29 18:05 (UTC)

On x86_64 there is problem with compiling this package. File cairo-dock.pc is in /usr/lib64/pkgconfig, package searches it in /usr/lib/pkgconfig. Simply copy file or add /usr/lib64/pkgconfig to PKG_CONFIG_PATH environment variable. I think it could be done somehow by this package or by cairo-dock-bzr package.

Mautz commented on 2010-07-11 18:12 (UTC)

You must first compile and install cairo-dock-bzr.

commented on 2010-07-11 12:16 (UTC)

I get this error: CMake Error at CMakeLists.txt:61 (MESSAGE): warning : version mismatch with the core : 2.2.0-0beta2<>2.2.0-0beta1 I'm using cmake 2.8.2-1

Mautz commented on 2010-07-06 12:09 (UTC)

If you still have problems with the launchpad servers, please tell me so that i can modify the PKGBUILD.

ssri commented on 2010-06-26 16:08 (UTC)

I met the same problem as igor did for the past several days, so I modified the PKGBUILD, which allows one to download the latest build without changing the pkgversion: http://aur.pastebin.com/GsHkiGZP

Mautz commented on 2010-05-13 21:03 (UTC)

Maybe the launchpad servers are under heavy load or experiencing some problems. Just try again a little bit later.

commented on 2010-05-12 15:17 (UTC)

I have been waiting for almost ten hours after the message: ... ... ==> Starting build()... ==> Connecting to the server.... You have not informed bzr of your Launchpad ID, and you must do this to write to Launchpad or access private data. See "bzr help launchpad-login". What is the matter? Is it just a net problem? I am still waiting at the point right now :(

Mautz commented on 2010-05-12 12:21 (UTC)

I never got this error. Maye it's a bug in bzr. https://bugs.launchpad.net/bzr/+bug/572055

commented on 2010-05-12 09:18 (UTC)

I meet the error as : "You have not informed bzr of your Launchpad ID, and you must do this to write to Launchpad or access private data. See "bzr help launchpad-login". bzr: ERROR: [Errno 4] Interrupted system call" What's the matter with this problem? Thanks

Mautz commented on 2010-04-28 00:16 (UTC)

Updated.

commented on 2010-04-15 13:05 (UTC)

Please note that cairo-dock now uses cmake instead of autoconf/automake. Could the PKGBUILD be updated to take that into account?