Package Details: cairo-ubuntu 1.16.0-2

Git Clone URL: https://aur.archlinux.org/cairo-ubuntu.git (read-only)
Package Base: cairo-ubuntu
Description: 2D graphics library with support for multiple output devices (with ubuntu patches)
Upstream URL: https://cairographics.org/
Licenses: MPL, LGPL
Conflicts: cairo
Provides: cairo=1.16.0
Submitter: wonder
Maintainer: el_aur
Last Packager: el_aur
Votes: 327
Popularity: 0.000001
First Submitted: 2008-06-04 11:52
Last Updated: 2019-02-11 16:20

Required by (437)

Sources (5)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

gim commented on 2014-01-10 13:39

Could you add "patch" and "libtool" packages as a dependency, please? Otherwise it fails to build:

aur-cairo-ubuntu/./PKGBUILD: line 32: patch: command not found

autoreconf: running: libtoolize --copy --force
Can't exec "libtoolize": No such file or directory at /usr/share/autoconf/Autom4te/FileUtils.pm line 345, <GEN3> line 5.
autoreconf: failed to run libtoolize: No such file or directory
autoreconf: libtoolize is needed because this package uses Libtool

mikevmk commented on 2013-10-03 06:14

The link to archive changed:
http://archive.ubuntu.com/ubuntu/pool/main/c/cairo/cairo_1.12.16-0ubuntu2.debian.tar.gz

Nordlicht commented on 2013-08-27 00:58

cairo-respect-fontconfig.patch is not available.

Anonymous comment on 2013-05-14 09:09

Never mind...

As always there has been an incorrect usage of fmask in my fstab. Fixing the default fmask solved the permission problem.

Anonymous comment on 2013-05-13 23:07

I'm getting the following error

% makepkg -f -s

/home/mobe/Downloads/cairo-ubuntu/PKGBUILD: Line 42: ./configure: Keine Berechtigung .......... => No permissions
==> FEHLER: Ein Fehler geschah in build().
Breche ab ... => aborting

Line 42 is calling

/home/mobe/Downloads/cairo-ubuntu/src/cairo-1.12.14/configure

which permissions are set to 640. Maybe that's the culprit.


Jib commented on 2013-05-09 21:27

@Ner0: Sorry, my bad!

dflt commented on 2013-05-09 18:20

Ner0, thank you very much for correcting makedeps! :)

Ner0 commented on 2013-05-09 12:33

What do you mean? Download the tarball, everything's there.

Jib commented on 2013-05-09 12:27

1.12-14-2 : Patches are missing from sources.

dflt commented on 2013-05-08 18:44

gtk-doc and valgrind are not required dependencies, please correct it (I'm not sure about libspectre)