Package Details: cairo-ubuntu 1.16.0-2

Git Clone URL: https://aur.archlinux.org/cairo-ubuntu.git (read-only)
Package Base: cairo-ubuntu
Description: 2D graphics library with support for multiple output devices (with ubuntu patches)
Upstream URL: https://cairographics.org/
Licenses: MPL, LGPL
Conflicts: cairo
Provides: cairo=1.16.0
Submitter: wonder
Maintainer: el_aur
Last Packager: el_aur
Votes: 327
Popularity: 0.000001
First Submitted: 2008-06-04 11:52
Last Updated: 2019-02-11 16:20

Required by (437)

Sources (5)

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 10 11 12 13 ... Next › Last »

mityukov commented on 2013-01-12 11:10

affects me too

Anonymous comment on 2013-01-10 08:37

same too

amuroray commented on 2013-01-06 21:55

@ thOth
same here...:(

th0th commented on 2013-01-06 15:10

Build fails with following output:

build/Makefile.am.changelog:57: warning: '%'-style pattern rules are a GNU make extension
Makefile.am:81: 'build/Makefile.am.changelog' included from here
parallel-tests: error: required file 'build/test-driver' not found
parallel-tests: 'automake --add-missing' can install 'test-driver'
/usr/share/automake-1.13/am/ltlibrary.am: warning: 'libcairoboilerplate.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
boilerplate/Makefile.am:3: 'build/Makefile.am.common' included from here
build/Makefile.am.common:5: while processing Libtool library 'libcairoboilerplate.la'
/usr/share/automake-1.13/am/ltlibrary.am: warning: 'libcairoboilerplate_cxx.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
boilerplate/Makefile.am:18: while processing Libtool library 'libcairoboilerplate_cxx.la'
/usr/share/automake-1.13/am/ltlibrary.am: warning: 'libcairoperf.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
perf/Makefile.am:1: 'build/Makefile.am.common' included from here
build/Makefile.am.common:5: while processing Libtool library 'libcairoperf.la'
/usr/share/automake-1.13/am/ltlibrary.am: warning: 'libcairo-perf-micro.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
perf/micro/Makefile.am:5: while processing Libtool library 'libcairo-perf-micro.la'
/usr/share/automake-1.13/am/ltlibrary.am: warning: 'libcairo.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
src/Makefile.am:23: while processing Libtool library 'libcairo.la'
/usr/share/automake-1.13/am/ltlibrary.am: warning: 'libcairo_cxx.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
src/Makefile.am:26: while processing Libtool library 'libcairo_cxx.la'
test/Makefile.am:416: warning: user target 'recheck' defined here ...
/usr/share/automake-1.13/am/check.am: ... overrides Automake target 'recheck' defined here
/usr/share/automake-1.13/am/ltlibrary.am: warning: 'libpdiff.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
test/pdiff/Makefile.am:6: while processing Libtool library 'libpdiff.la'
/usr/share/automake-1.13/am/ltlibrary.am: warning: 'backtrace-symbols.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
util/Makefile.am:1: 'build/Makefile.am.common' included from here
build/Makefile.am.common:5: while processing Libtool library 'backtrace-symbols.la'
/usr/share/automake-1.13/am/ltlibrary.am: warning: 'malloc-stats.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
util/Makefile.am:1: 'build/Makefile.am.common' included from here
build/Makefile.am.common:5: while processing Libtool library 'malloc-stats.la'
/usr/share/automake-1.13/am/ltlibrary.am: warning: 'cairo-fdr.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
util/cairo-fdr/Makefile.am:4: while processing Libtool library 'cairo-fdr.la'
/usr/share/automake-1.13/am/ltlibrary.am: warning: 'libcairo-gobject.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
util/cairo-gobject/Makefile.am:1: while processing Libtool library 'libcairo-gobject.la'
/usr/share/automake-1.13/am/ltlibrary.am: warning: 'libcairo-missing.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
util/cairo-missing/Makefile.am:5: while processing Libtool library 'libcairo-missing.la'
/usr/share/automake-1.13/am/ltlibrary.am: warning: 'libcairo-script-interpreter.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
util/cairo-script/Makefile.am:5: while processing Libtool library 'libcairo-script-interpreter.la'
/usr/share/automake-1.13/am/ltlibrary.am: warning: 'cairo-sphinx.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
util/cairo-sphinx/Makefile.am:3: while processing Libtool library 'cairo-sphinx.la'
/usr/share/automake-1.13/am/ltlibrary.am: warning: 'libcairo-trace.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.13/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
util/cairo-trace/Makefile.am:5: while processing Libtool library 'libcairo-trace.la'
autoreconf: automake failed with exit status: 1
==> ERROR: A failure occurred in build().
Aborting...

Anonymous comment on 2012-12-23 18:05

@ ernetas
the problem is fixed after last updates. I hope a newer version of cairo-ubunto will be released soon.

ernetas commented on 2012-12-02 10:25

Please, don't upgrade until https://bbs.archlinux.org/viewtopic.php?pid=1197937 is fixed! :)

Anonymous comment on 2012-11-20 13:07

Could you change the fontconfig-ubuntu to fontconfig in order to do the people who use infinality package a favour?

wzyboy commented on 2012-11-20 12:14

Shouldn't this be updated with https://launchpad.net/ubuntu/quantal/+source/cairo ?

thestinger commented on 2012-10-30 20:58

This should just depend on libxft now. The patches were merged upstream, and the libxft-ubuntu package no longer had any real patches left so it was deleted - it simply added debian packaging, changelog, etc.

Anonymous comment on 2012-10-20 12:34

Why this relies on fontconfig-ubuntu? People who wants to use infinility don't want fontconfig-ubuntu and I think this is not necessary. I think libxft-ubuntu is also useless.