Package Details: caja-dropbox 1.18.0-1

Git Clone URL: https://aur.archlinux.org/caja-dropbox.git (read-only)
Package Base: caja-dropbox
Description: Dropbox for Linux - Caja extension
Upstream URL: https://github.com/mate-desktop/caja-dropbox
Licenses: GPL, custom:CC-BY-ND-3
Conflicts: caja-dropbox-gtk3
Submitter: lifning
Maintainer: FabioLolix (ThanosApostolou)
Last Packager: vlad
Votes: 35
Popularity: 0.975027
First Submitted: 2012-03-09 23:12
Last Updated: 2017-03-18 20:43

Latest Comments

FabioLolix commented on 2017-08-17 17:58

@koesherbacon

I don't have a mate installation at the moment, but it builds anyway on Cinnamon.

Why are you skipping integrity source check?

==> Download dei sorgenti in corso...
-> Download di caja-dropbox-1.18.0.tar.gz in corso...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 134 0 134 0 0 227 0 --:--:-- --:--:-- --:--:-- 227
100 104k 0 104k 0 0 64094 0 --:--:-- 0:00:01 --:--:-- 124k
==> Validazione di source file con sha1sums...
caja-dropbox-1.18.0.tar.gz ... Verificato
==> Estrazione dei sorgenti in corso...
-> Estrazione di caja-dropbox-1.18.0.tar.gz usando bsdtar in corso...
==> Avvio di prepare() in corso...
aclocal: warning: couldn't open directory 'm4': No such file or directory
libtoolize: putting auxiliary files in '.'.
libtoolize: copying file './ltmain.sh'
libtoolize: putting macros in AC_CONFIG_MACRO_DIRS, 'm4'.
libtoolize: copying file 'm4/libtool.m4'
libtoolize: copying file 'm4/ltoptions.m4'
libtoolize: copying file 'm4/ltsugar.m4'
libtoolize: copying file 'm4/ltversion.m4'
libtoolize: copying file 'm4/lt~obsolete.m4'
configure.ac:20: installing './compile'
configure.ac:21: installing './config.guess'
configure.ac:21: installing './config.sub'
configure.ac:5: installing './install-sh'
configure.ac:5: installing './missing'
src/Makefile.am: installing './depcomp'

koesherbacon commented on 2017-08-17 14:41

I'm having difficulty installing the current 1.18.0 version due to the error "Failed to create 'm4'." Do you have any suggestions for me? Thanks a lot!

Here'sthe output with the error and the additional proof that m4 is installed correctly. (I apologize in advance if I have not properly formatted this cut'n'paste. I'm not sure how to get [ code ] using this comment box.)

====

-> Downloading caja-dropbox-1.18.0.tar.gz...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 134 0 134 0 0 134 0 --:--:-- 0:00:01 --:--:-- 82
100 104k 0 104k 0 0 35709 0 --:--:-- 0:00:03 --:--:-- 66457
==> WARNING: Skipping all source file integrity checks.
==> Extracting sources...
-> Extracting caja-dropbox-1.18.0.tar.gz with bsdtar
==> Starting prepare()...
aclocal: warning: couldn't open directory 'm4': No such file or directory
libtoolize: putting auxiliary files in '.'.
libtoolize: copying file './ltmain.sh'
libtoolize: error: Failed to create 'm4'
autoreconf: libtoolize failed with exit status: 1
==> ERROR: A failure occurred in prepare().
Aborting...
==> ERROR: Makepkg was unable to build caja-dropbox.
==> Restart building caja-dropbox ? [y/N]
ev ~ $


m4-1.4.18-1-x86_64 166.1 KiB 117K/s 00:01 [#############################] 100%
(1/1) checking keys in keyring [#############################] 100%
(1/1) checking package integrity [#############################] 100%
(1/1) loading package files [#############################] 100%
(1/1) checking for file conflicts [#############################] 100%
(1/1) checking available disk space [#############################] 100%
:: Processing package changes...
(1/1) reinstalling m4 [#############################] 100%
:: Running post-transaction hooks...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Updating the info directory file...
ev ~ $

josealb77 commented on 2017-01-04 08:37

checking for CAJA... no
configure: error: Package requirements (libcaja-extension >= 1.17.1) were not met:

Requested 'libcaja-extension >= 1.17.1' but version of libcaja-extension is 1.16.1

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables CAJA_CFLAGS
and CAJA_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
==> ERROR: Se produjo un fallo en build().
Cancelando…
==> ERROR: Makepkg no ha podido compilar caja-dropbox.
==> ¿Reiniciar la compilación de caja-dropbox? [s/N]
==> ------------------------------------------------
==>

There's no libcaja-extension package in Arch neither AUR

Bachsau commented on 2016-12-10 08:26

This package should not include the dropbox client, desktop files and all those stuff. Focus on the caja-plugin instead and leave it up to the user to install dropbox-dist.

Atsuri commented on 2015-09-27 20:35

caja-dropbox (standard, not gtk3!) builds fine on a fresh installation + base-devel + mate (mate + mate-extra). Thank you very much for your efforts, vlad!

vlad commented on 2015-09-06 16:16

>I don't know if there is a way for package to depend on "caja" OR "caja-gtk3"
Unfortunately this is not possible.
Here is new package: https://aur.archlinux.org/packages/caja-dropbox-gtk3/

Mikaela commented on 2015-09-06 13:59

Could you make the PKGBUILD caja-gtk3 too? It works directly on GTK3 otherwise.

I don't know if there is a way for package to depend on "caja" OR "caja-gtk3", but I hope there is and it's possible to do with caja-dropbox.

playenball commented on 2015-02-07 05:20

Here is a PKGBUILD that is working for me

http://pastebin.com/dGR8twRX

playenball commented on 2015-02-04 23:51

I get the following error when trying to build caja-dropbox

CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/sh /tmp/pacaurtmp-playenball/caja-dropbox/src/caja-dropbox-1.8.0/missing aclocal-1.14 -I m4
/tmp/pacaurtmp-playenball/caja-dropbox/src/caja-dropbox-1.8.0/missing: line 81: aclocal-1.14: command not found
WARNING: 'aclocal-1.14' is missing on your system.
You should only need it if you modified 'acinclude.m4' or
'configure.ac' or m4 files included by 'configure.ac'.
The 'aclocal' program is part of the GNU Automake package:
<http://www.gnu.org/software/automake>
It also requires GNU Autoconf, GNU m4 and Perl in order to run:
<http://www.gnu.org/software/autoconf>
<http://www.gnu.org/software/m4/>
<http://www.perl.org/>
Makefile:398: recipe for target 'aclocal.m4' failed
make: *** [aclocal.m4] Error 127

Any ideas?

corrosiontears commented on 2015-01-30 13:28

Reporting error during compilation.

corrosiontears commented on 2015-01-30 13:27

Error on compilation for me, guys.

lifning commented on 2013-08-29 03:18

Hi iroha, thanks for the heads-up. I think I will be disowning this package, since I no longer use MATE. Feel free to adopt it! :)

julian.carpenter commented on 2013-08-26 20:56

hi, it probably would be a good idea to change the source for that to the official github site: https://github.com/mate-desktop/caja-dropbox
or for example here: https://github.com/mate-desktop/archlinux-packages/tree/master/caja-dropbox

i don't know how up-to-date this launchpad site is ...
thanks !

lifning commented on 2012-07-08 18:28

Updated. Cheers

tea commented on 2012-07-08 18:03

Yep. Replace makedepend 'docutils' with 'python2-docutils'.

tea commented on 2012-07-08 17:41

Dependency docutils doesn't exist, apparently.