Package Details: cambalache-git 0.8.1.r204.g2f601c6-1

Git Clone URL: https://aur.archlinux.org/cambalache-git.git (read-only, click to copy)
Package Base: cambalache-git
Description: A new RAD tool for Gtk 4 and 3 with a clear MVC design and data model first philosophy
Upstream URL: https://gitlab.gnome.org/jpu/cambalache
Keywords: gtk
Licenses: LGPL
Conflicts: cambalache
Provides: cambalache
Submitter: Prince781
Maintainer: None
Last Packager: Prince781
Votes: 4
Popularity: 0.000536
First Submitted: 2021-07-22 00:17 (UTC)
Last Updated: 2022-05-14 05:03 (UTC)

Latest Comments

1 2 Next › Last »

SilverRainZ commented on 2023-05-19 17:24 (UTC)

Adding a webkitgtk-6.0 dep (no version 2) seems to fix this issue. cc @wildwestrom

ref: https://github.com/archlinuxcn/repo/commit/d9ff4b41c9f98eefc7acfd91e82ce50b71d59b75

wildwestrom commented on 2022-12-08 13:29 (UTC) (edited on 2022-12-08 13:29 (UTC) by wildwestrom)

This isn't compiling for me. Says it's missing WebKit. Not sure how to remedy the situation. The dependency was added here at fc1e715f.

Message: Python module WebKit2 >= 2.32.0 found: YES 2.38.2 4.1
Message: Python module WebKit >= 2.32.0 found: NO  6.0

cambalache/meson.build:72:0: ERROR: Assert failed: One or more required modules where not found

AlterEigo commented on 2022-11-23 13:27 (UTC)

gobject-introspection is also needed for compiling (can install from pacman)

DeedleFake commented on 2022-09-16 01:07 (UTC) (edited on 2022-09-16 01:07 (UTC) by DeedleFake)

FYI, if anyone's having issues with the UI preview not displaying, it's because you need to install the webkit2gtk-5.0 package.

p3732 commented on 2022-09-03 13:03 (UTC)

'cmake' is not necessary in makedependens, project is (now?) using meson.

wildwestrom commented on 2022-08-01 20:27 (UTC)

Something is wrong with this package, as when I install either cambalache-git or cambalache, I get the following:

Traceback (most recent call last):
  File "/usr/bin/cambalache", line 40, in <module>
    from cambalache.app import CmbApplication
  File "/home/main/.local/lib/python3.10/site-packages/cambalache/__init__.py", line 41, in <module>
    resource = Gio.Resource.load(os.path.join(pkgdatadir, 'cambalache.gresource'))
gi.repository.GLib.GError: g-file-error-quark: Failed to open file “/home/main/.local/share/cambalache/cambalache.gresource”: open() failed: No such file or directory (4)

The flatpak still works, but I don't know why it works.

SilverRainZ commented on 2022-07-21 12:47 (UTC)

Should add 'gtksourceview4' 'libadwaita' 'libhandy' as new dependencies.

See also: https://github.com/archlinuxcn/repo/commit/d1ede468f6c8575ea3c8332ed037b6565fd52a6d

SilverRainZ commented on 2022-04-29 11:30 (UTC)

Should add cmake as makedeps.

See also: https://github.com/archlinuxcn/repo/commit/79de10084d34a1ad29408711731ffbbaf186337c

greyltc commented on 2021-08-09 16:41 (UTC) (edited on 2021-08-09 16:46 (UTC) by greyltc)

There are now :-)

Have you seen https://wiki.archlinux.org/title/VCS_package_guidelines#Git ?

I think your pkgver is missing an r

Prince781 commented on 2021-08-07 15:52 (UTC)

There are no tags yet, so the version number comes from the meson.build file.