Package Details: camlp5-transitional 7.07-1

Git Clone URL: https://aur.archlinux.org/camlp5-transitional.git (read-only)
Package Base: camlp5-transitional
Description: A preprocessor-pretty-printer of OCaml. (transitional)
Upstream URL: https://camlp5.github.io/
Licenses: BSD
Conflicts: camlp5
Submitter: td123
Maintainer: wilbowma
Last Packager: wilbowma
Votes: 21
Popularity: 0.000002
First Submitted: 2012-04-09 20:52
Last Updated: 2019-03-19 21:56

Latest Comments

wilbowma commented on 2016-12-01 04:13

@noobman, updated, thanks!

noobman commented on 2016-11-25 13:38

Sorry: the compatibility with ocaml version "4.04.0"
is not yet implemented. Please report.
Information: directory ocaml_stuff/4.04.0 is missing.

wilbowma commented on 2016-01-25 22:23

@pyropeter I cannot reproduce that error. What version of ocaml do you have?

pyropeter commented on 2016-01-03 02:56

cd ../main; make optp5 CAMLP5OPT=../meta/camlp5r.opt CAMLP5M="-I ../meta pa_r.cmx pa_rp.cmx pr_dump.cmx"
make[3]: Entering directory '/$foo/camlp5-transitional/src/camlp5-6.14/main'
ocamlopt.opt ../odyl/odyl.cmxa camlp5.cmxa -I ../meta pa_r.cmx pa_rp.cmx pr_dump.cmx ../odyl/odyl.cmx -linkall -o ../meta/camlp5r.opt
/usr/bin/ld: /usr/lib/ocaml/libasmrun.a(roots.o): relocation R_X86_64_32 against `caml_frametable' can not be used when making a shared object; recompile with -fPIC
/usr/lib/ocaml/libasmrun.a: error adding symbols: Bad value
collect2: error: ld returned 1 exit status
File "caml_startup", line 1:
Error: Error during linking
Makefile:28: recipe for target '../meta/camlp5r.opt' failed
make[3]: *** [../meta/camlp5r.opt] Error 2
make[3]: Leaving directory '/$foo/camlp5-transitional/src/camlp5-6.14/main'
Makefile:23: recipe for target 'camlp5r.opt' failed

lonaowna commented on 2015-09-01 20:58

Won't build:

Sorry: the compatibility with ocaml version "4.02.3"
is not yet implemented. Please report.

wilbowma commented on 2015-01-20 01:50

Here is an updated PKGBUILD, with options=('staticlibs'), since ssreflect requires this: http://sprunge.us/SeCc

zorun commented on 2014-12-25 00:59

Does not compile with version 4.02.1 of OCaml, please update this package to camlp5 6.12.