Package Details: camlp5 6.14-1

Git Clone URL: https://aur.archlinux.org/camlp5.git (read-only)
Package Base: camlp5
Description: A preprocessor-pretty-printer of OCaml.
Upstream URL: http://camlp5.gforge.inria.fr/
Licenses: BSD
Conflicts: camlp5-transitional
Submitter: td123
Maintainer: mgrabovsky
Last Packager: mgrabovsky
Votes: 11
Popularity: 0.000000
First Submitted: 2012-04-09 20:49
Last Updated: 2015-08-18 14:59

Dependencies (1)

Required by (1)

Sources (1)

Latest Comments

gciruelos commented on 2014-10-13 00:22

diff --git a/PKGBUILD.old b/PKGBUILD
index 5c39ca6..ee3ee71 100644
--- a/PKGBUILD.old
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Massimiliano Brocchini <brocchini@netseven.it>

pkgname=camlp5
-_baseversion=6.11
+_baseversion=6.12
_patchlevel=0
#pkgver=${_baseversion}.${_patchlevel}
pkgver=${_baseversion}
@@ -48,4 +48,4 @@ package() {
${pkgdir}/usr/share/licenses/camlp5/LICENSE
}

-md5sums=('5bd3d0e8a32d762b28107caef631f860')
+md5sums=('d49d30b62396b7285f3d609ac90c3fe5')

jmnotin commented on 2013-12-17 16:19

Some files (like gramlib.a) are not included by makepkg and yet are needed in some cases. Adding the line:

options=('staticlibs')

in PKGBUILD solves the problem. This remark apply to camlp5-transitional too.

oriba commented on 2013-05-20 13:26

diff --git a/PKGBUILD b/PKGBUILD
index c2832af..cf3f98d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Massimiliano Brocchini <brocchini@netseven.it>

pkgname=camlp5
-_baseversion=6.08
+_baseversion=6.09
_patchlevel=0
#pkgver=${_baseversion}.${_patchlevel}
pkgver=${_baseversion}
@@ -48,4 +48,4 @@ package() {
${pkgdir}/usr/share/licenses/camlp5/LICENSE
}

-md5sums=('fa2c46da8997982bd2354463e83446e9')
+md5sums=('1006190248b98f72a2e661cdfacc6314')

eagletmt commented on 2012-10-13 17:12

@xrchz Thanks, I've updated it.

xrchz commented on 2012-10-13 13:47

simply bumping the _baseversion to 6.07 and _patchlevel to 1 seems to work.

xrchz commented on 2012-10-03 08:37

apparently this needs to be built against the same version of ocaml you're using in order to use it. so may I request that you make a build for ocaml 4.00.0?