Package Details: cantarell-static-fonts 0.303.1-3

Git Clone URL: https://aur.archlinux.org/cantarell-static-fonts.git (read-only, click to copy)
Package Base: cantarell-static-fonts
Description: Humanist sans serif font - static fonts
Upstream URL: https://gitlab.gnome.org/GNOME/cantarell-fonts
Licenses: custom:SIL
Conflicts: cantarell-fonts
Provides: cantarell-fonts
Submitter: json
Maintainer: json
Last Packager: json
Votes: 2
Popularity: 0.003699
First Submitted: 2022-03-16 20:19 (UTC)
Last Updated: 2024-05-21 17:33 (UTC)

Dependencies (3)

Required by (41)

Sources (2)

Latest Comments

json commented on 2024-05-21 17:36 (UTC)

Thanks for letting me know. I included a mechanism to automatically update dependencies with new python releases. This should fix your issue and make the build process more robust.

BudgieUser commented on 2024-05-17 15:36 (UTC)

Seems like again I have problems to build:

https://pastebin.com/raw/wrgfZYEj

json commented on 2023-07-24 21:06 (UTC) (edited on 2023-07-24 21:07 (UTC) by json)

Thanks for your comment. This is related to some broken dependencies with Python 3.11 an has been fixed upstream. I applied this patch and the package should now build again.

BudgieUser commented on 2023-07-08 14:38 (UTC)

I used this package in the past to get rid of blurry bold fonts in KDE Apps such as MusicBrainz Picard and the Nextcloud desktop client. Unfortunately not being able to build this right now

src/pyclipper/_pyclipper.cpp:212:12: fatal error: longintrepr.h: No such file or directory
        212 |   #include "longintrepr.h"
            |            ^~~~~~~~~~~~~~~
      compilation terminated.
      error: command '/usr/bin/gcc' failed with exit code 1
      [end of output]

  note: This error originates from a subprocess, and is likely not a problem with pip.
  ERROR: Failed building wheel for pyclipper
Successfully built psautohint
Failed to build pyclipper
ERROR: Could not build wheels for pyclipper, which is required to install pyproject.toml-based projects

[notice] A new release of pip available: 22.3.1 -> 23.1.2
[notice] To update, run: pip install --upgrade pip
==> ERROR: A failure occurred in build().
    Aborting...
error: failed to build 'cantarell-static-fonts-0.303.1-1':
error: packages failed to build: cantarell-static-fonts-0.303.1-1

pacifi5t commented on 2022-04-12 23:11 (UTC)

This package fixes ugly bold fonts in Qt apps. Thank you a lot!

json commented on 2022-03-16 20:31 (UTC)

This package builds static variants of the Cantarell font for old applications that are not fully compatible with the variable font. Such applications include Zotero (https://forums.zotero.org/discussion/94927/) or EMACS (FS#72212)