Package Details: cardano-sl 1.3.0-1

Git Clone URL: https://aur.archlinux.org/cardano-sl.git (read-only)
Package Base: cardano-sl
Description: Cryptographic currency implementing Ouroboros PoS protocol
Upstream URL: https://github.com/input-output-hk/cardano-sl/
Licenses: MIT
Submitter: tensor5
Maintainer: tensor5
Last Packager: tensor5
Votes: 7
Popularity: 0.184294
First Submitted: 2017-12-02 17:14
Last Updated: 2018-08-10 15:25

Latest Comments

1 2 3 Next › Last »

Gio commented on 2018-06-23 10:48

HI. I was trying to install the latest version (19.04.2018) but Pacman during the building process stopped suddenly outputting the following error:

^~~~~~~~~~~~

CC shared-objects/memtable/vectorrep.o CC shared-objects/memtable/write_buffer_manager.o cc1plus: all warnings being treated as errors make: [Makefile:639: shared-objects/memtable/skiplistrep.o] Error 1 make: Waiting for unfinished jobs.... ==> ERROR: A failure occurred in build(). Aborting...

Alko89 commented on 2018-05-04 15:38

Hi

I want to know how can I run cardano as headless? I Installed cardano-sl and want to just run the blockchain without the wallet. Can someone help me how to start the node?

tanzeelrana commented on 2018-02-19 03:06

pacman -Qi cardano-sl error: package 'cardano-sl' was not found

tensor5 commented on 2018-02-12 15:28

rocksdb is already a dependecy.

[nicola@archlinux ~]$ pacman -Qi cardano-sl
Name            : cardano-sl
Version         : 1.0.3-2
Description     : Cryptographic currency implementing Ouroboros PoS protocol
Architecture    : x86_64
URL             : <https://github.com/input-output-hk/cardano-sl/>
Licenses        : MIT
Groups          : None
Provides        : None
Depends On      : gmp  openssl  rocksdb
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 688.10 MiB
Packager        : Unknown Packager
Build Date      : Tue 19 Dec 2017 08:02:15 PM CET
Install Date    : Wed 20 Dec 2017 10:14:11 AM CET
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : None

goetzc commented on 2018-02-11 19:40

As the preview comment mentions, rocksdb (found in the AUR) is a dependency of rocksdb-haskell, please add it to the deps array.

matiwinnetou commented on 2018-01-29 10:48

This worked fine for me but one needs to have lots of space in tmpfs... and obviously install rocksdb before.

emes commented on 2018-01-23 20:09

I'm getting the following error while building. Full system upgrade didn't help.

--  While building custom Setup.hs for package cardano-sl-db-1.0.3 using:
  /home/emes/.stack/setup-exe-cache/x86_64-linux-tinfo6/Cabal-simple_mPHDZzAJ_1.24.2.0_ghc-8.0.2 --builddir=.stack-work/dist/x86_64-linux-tinfo6/Cabal-1.24.2.0 build lib:cardano-sl-db --ghc-options " -ddump-hi -ddump-to-file"
Process exited with code: ExitFailure 1
Logs have been written to: /home/emes/builds/cardano-sl/src/cardano-sl/.stack-work/logs/cardano-sl-db-1.0.3.log

Configuring cardano-sl-db-1.0.3...
Preprocessing library cardano-sl-db-1.0.3...
[ 1 of 13] Compiling Pos.DB.Error     ( Pos/DB/Error.hs, .stack-work/dist/x86_64-linux-tinfo6/Cabal-1.24.2.0/build/Pos/DB/Error.o )
[ 2 of 13] Compiling Pos.DB.Class     ( Pos/DB/Class.hs, .stack-work/dist/x86_64-linux-tinfo6/Cabal-1.24.2.0/build/Pos/DB/Class.o )
[ 3 of 13] Compiling Pos.DB.Functions ( Pos/DB/Functions.hs, .stack-work/dist/x86_64-linux-tinfo6/Cabal-1.24.2.0/build/Pos/DB/Functions.o )
[ 4 of 13] Compiling Pos.DB.Misc.Common ( Pos/DB/Misc/Common.hs, .stack-work/dist/x86_64-linux-tinfo6/Cabal-1.24.2.0/build/Pos/DB/Misc/Common.o )
[ 5 of 13] Compiling Pos.DB.Pure      ( Pos/DB/Pure.hs, .stack-work/dist/x86_64-linux-tinfo6/Cabal-1.24.2.0/build/Pos/DB/Pure.o )
<command line>: can't load .so/.DLL for: /home/emes/builds/cardano-sl/src/cardano-sl/.stack-work/install/x86_64-linux-tinfo6/lts-9.1/8.0.2/lib/x86_64-linux-ghc-8.0.2/libHSrocksdb-haskell-1.0.0-ASh627zSIahH8QxTbLrgnb-ghc8.0.2.so (/usr/lib/libjemalloc.so.2: cannot allocate memory in static TLS block)

gwpl commented on 2018-01-11 15:18

Today I am trying to compile and run it again. I had again to downgrade jemalloc to 4.5.0. Could you add hard dependency on version , i.e. that this package require jemalloc with version <=4.5.0 ? (how to make one, in gist I linked earlier: https://gist.github.com/gwpl/0e4a3ae4d4e21e429b324808cdca3e46 )

tensor5 commented on 2018-01-06 11:51

@emes, rocksdb is already a dependency.

emes commented on 2018-01-05 23:19

Please add rocksdb to deps, it's required.