Package Details: carla-git 1:2.3.0.RC2.r0.g2294a5c86-1

Git Clone URL: https://aur.archlinux.org/carla-git.git (read-only, click to copy)
Package Base: carla-git
Description: Audio Plugin Host
Upstream URL: http://kxstudio.sf.net/carla
Keywords: daw host plugin vst2 vst3
Licenses: GPL2+
Conflicts: carla
Provides: carla
Submitter: cocreature
Maintainer: SpotlightKid (Joermungand)
Last Packager: SpotlightKid
Votes: 23
Popularity: 0.161915
First Submitted: 2013-10-11 12:29
Last Updated: 2021-03-17 22:08

Required by (12)

Sources (1)

Pinned Comments

SpotlightKid commented on 2021-03-17 22:10

Heads up, everybody! I've switched this package back from building the "develop" branch to the "main" branch again, since the "develop" branch is now gone. If you re-use your package build directories, you might have to delete the old "carla" repo directory and you also may need to delete the "src" directory before re-building.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

falkTX commented on 2017-11-23 22:24

I have removed the experimental plugins from latest git.
Please update the PKGBUILD for it.

Changes are:
1. remove zita-convolver, zita-resampler, clxclient, clthreads dependencies
2. remove EXPERIMENTAL_PLUGINS=true from the make steps

Thank you.

Shirx commented on 2017-11-22 20:15

Great, thanks! I'll be less lazy next time :)

SpotlightKid commented on 2017-11-22 20:09

Yes, just built the package successfully myself.

funkmuscle commented on 2017-11-22 20:08

I reported upstream and falkTX fixed. it builds now.

SpotlightKid commented on 2017-11-21 15:15

This is a git package. Breakages from time to time are to be expected ;)

Better to report these upstream: https://github.com/falkTX/Carla/issues

There are some changes going on right now in the repository to add BSD compatibility, which may have introduced build failures. I'd just wait for things to settle down for a few days...

Shirx commented on 2017-11-21 15:11

The build() fails with a compilation error:
../includes/CarlaNativeJack.h:272:16: error: ‘ENODATA’ was not declared in this scope
return ENODATA;

When EXPERIMENTAL_PLUGINS=false is set in the PKGBUILD, it compiles fine, but probably misses the compatibility to the carla-bridges-win.

SpotlightKid commented on 2017-07-21 18:20

Actually, carla seems to work fine without libQtSvg.so and I can import from PyQt5.QtSvg in python.

Do you get any actual errors without it?

SpotlightKid commented on 2017-07-21 18:00

Damn, I thought it was covered by python-pyqt5, but it's only a opt/makedep there.

lysergia commented on 2017-07-21 16:56

Also needs `qt5-svg`

SpotlightKid commented on 2017-07-20 23:02

You're right. Not sure why I missed that. Fixed.