Package Details: cartaodecidadao 3.0.13-2

Git Clone URL: https://aur.archlinux.org/cartaodecidadao.git (read-only)
Package Base: cartaodecidadao
Description: Portuguese Citizen Card Application
Upstream URL: http://www.cartaodecidadao.pt/
Licenses: GPL2, LGPL3, custom:EUPL
Submitter: r3pek
Maintainer: r3pek
Last Packager: r3pek
Votes: 7
Popularity: 0.071764
First Submitted: 2015-10-18 03:14
Last Updated: 2018-10-17 23:52

Latest Comments

1 2 3 4 Next › Last »

cvalente commented on 2018-11-15 02:56

The package for the dependency xml-security-c-ria is FUBAR. The source file can't even be found. On top of that it conflicts with the newer version implying some other packages can't actually be installed.

To fix that I've changed this package to compile statically against xml-security-c-1.7.3

One less deprecated dependency to worry about.

Of course this should ultimately be solved by the devs by using the newer APIs (same for openssl-1.0), but I won't be holding my breath.

Here is the patch.

https://hastebin.com/uhudelizih.diff

knaick commented on 2018-10-17 20:13

@r3pek tried to install the version 2.0.31-1. My current Java version is 10.0.2(openjdk 10.0.2 2018-07-17).

I get a awesome while installing on my system :

"Java version (0.0.2) must higher than 1.4.2 ==> ERROR: A failure occurred in build(). Aborting... Error making: cartaodecidadao "

Quatro commented on 2018-10-03 13:08

Also missing extra/qt5-graphicaleffects dep

Quatro commented on 2018-10-03 10:41

https://hastebin.com/uhutatupaw.pl

Patch para o fix para java version ^

ArchGalileu commented on 2018-09-13 17:18

@Mccurly

Perfect ;) hehehe

Thank you ;)

Best regards ArchGalileu

Mccurly commented on 2018-09-07 19:49

Hi, for those with a Java version higher than 9.x.x you should go to the configure file on the src/eidmw/ directory (line 124) and add a plus sign to the first "[0-9]" group which should look the same as the others (REGEX expression for considering two digits) "[0-9]+"

Consider please to change the src of that code upstream as well.

Aside from that, in here I cannot upgrade because there's an undefined reference to a function (eIDMW...) at making eidguiV2...

(...EDIT...)

I noticed there were other comment pages for this package (... yes I am that distracted...). Because of that I managed to update/install the latest cartaodecidadao.

Followed @r3pek advice that he had given to @Joaoreis. Since the compilation errored out at the linking stage, (the same sort of error as with @Joaoreis)I uninstalled previous version and it went through successfully.

I suggest again (for those who are getting verification errors with the Java Version, when you have installed a java version higher than 9.xx.xx) that you access the temporary folder where the building of the source occurs, and go down to the respective "cartaodecidadao/src/eidmw/configure" file and change its line #124 from "$javaVer =~ m/([0-9]).([0-9]+).([0-9]+)/;" to "$javaVer =~ m/([0-9]+).([0-9]+).([0-9]+)/;" (add the plus sign to the first "[0-9]" group, that becomes "[0-9]+". Maybe you will be able to compile and install.

tiago.casal commented on 2018-08-31 18:30

@ArchGalileu e @r3pek

It's the upstream code, I'm working on it... I've been having this issue for some time now, I usually place this little patch on line 129 of the configure file to just bypass version check:

my $javaVerII = $javaVerI;

r3pek commented on 2018-08-31 18:09

@ArchGalileu

$ archlinux-java status Available Java environments: java-7-openjdk java-8-openjdk (default)

WFM with java-8-openjdk

ArchGalileu commented on 2018-08-31 18:05

Already tried multiple java sources but nothing... always this error

Java version (0.0.2) must higher than 1.4.2

Available Java environments: java-10-jre/jre (default) java-10-openjdk java-8-openjdk/jre

Best regards ArchGalileu

r3pek commented on 2018-08-31 13:18

@abred Sim, já tinha reparado no QIcon ;)

Estou a tratar de trazer a versão 3.X para o AUR (que para já, não compila).