Package Details: cartaodecidadao 2.4.6.5238-1

Git Clone URL: https://aur.archlinux.org/cartaodecidadao.git (read-only)
Package Base: cartaodecidadao
Description: Portuguese Citizen Card Application
Upstream URL: http://www.cartaodecidadao.pt/
Licenses: GPL2, LGPL3, custom:EUPL
Submitter: r3pek
Maintainer: r3pek
Last Packager: r3pek
Votes: 3
Popularity: 0.000045
First Submitted: 2015-10-18 03:14
Last Updated: 2017-11-25 19:48

Latest Comments

R00KIE commented on 2017-11-06 13:30

Penso que é necessário adicionar java-environment as makedepends, caso contrário não dá para compilar o programa.

==> Starting build()...
Use of uninitialized value $distro in string eq at ./configure line 142.
which: no javac in (/usr/local/sbin:/usr/local/bin:/usr/bin:/extra/scripts:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl)
java not found, please adjust PATH: export PATH=<path_to_javac>:$PATH
==> ERROR: A failure occurred in build().

tiago.casal commented on 2017-11-03 03:55

@r3pek
aqui compila e instala perfeitamente.
o erro que tenho é depois de instalar, ao tentar correr a aplicação.

r3pek commented on 2017-11-01 22:14

@Joaoreis
Desinstala a versão antiga. Por alguma razão que não consegui testar, o linker está a ir buscar a versão instalada em vez da nova que vai instalar, daí esse erro

joaosreis commented on 2017-11-01 21:35

Tenho este erro ao tentar atualizar para a versão 2.4.4.5176:

/usr/lib/libpteidlib.so: undefined reference to `eIDMW::APL_Card::SignClose(eIDMW::PDFSignature*, eIDMW::CByteArray)'
collect2: error: ld returned 1 exit status
make[1]: *** [Makefile:405: ../bin/pteidgui] Error 1
make[1]: Leaving directory '/home/joaosreis/cartaodecidadao/src/eidmw/eidgui'
make: *** [Makefile:486: sub-eidgui-make_first-ordered] Error 2

r3pek commented on 2017-11-01 19:42

@a36233
actualiza o libxml-security-c

@tiago.casal
Tás a usar algum AUR helper? Tenta eliminar-lhe a cache (se for o pacaur é em ~/.cache/pacaur/)

a36233 commented on 2017-10-31 14:21

Falha-me a fazer o build:
https://pastebin.com/nWQHs5GC

tiago.casal commented on 2017-10-31 06:21

actualizou... continua a dar o mesmo erro do curl openssl 3

tiago.casal commented on 2017-10-29 03:35

getting this error

pteidgui: ../lib/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by /usr/local/bin/../lib/libpteidapplayer.so.2)

bms commented on 2017-09-26 22:20

- makedepends=('swig')
+ makedepends=('swig' 'subversion')

Cumps

paneves commented on 2017-09-25 21:44

'Tá safo. Já instalou.
Obrigado pela ajuda!

r3pek commented on 2017-09-25 21:26

@paneves
Aqui instalou bem. Tenta apagar o que tens em cache: rm -rf ~/.cache/pacaur/cartaodecidadao

paneves commented on 2017-09-25 19:01

Alô:

Ao tentar instalar surge o seguinte erro:

==> Cleaning up...
:: Installing cartaodecidadao package(s)...
:: cartaodecidadao package(s) failed to install.
:: ensure package version does not mismatch between .SRCINFO and PKGBUILD
:: ensure package name has a VCS suffix if this is a devel package

Já verifiquei o .SRCINFO e o PKGBUILD e a versão é a mesma em ambos os ficheiros (2.4.0.4973). Alguma ideia?

r3pek commented on 2017-09-23 20:58

@flacc
Já viste bem o k escreveste?

flacc commented on 2017-09-23 19:58

[flacc@venus ~]$ yaourt -Ss cartaocidadao
[flacc@venus ~]$


Nem aparece para instalar :/

guicale commented on 2017-09-22 17:08

Fica aqui um patch para o PKGBUILD que instala corretamente o programa:
https://pastebin.com/NuqP3BuS

a36233 commented on 2017-09-22 15:46

Adding misc/certs/*.der from eidmw repo to /usr/local/share/certs fixes "Consistência da informação do cartão está comprometida!"

a36233 commented on 2017-09-22 15:32

Consegui instalar com o source abaixo, mas ao ler o cartão dá-me:

APL_CrlDownloadingCache::scanDir "/usr/local/share/certs/" : No such file or directory

Consistência da informação do cartão está comprometida!

a36233 commented on 2017-09-22 15:19

Please update source to:
source=("svn+https://svn.gov.pt/projects/ccidadao/repository/middleware-offline/trunk/_src/eidmw")
or use correct tags

tiago.casal commented on 2017-09-22 14:08

Building cartaodecidadao...
Cloning into 'cartaodecidadao'...
remote: Counting objects: 36, done.
remote: Compressing objects: 100% (35/35), done.
remote: Total 36 (delta 3), reused 31 (delta 1)
Unpacking objects: 100% (36/36), done.
==> Making package: cartaodecidadao 2.4.0.4973-1 (Fri 22 Sep 15:08:18 WEST 2017)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Cloning eidmw svn repo...
svn: E170000: URL 'https://svn.gov.pt/projects/ccidadao/repository/middleware-offline/tags/version2.4.0.4973-4973/source/_src/eidmw' doesn't exist
==> ERROR: Failure while downloading eidmw svn repo
Aborting...

Lasering commented on 2017-07-27 09:53

To be able to use the /usr/lib/pteid_jni/pteidlibj.jar it is necessary to include the following line in the PKGBUILD:

ln -sr ${srcdir}/usr/lib/pteid_jni/libpteidlibj.so.1.61.0 ${srcdir}/usr/lib/pteid_jni/libpteidlibj.so

Because otherwise when doing System.loadLibrary("pteidlibj") in java you would get a UnsatisfiedLinkError.