Package Details: carvel-tools 20220621-1

Git Clone URL: https://aur.archlinux.org/carvel-tools.git (read-only, click to copy)
Package Base: carvel-tools
Description: Set of Carvel (k14s) tools: ytt kbld kapp kwt imgpkg vendir
Upstream URL: https://carvel.dev
Licenses: Apache
Conflicts: imgpkg, kapp, kbld, kwt, vendir, ytt
Provides: imgpkg, kapp, kbld, kwt, vendir, ytt
Submitter: Zebradil
Maintainer: Zebradil
Last Packager: Zebradil
Votes: 2
Popularity: 0.002456
First Submitted: 2020-11-21 23:21 (UTC)
Last Updated: 2022-06-21 11:39 (UTC)

Dependencies (0)

Required by (2)

Sources (9)

Latest Comments

9numbernine9 commented on 2022-05-16 23:10 (UTC)

@Zebradil No problem! Just happened that I was trying to use a feature of the newest kapp and was wondering why it didn't work. :-)

Zebradil commented on 2022-05-16 20:52 (UTC)

@9numbernine9 Updated, thanks for reporting, again :-) Some day I will take some time to automate the process...

9numbernine9 commented on 2022-05-16 19:52 (UTC) (edited on 2022-05-16 19:52 (UTC) by 9numbernine9)

Hello! Would it be possible to update the Carvel tools installed by this package? Several of them have newer versions available than what this package currently provides:

  • kbld 0.33.0
  • kapp 0.47.0
  • imgpkg 0.29.0
  • vendir 0.27.0

Thanks!

techknowlogick commented on 2021-07-29 21:33 (UTC)

Yes, thanks @zebradil!

9numbernine9 commented on 2021-07-29 20:36 (UTC)

Looks good now - thanks for the quick fix @Zebradil !

Zebradil commented on 2021-07-29 19:56 (UTC)

@9numbernine9 thanks for reporting. Fixed.

9numbernine9 commented on 2021-07-29 13:07 (UTC)

Hello @Zebradil - I'm having trouble with the most recent version of this package. It seems like the tools in the package don't seem to actually get installed anywhere that I can find? (e.g. which ytt or even find / -name ytt don't return anything). I installed the package with yay carvel-tools if that matters. Any ideas?

Zebradil commented on 2021-07-19 19:09 (UTC)

@techknowlogick yeah, missed this part. Could you test again?

techknowlogick commented on 2021-07-19 00:23 (UTC)

Thanks @Zebradil for your hard work on this! This mostly worked :) It failed due to the install calls to kbld and such as even though they are excluded in the fetch they have the install calls for the reasons you've mentioned. I've only packaged a few arch packages so I don't know if this is possible, but is it possible to wrap the install calls for the non-arm64 packages in an if x86 then install?

Zebradil commented on 2021-07-18 23:31 (UTC)

Hey @techknowlogick, I updated the packaging script. Can't test it right now. Could you give it a try? Btw, not all tools are available on arm64, only ytt, kapp and vendir.

techknowlogick commented on 2021-06-09 02:34 (UTC)

Carvel tools upstream support linux arm64, could this package too?