Package Details: casadi 3.6.5-3

Git Clone URL: https://aur.archlinux.org/casadi.git (read-only, click to copy)
Package Base: casadi
Description: Symbolic framework for automatic differentiation and numeric optimization
Upstream URL: https://github.com/casadi/casadi
Licenses: LGPL-3.0-only
Submitter: bchretien
Maintainer: Nim65s
Last Packager: Nim65s
Votes: 9
Popularity: 0.26
First Submitted: 2015-12-17 21:47 (UTC)
Last Updated: 2024-06-05 21:02 (UTC)

Latest Comments

1 2 Next › Last »

Nim65s commented on 2024-06-05 21:13 (UTC)

Hi,

I need this, so I adopted and updated it a bit. Everything seems fine for me, both on my daily desktop and in a clean docker.

Feel free to report new issues or ask for more options here :)

greyltc commented on 2024-06-04 19:09 (UTC) (edited on 2024-06-04 19:10 (UTC) by greyltc)

This package seems broken ( undefined symbol: _ZN6casadi10differenceERKSt6vectorINS_2MXESaIS1_EES5 ) I've tried a few things and I haven't managed to figure out how to fix it. I've filed an issue upstream here: https://github.com/casadi/casadi/issues/3712

I've just posted a new alternative package to the AUR, python-casadi-bin that just uses the prebuilt .whl from pypi and that seems to work, so I've removed this broken casadi package from my packages' dependencies in favor of that one.

adsun commented on 2024-06-04 17:00 (UTC)

I'll be disowning this package since I haven't used this package in a long time and I think someone else would be better at maintaining it than me.

adsun commented on 2024-06-04 16:27 (UTC) (edited on 2024-06-04 17:01 (UTC) by adsun)

@pirofti I tried to implement octave support for the casadi package, but it turns out that it requires using a custom-built version of swig that seems to be out of date, otherwise using the system swig results in errors when compiling. I've disowned the package because I haven't used it in a long time, so if you want to, feel free to adopt this package.

greyltc commented on 2024-06-03 23:45 (UTC)

import casadi in python is failing for me with

ImportError: /usr/lib/python3.12/site-packages/casadi/casadi.so: undefined symbol: _ZN6casadi10differenceERKSt6vectorINS_2MXESaIS1_EES5

Anyone have a solution for that?

pirofti commented on 2024-04-15 11:28 (UTC) (edited on 2024-04-15 11:29 (UTC) by pirofti)

Hi,

I just created a octave-casadi port in order to be able to use casadi within octave. If there is any interest we could also probably merge that into this pacakge.

Thank you for maintaining this port!

All the best, Paul

Nim65s commented on 2023-04-12 10:04 (UTC)

Hi,

Could we replace this hardcoded "make" by a "cmake --build" ? Otherwise, it fails for users with "export CMAKE_GENERATOR=Ninja".

ref. https://wiki.archlinux.org/title/CMake_package_guidelines#Template

Thanks !

oysstu commented on 2019-11-26 14:52 (UTC)

The following patch solves the import error due to swig4 (https://pastebin.com/zRHwUgBH)

Nim65s commented on 2019-08-07 16:09 (UTC)

Thanks !

adsun commented on 2019-08-06 21:16 (UTC)

Updated. Casadi now uses python version 3 instead of 2, and enables additional interfaces.