Package Details: catalyst-test 15.12-30

Git Clone URL: https://aur.archlinux.org/catalyst-test.git (read-only)
Package Base: catalyst-test
Description: AMD/ATI Catalyst drivers for linux AKA Crimson. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. PRE-GCN Radeons are optionally supported
Upstream URL: http://www.amd.com
Licenses: custom
Conflicts: catalyst, catalyst-control, catalyst-daemon, catalyst-dkms, catalyst-generator, catalyst-hook, catalyst-utils, lib32-catalyst-utils, lib32-libegl, lib32-libgl, lib32-libgles, lib32-libglvnd, lib32-mesa-libgl, lib32-mesa-libgl-git, lib32-opencl-amd, lib32-opencl-catalyst, libegl, libgl, libgles, libglvnd, mesa-libgl, mesa-libgl-git, opencl-amd, opencl-catalyst
Provides: catalyst=15.12, catalyst-dkms=15.12, catalyst-hook=15.12, catalyst-libgl=15.12, catalyst-utils=15.12, dri, lib32-catalyst-libgl=15.12, lib32-catalyst-utils=15.12, lib32-dri, lib32-libegl, lib32-libgl, lib32-libgles, lib32-libtxc_dxtn, lib32-mesa-libgl, lib32-mesa-libgl-git, lib32-opencl-catalyst=15.12, lib32-opencl-driver, libatical=15.12, libegl, libgl, libgles, libtxc_dxtn, mesa-libgl, mesa-libgl-git, opencl-catalyst=15.12, opencl-driver
Submitter: Vi0L0
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 171
Popularity: 0.023379
First Submitted: 2010-02-17 20:49
Last Updated: 2019-05-22 18:29

Dependencies (28)

Required by (900)

Sources (40)

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 10 11 12 ... Next › Last »

quicken2k commented on 2017-07-16 20:01

@Vi0L0

Thanks, I'll try that. When I try to install it I get a mesa-libglvnd pgp error. How do I fix this?. Won't let me proceed.

Vi0L0 commented on 2017-07-16 18:54

Sure, just rename linux to linux-lts
and linux-headers to linux-lts-headers
in depends array @ PKGBUILD file

quicken2k commented on 2017-07-16 17:18

@Vi0L0

I wanted to install catalyst-test with the 4.9 lts kernel, but it tries to push me to 4.11 is there a way to use catalyst-test with 4.9 lts?

Vi0L0 commented on 2017-05-25 18:15

Thanks npfeiler, I will add your patch after getting back from vacation leave, in Sunday.
Edit: Done, mesa 17.1.0 has took me some time, I should update more packages tomorrow, or the day after... work is taking me too much time.
Plus is that I got Gnome working. Yes, it was as easy as updating patched mutter (I also updated cogl but it should not be that important)
mutter for people who don't like waiting for packages to arrive in the repo: https://pastebin.com/pcWzmA5B
patched cogl, just in case: https://pastebin.com/RjEDxzaa

npfeiler commented on 2017-05-25 16:40

4.11 patch v2 https://pastebin.com/e4WtkQE9
EDIT: added a missing line

blueberry commented on 2017-04-23 10:46

@obrez Try to reinstall catalyst-dkms with -Syuu (which allows downgrades).

obrez commented on 2017-04-21 18:09

@blueberry @Vi0L0 Just want to thank you guys, Been fighting this for a month. I moved to LTS kernel for now and everything is working. I am getting these errors though when running pacman.

error: missing 'linux>=3.0' dependency for 'catalyst-dkms'
error: missing 'linux<4.11' dependency for 'catalyst-dkms'
error: missing 'linux-api-headers>=4.10' dependency for 'glibc'

do I need catalyst-dkms?

thanks again guys <3

blueberry commented on 2017-04-17 14:48

Yesterday I updated catalyst-test and xorg "broke" in a sense that it refused connections, but Xorg.0.log and journalctl -b didn't have any unusual errors, except a hint that there was some crash dump connected to xorg/fglrx (but this wasn't so obvious to notice, at least for me). I googled and tried all possible and impossible re/installations, but nothing helped.

I have a pretty unusual configuration with 2x R9 290x + Nvidia 1080 + xmonad + startix with xinitrc, but even plugging out nvidia card didn't help.

The solution (in my case) was to ** switch kernel to linux-lts (4.9).**! I didn't try this before because Vi0L0 is using 4.10, but in the end that segfault prompted me to try kernel 4.9, and that was the solution.

I can't post the actual outputs since there were so many things that I tried, but I hope this can help someone...

herycp commented on 2017-04-16 09:17

@Vi0L0
yes

all mentioned modules blacklisted

Vi0L0 commented on 2017-04-16 08:17

@herycp: this RIP doesn't look good, but like I said gdm probably won't work, so check other one. Also did you blacklisted all mentioned modules?