Package Details: catalyst-test 15.12-30

Git Clone URL: https://aur.archlinux.org/catalyst-test.git (read-only)
Package Base: catalyst-test
Description: AMD/ATI Catalyst drivers for linux AKA Crimson. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. PRE-GCN Radeons are optionally supported
Upstream URL: http://www.amd.com
Licenses: custom
Conflicts: catalyst, catalyst-control, catalyst-daemon, catalyst-dkms, catalyst-generator, catalyst-hook, catalyst-utils, lib32-catalyst-utils, lib32-libegl, lib32-libgl, lib32-libgles, lib32-libglvnd, lib32-mesa-libgl, lib32-mesa-libgl-git, lib32-opencl-amd, lib32-opencl-catalyst, libegl, libgl, libgles, libglvnd, mesa-libgl, mesa-libgl-git, opencl-amd, opencl-catalyst
Provides: catalyst=15.12, catalyst-dkms=15.12, catalyst-hook=15.12, catalyst-libgl=15.12, catalyst-utils=15.12, dri, lib32-catalyst-libgl=15.12, lib32-catalyst-utils=15.12, lib32-dri, lib32-libegl, lib32-libgl, lib32-libgles, lib32-libtxc_dxtn, lib32-mesa-libgl, lib32-mesa-libgl-git, lib32-opencl-catalyst=15.12, lib32-opencl-driver, libatical=15.12, libegl, libgl, libgles, libtxc_dxtn, mesa-libgl, mesa-libgl-git, opencl-catalyst=15.12, opencl-driver
Submitter: Vi0L0
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 171
Popularity: 0.022491
First Submitted: 2010-02-17 20:49
Last Updated: 2019-05-22 18:29

Dependencies (28)

Required by (900)

Sources (40)

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 10 11 12 13 ... Next › Last »

herycp commented on 2017-04-16 02:10

Can't initialize KMS backend: could not find drm kms device

but i disable kms :
File: /etc/default/grub

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Antergos"
GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=04301697-cfc4-46a3-9c00-f1ff51617609"
GRUB_CMDLINE_LINUX="nomodeset"

herycp commented on 2017-04-16 02:07

@Vi0L0

i tried install like ur note but blank (just unrespon screen so i cant swich tty and try run startx) in prosses before run dm (i use gdm)

journal :

Apr 16 07:08:50 rio-MPC systemd[565]: Started D-Bus User Message Bus.
Apr 16 07:08:50 rio-MPC gnome-shell[583]: Can't initialize KMS backend: could not find drm kms device
Apr 16 07:08:50 rio-MPC gnome-session[576]: gnome-session-binary[576]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Apr 16 07:08:50 rio-MPC gnome-session-binary[576]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Apr 16 07:08:50 rio-MPC gnome-session-binary[576]: Unrecoverable failure in required component org.gnome.Shell.desktop
Apr 16 07:08:50 rio-MPC gdm[499]: GdmDisplay: display lasted 0,324748 seconds
Apr 16 07:08:50 rio-MPC systemd-logind[462]: Removed session c2.
Apr 16 07:08:50 rio-MPC gdm[499]: Child process -572 was already dead.
Apr 16 07:08:50 rio-MPC gdm[499]: Child process 554 was already dead.
Apr 16 07:08:50 rio-MPC gdm[499]: Unable to kill session worker process
...............................

Apr 16 07:08:52 rio-MPC kernel: RIP: KCL_ACPI_GetVfctBios+0x36/0x70 [fglrx] RSP: ffffc900022cba58

..............................



Vi0L0 commented on 2017-04-07 21:35

it's working fine (as for catalyst) here on 4.10.8-1-ARCH kernel and plasma desktop. I'm using sddm desktop manager, gdm probably won't work, but GNOME on Xorg should work fine with additional patched packages from [catalyst] like cogl, mutter and imagemagick-nocl.
edit: I now switched to GNOME on xorg and it's also running well. It has compositing, while plasma isn't able to render compositing on catalyst since months

Just a couple of notes:
1. add [xorg117] and [catalyst] repos over other repositories in pacman.conf
2. blacklist some modules:
# cat /etc/modprobe.d/blacklist.conf
blacklist radeon
blacklist amdgpu
blacklist kms
blacklist drm_kms_helper
3. It's better to have xorg.conf with fglrx inside
4. Don't forget about nomodeset in kernel options

Heres what I did to switch from mesa-git to catalyst
- performed steps from notes mentioned above :>
- removed conflicting packages:
pacman -Rdd mesa-libgl-git xf86-video-amdgpu-git lib32-mesa-libgl-git
- downgraded xorg-server and installed other packages (also mesa-noglvnd and mutter should be installed, even when they are not mentioned in command below) from [catalyst] repo:
pacman -Syuu catalyst-dkms catalyst-utils catalyst-libgl opencl-catalyst lib32-catalyst-utils lib32-catalyst-libgl lib32-opencl-catalyst imagemagick-nocl
- rebooted

if that won't help then you should give additional info including info about your GPU + links to pastebin with your:
- Xorg.0.log
- dmesg
- journalctl -b
- try to run startx and note what it returns

obrez commented on 2017-04-07 16:29

No problem @Vi0L0, Thanks for looking into it. You are correct I am not or have ever used [mesa-git] repo.

Vi0L0 commented on 2017-04-07 06:39

mesa-noglvnd is also dependency of this catalyst-test 15.12-14 package, so you had to install mesa-noglvnd anyway. In theory if you built mesa-noglvnd on your own it should work just like mine, but I would recommand testing mine, just in case.
I will look at catalyst-test later today, yesterday I had an issue with amdgpu @ latest update on [mesa-git] side and the result was blank screen without sign of error in logs - so it's kinda similar. But I guess you are not using [mesa-git] repo?

obrez commented on 2017-04-06 21:42

@Vi0L0 I think we have similar issues, I did try to use the packages from the repo but went back to catalyst-test later. Should I use the repo now that mesa-noglvnd is being used instead?

obrez commented on 2017-04-06 21:41

Thank you @Vi0L0, I don't know what is going on with my system, everything seems right, but I still cant get X to start.

Vi0L0 commented on 2017-04-06 21:36

@obrez: seems right
edit: you guys sharing the same issue? were you trying to use packages from [catalyst] repo, including mesa-noglvnd? It was working well for me on Sunday, when I was checking it for the last time

obrez commented on 2017-04-06 21:30

do these links look right?
lrwxrwxrwx 1 root root 21 Apr 4 14:59 libGLESv1_CM.so -> libGLESv1_CM.so.1.1.0
lrwxrwxrwx 1 root root 21 Apr 4 14:59 libGLESv1_CM.so.1 -> libGLESv1_CM.so.1.1.0
lrwxrwxrwx 1 root root 35 Apr 4 14:59 libGLESv1_CM.so.1.1.0 -> /usr/lib/mesa/libGLESv1_CM.so.1.1.0
lrwxrwxrwx 1 root root 18 Apr 4 14:59 libGLESv2.so -> libGLESv2.so.2.0.0
lrwxrwxrwx 1 root root 18 Apr 4 14:59 libGLESv2.so.2 -> libGLESv2.so.2.0.0
lrwxrwxrwx 1 root root 32 Apr 4 14:59 libGLESv2.so.2.0.0 -> /usr/lib/mesa/libGLESv2.so.2.0.0
lrwxrwxrwx 1 root root 16 Jul 31 2016 libGLEW.so -> libGLEW.so.2.0.0
lrwxrwxrwx 1 root root 16 Jul 31 2016 libGLEW.so.2.0 -> libGLEW.so.2.0.0
-rw-r--r-- 1 root root 587408 Jul 31 2016 libGLEW.so.2.0.0
lrwxrwxrwx 1 root root 33 Apr 4 14:59 libGL.so -> /usr/lib/fglrx/fglrx-libGL.so.1.2
lrwxrwxrwx 1 root root 33 Apr 4 14:59 libGL.so.1 -> /usr/lib/fglrx/fglrx-libGL.so.1.2
lrwxrwxrwx 1 root root 33 Apr 4 14:59 libGL.so.1.2.0 -> /usr/lib/fglrx/fglrx-libGL.so.1.2
lrwxrwxrwx 1 root root 15 Dec 5 2015 libGLU.so -> libGLU.so.1.3.1
lrwxrwxrwx 1 root root 15 Dec 5 2015 libGLU.so.1 -> libGLU.so.1.3.1
-rwxr-xr-x 1 root root 522952 Dec 5 2015 libGLU.so.1.3.1

Vi0L0 commented on 2017-04-06 19:30

@quicken2k: be sure to not have libglvnd installed, as well as mesa-libgl or mesa-libgl-noglvnd.
Check lib links in /usr/lib/. libGL should point to fglrx's lib, while libEGL and libGLES to mesa's libs. If it's not reinstall catalyst.
Basically catalyst should be installed at the end.
If you have hybric graphics / pxp - write about it.

If that didn't help then paste Xorg.0.log and `journalctl -b` on some pastebin portal