Package Details: catalyst-total-hd234k 13.1-42

Git Clone URL: https://aur.archlinux.org/catalyst-total-hd234k.git (read-only)
Package Base: catalyst-total-hd234k
Description: AMD/ATI legacy drivers. catalyst-dkms+ catalyst-utils + lib32-catalyst-utils
Upstream URL: https://www.amd.com
Licenses: custom
Conflicts: catalyst, catalyst-daemon, catalyst-dkms, catalyst-generator, catalyst-test, catalyst-utils, libegl, libgl, libgles, libglvnd, mesa-libgl, mesa-libgl-git, nvidia, nvidia-utils, opencl-amd, xf86-video-ati, xf86-video-radeonhd
Provides: catalyst=13.1, catalyst-dkms=13.1, catalyst-libgl=13.1, catalyst-utils=13.1, dri, libatical=13.1, libegl, libgl, libgles, libtxc_dxtn, opencl-catalyst=13.1, opencl-driver
Submitter: Vi0L0
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 34
Popularity: 0.000008
First Submitted: 2012-06-12 16:59
Last Updated: 2018-04-29 16:55

Dependencies (23)

Required by (723)

Sources (35)

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 11 12 13 14 ... Next › Last »

osaad commented on 2014-06-09 21:25

any news on compatability with 3.14.5?

Vi0L0 commented on 2014-05-02 08:52

There's a bug in linux 3.14.2 package:
https://bugs.archlinux.org/index.php?do=details&action=details.addvote&task_id=40171

Temporary workaround is to downgrade linux and linux-headers to 3.14.1 or use gcc from [testing]. The first solution should be imho safer. You can find 3.14.1 at arm:

x86_64:
ftp://seblu.net/archlinux/arm/2014/04/25/core/os/x86_64/linux-3.14.1-1-x86_64.pkg.tar.xz
ftp://seblu.net/archlinux/arm/2014/04/25/core/os/x86_64/linux-headers-3.14.1-1-x86_64.pkg.tar.xz

i686:
ftp://seblu.net/archlinux/arm/2014/04/25/core/os/i686/linux-3.14.1-1-i686.pkg.tar.xz
ftp://seblu.net/archlinux/arm/2014/04/25/core/os/i686/linux-headers-3.14.1-1-i686.pkg.tar.xz

Vi0L0 commented on 2014-05-02 08:52

there's a bunch of patches here:
patch -Np1 -i ../3.5-do_mmap.patch
patch -Np1 -i ../arch-fglrx-3.7.patch
patch -Np1 -i ../arch-fglrx-3.8.patch
patch -Np0 -i ../gentoo_linux-3.10-proc.diff
patch -l -Np1 -i ../foutrelis_3.10_fix_for_legacy.patch
patch -Np1 -i ../lano1106_fglrx_intel_iommu.patch
patch -Np1 -i ../lano1106_kcl_agp_13_4.patch
patch -Np1 -i ../arch_3.13_kernel_acpi_node.patch
patch -Np1 -i ../cold-fglrx-3.14-current_euid.patch
which bring support for kernels up to 3.14 (and 3.15 rc for now).
I dont see a reason for which this should not work with ubuntu, but i never tested it there

Alinz commented on 2014-04-30 15:34

Hi Vi0L0,
Does your patch work with ubuntu? My system kernel vesion is 3.11, should I downgrade kernel to use it?

doblerone commented on 2014-04-20 17:03

Hi again ViOLO,

now it seems to be a conflict with mesa-libgl

:: mesa-libgl y catalyst-total-hd234k están en conflicto (libgl). ¿Quitar catalyst-total-hd234k? [s/N]
error: se han detectado paquetes con conflictos no resolvibles
error: error al preparar la transacción (dependencias en conflicto)
:: mesa-libgl y catalyst-total-hd234k están en conflicto

I will wait for your advise.

Awebb commented on 2014-04-16 11:24

...which won't work anymore, because the xorg-server package is at 1.15-1 now. Was this always that complicated?

Vi0L0 commented on 2014-04-11 18:10

update catalyst-total-hd234k at first, newest version depends on linux<3.15

doblerone commented on 2014-04-11 15:41

Hi ViOLO, this is what I get when I try to update my system with:
sudo pacman -Syu

resolviendo dependencias...
verificando conflictos...
error: error al preparar la transacción (no se pudieron satisfacer las dependencias)
:: catalyst-total-hd234k: necesita linux<3.14

What should I do?
Thanks in advance.

Vi0L0 commented on 2014-03-23 18:52

13.1-24:
- added 3.14 kernel support (thanks to Cold's patch)

I wasn't able to check if it's working fine, I only can say that it compiles. But should be OK

Vi0L0 commented on 2014-03-22 20:45

sorry I didn't find time today, I will add patch tomorrow