Package Details: catalyst-total 15.9-14

Git Clone URL: https://aur.archlinux.org/catalyst-total.git (read-only)
Package Base: catalyst-total
Description: AMD/ATI Catalyst drivers for linux. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
Upstream URL: http://www.amd.com
Licenses: custom
Conflicts: catalyst, catalyst-daemon, catalyst-dkms, catalyst-generator, catalyst-hook, catalyst-utils, libcl, libgl, mesa-libgl, mesa-libgl-git
Provides: catalyst=15.9, catalyst-hook=15.9, catalyst-libgl=15.9, catalyst-utils=15.9, dri, libatical=15.9, libcl, libgl, libtxc_dxtn, mesa-libgl, mesa-libgl-git, opencl-catalyst=15.9
Submitter: None
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 128
Popularity: 0.596340
First Submitted: 2009-11-11 05:59
Last Updated: 2016-10-19 19:44

Dependencies (22)

Required by (721)

Sources (27)

  • 4.2-amd-from_crimson_15.11.patch
  • 4.3-gentoo-mtrr.patch
  • 4.3-kolasa-seq_printf.patch
  • 4.4-manjaro-xstate.patch
  • 4.6-arch-get_user_pages-page_cache_release.patch
  • 4.7-arch-cpu_has_pge-v2.patch
  • arch-fglrx-authatieventsd_new.patch
  • ati-powermode.sh
  • atieventsd.service
  • atieventsd.sh
  • catalyst.conf
  • catalyst.sh
  • crimson_i686_xg.patch
  • dkms.conf
  • fglrx_gpl_symbol.patch
  • grsec_arch.patch
  • http://www2.ati.com/drivers/linux/amd-catalyst-15.9-linux-installer-15.201.1151-x86.x86_64.zip
  • lano1106_fglrx_intel_iommu.patch
  • lano1106_kcl_agp_13_4.patch
  • lib32-catalyst.sh
  • makefile_compat.patch
  • makesh-dont-check-gcc-version.patch
  • pxp_switch_catalyst
  • switchlibGL
  • switchlibglx
  • temp-links-catalyst.service
  • temp_links_catalyst

Latest Comments

MikkelH commented on 2016-10-27 16:55

Hello.
Trying to build it on gcc-5.4.0 and kernel 4.7.9, but compilation is failing on kcl_agp

kcl_agp.c:153:5: error: invalid initializer
&agp_free_memory,
kcl_agp.c:153:5: note: (near initialization for ‘kcl_agp_callbacks.<anonymous>’)
kcl_agp.c:154:5: error: initialization from incompatible pointer type [-Werror=incompatible-pointer-types]
&kcl_agp_wrap_allocate_memory,

Tried to read some stuff online about fixing that kind of error, but failed to apply it to kcl_agp. Any help?

zhuebok commented on 2016-09-23 11:39

Hello.
After installation and configuring my xorg.con I can start Xorg with root rights only, when I start it from non-root user, Xorg fails with next messages:
[ 13.105] (EE) fglrx(0): failed to map MMIO register space!(EE) fglrx(0): MapMMIO failed
[ 13.105] (EE) fglrx(0): PreInitAdapter failed
[ 13.105] (EE) fglrx(0): PreInit failed

This is the permission problem (may be even with X11, I installed it from http://catalyst.wirephire.com/repo/xorg117), but about two days I can not find solution for it.

Vi0L0 commented on 2016-09-18 19:34

I have been using oss amdgpu latelly, but can confirm that catalyst-total works fine on 4.7.4-1-ARCH.

drxspace commented on 2016-09-15 16:21

Is there anyone else having issues with the Linux kernel 4.7.3-2?

Deepcool commented on 2016-08-28 01:02

I found success and installed the xorg 1.17 and catalyst-total.

But I had to bring the system down to the base than build from the ground up.

Thank you

Vi0L0 commented on 2016-08-12 21:16

It's very likely, but I will be able to perform necessary tests and updates on Monday. Give me this time please.

AlPiotrowicz commented on 2016-08-12 19:19

I'm not very tech guy, but could it just work by patching it by Vi0l0's 4.7-arch-cpu_has_pge.patch from the catalyst-test aur package?


Any clues welcome.

gissf1 commented on 2016-08-12 04:16

Today I tried updating my system and got this:

$ yaourt -Syua
[...snip...]
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: catalyst-total: installing linux (4.7-1) breaks dependency 'linux<4.7'
$

Are there patches for kernel 4.7.x yet? or should we switch to linux-lts which sits nicely at 4.4.16-1 right now?

beaker23 commented on 2016-08-11 21:33

Check the arch wiki for catalyst:

https://wiki.archlinux.org/index.php/Catalyst#Xorg_repositories

You'll have to use one of the unofficial builds.

arun_kpm commented on 2016-08-10 10:49

there is no old version of xorg-server(less than 1.18) in aur . so , I am getting this error

http://freetexthost.com/4ig3jnbzws

thanks @beaker23

All comments