Package Details: catalyst-total 15.9-25

Git Clone URL: https://aur.archlinux.org/catalyst-total.git (read-only)
Package Base: catalyst-total
Description: AMD/ATI Catalyst drivers for linux. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
Upstream URL: https://www.amd.com
Licenses: custom
Conflicts: catalyst, catalyst-daemon, catalyst-dkms, catalyst-generator, catalyst-hook, catalyst-utils, libegl, libgl, libgles, libglvnd, mesa-libgl, mesa-libgl-git, opencl-amd
Provides: catalyst=15.9, catalyst-hook=15.9, catalyst-libgl=15.9, catalyst-utils=15.9, dri, libatical=15.9, libegl, libgl, libgles, libtxc_dxtn, mesa-libgl, mesa-libgl-git, opencl-catalyst=15.9, opencl-driver
Submitter: None
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 130
Popularity: 0.000009
First Submitted: 2009-11-11 05:59
Last Updated: 2018-04-29 16:39

Dependencies (23)

Required by (816)

Sources (36)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

Vi0L0 commented on 2017-03-12 17:35

it works fine (i mean as for fglrx ;P) here on 4.10.1-1-ARCH x86_64.

would you be able to brings some more info in a free time?

bolvarak commented on 2017-03-12 16:50

There seems to be some incompatibility with the 4.10.1-1 kernel. I wasn't able to debug as I needed my computer up and running, but switching to linux-lts (4.9.13-1) solved the issue. Just a heads up for anyone who hasn't updated in a while.

Vi0L0 commented on 2017-03-11 18:21

ok, so for now I've added mesa packages of 17.0.1-1 version to [catalyst]* and [catalyst-stable] - simply copied from archive: https://archive.archlinux.org/packages/

Please downgrade if you updated mesa to -2 version.
After new version of mesa came out, I will build new mesa packages without glvnd support. Then I will most probably add new mesa package to aur. Will let know when it will happen

*
[catalyst]
Server = http://mirror.hactar.xyz/Vi0L0/catalyst/$arch

Vi0L0 commented on 2017-03-11 16:59

thanks Flowneee

yes, mesa-libgl is gone and things get little messy
let me link the case to the forum:
https://bbs.archlinux.org/viewtopic.php?pid=1696559#p1696559

Flowneee commented on 2017-03-11 14:23

When i try to update system i got this

looking for conflicting packages...
:: mesa and catalyst-total are in conflict (mesa-libgl). Remove catalyst-total? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: mesa and catalyst-total are in conflict

P.S. I asked on forum about this issue https://bbs.archlinux.org/viewtopic.php?pid=1696510#p1696510 and there was noticed that mesa-libgl doesnt exists anymore and package need to be fixed.

makaleh commented on 2017-02-28 04:07

Vi0L0, any plans for xorg 1.19 support? Just curious. What would be the roadblocks to 1.19 compatibility?

Vi0L0 commented on 2016-12-12 13:04

You can't have the same problem because package was updated and it's building without a word about ocl-icd or libcl. You can have other problem though :) but I guess that you can fix it with:
pacman -Udd <path_to_catalyst-total_pkg>
then pacman -Syu ocl-icd

freedent commented on 2016-12-12 11:49

I have the same problem of LeRieur about ocl-icd.

Vi0L0 commented on 2016-12-11 09:39

should be better now, also added initial 4.9 kernel support (tested on -rc8)

Anonymous comment on 2016-12-10 19:48

Please add ocl-icd to provides instead of libcl. Can't install imagemagick because of this patch: https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/imagemagick&id=193cd1967d79f4de07019e94cda75aaff9947a3d

ocl-icd and catalyst-total are in conflict (libcl)