Package Details: catalyst-total 15.9-25

Git Clone URL: https://aur.archlinux.org/catalyst-total.git (read-only)
Package Base: catalyst-total
Description: AMD/ATI Catalyst drivers for linux. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
Upstream URL: https://www.amd.com
Licenses: custom
Conflicts: catalyst, catalyst-daemon, catalyst-dkms, catalyst-generator, catalyst-hook, catalyst-utils, libegl, libgl, libgles, libglvnd, mesa-libgl, mesa-libgl-git, opencl-amd
Provides: catalyst=15.9, catalyst-hook=15.9, catalyst-libgl=15.9, catalyst-utils=15.9, dri, libatical=15.9, libegl, libgl, libgles, libtxc_dxtn, mesa-libgl, mesa-libgl-git, opencl-catalyst=15.9, opencl-driver
Submitter: None
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 130
Popularity: 0.000016
First Submitted: 2009-11-11 05:59
Last Updated: 2018-04-29 16:39

Dependencies (23)

Required by (800)

Sources (36)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

lordmocha commented on 2016-02-08 05:40

The dependency `xorg-server` demands version `<1.18.0`, but the most recent version is `1.18.0-4`.

Any chance of an updated catalyst-total? Thanks.

AlPiotrowicz commented on 2016-01-21 14:37

All works like a charm now. It must have been 0xfc issue.
Thank you very much. Appreciate all your work.

Vi0L0 commented on 2016-01-21 11:04

it doesn't like ü (hex fc in char is ü), but I removed it yesterday.
Can you check one more time?

AlPiotrowicz commented on 2016-01-20 10:08

Hi, thanks for an update.

Seems it fails with aura update

Cannot decode byte '\xfc': Data.Text.Internal.Encoding.streamDecodeUtf8With: Invalid UTF-8 stream

Any clues appreciated.

Best regards.

Vi0L0 commented on 2015-12-22 17:56

15.9-9:
- adding new patch from crimson
- removing gcc49 dependency
- adding initial grsec kernel support
- adding initial 4.4 kernel support

should be safe to remove gcc49 pkg :)

Neije commented on 2015-12-06 23:04

Hey !

Thanks for your answer. So I tried, but it seems my card (HD 5670) is not supported anymore !!! so I got nothing good with catalyst-total and even if installation succeeded, I couldn't start X.

So I suppose I have to find a solution to fix my glitches with the open source driver ...

Vi0L0 commented on 2015-12-01 21:40

Just add [xorg117] repo on the top of pacman.conf file. Then as root in CLI type:
pacman -Syuu
It should downgrade xserver related packages.
Then you should be ready to install catalyst-total[1].

Typically generating xorg.conf and adding nomodeset to kernel options should be all that you need.
If you are on hybrid gfx then its good to look at last pages of bar & grill and search for pxp users comments.

[1]there's new release in catalyst-test but internet is saying that it dropped support for pre-GCN GPUs, neverthless some hd 5 6 k owners have successes on running newest driver, you can check it out, but at first set up 15.9 to be sure that your config is fine.

Neije commented on 2015-12-01 07:41

Hello Violo, everyone,

I wanted to try out the open source driver with my card (5670) and although it does work, I would like to come back to the catalyst for some more tests. Right now, I had to upgrade all my system and I have the latest xorg + xserver package ... which is kinda problem for installing the driver because of 1.18.0 dependencies.

I normally use the xorg repos. I would like to know how I should proceed now ? I am confused just how I can get the driver installed. can I force it ? or should I use a test version compatible with the xorg-server package ?

Vi0L0 commented on 2015-11-25 20:18

for now Crimson will stay on catalyst-test@AUR and [catalyst] (it will be updated soon), and this updated to 15.9-6 package should stay for some time (don't worry, new package probably called catalyst-total-hd56k will be created later) to serve pre-GCN cards users.

depletionmode commented on 2015-11-24 14:08

The new driver (Crimson) has been released today. Is this package going to be updated at some point for the new driver branch or another package opened for that driver (http://www2.ati.com/drivers/linux/radeon-crimson-15.11-15.30.1025.zip)?