Package Details: catalyst-total 15.9-25

Git Clone URL: https://aur.archlinux.org/catalyst-total.git (read-only)
Package Base: catalyst-total
Description: AMD/ATI Catalyst drivers for linux. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
Upstream URL: https://www.amd.com
Licenses: custom
Submitter: None
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 130
Popularity: 0.000010
First Submitted: 2009-11-11 05:59
Last Updated: 2018-04-29 16:39

Dependencies (23)

  • dkms
  • fontconfig
  • gcc-libs
  • libsm
  • libxcursor
  • libxi
  • libxinerama
  • libxrandr
  • linux-headers
  • make
  • mesa-noglvnd
  • patch
  • xorg-server<1.18.0
  • linux<4.17
  • gcc>4.0.0
  • xorg-server>=1.7.0
  • linux>=3.0
  • acpid (optional) – acpi event support / atieventsd
  • libxxf86vm (optional) – to run ATi Catalyst Control Center (amdcccle)
  • opencl-headers (optional) – headers necessary for OpenCL development
  • opencl-icd-loader (optional) – OpenCL ICD Bindings
  • procps-ng (optional) – brings pgrep used in acpi event support
  • qt4 (optional) – to run ATi Catalyst Control Center (amdcccle)

Required by (0)

Sources (36)

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 10 11 12 ... Next › Last »

transmutated commented on 2015-09-28 21:54

@Vi0L0, any update on this package? Looks like there is a 15.9 out there that supports a newer current xorg server finally. Will require some sort of patching to work with the present 4.2 kernel in core. Looks like this package hasn't been updated in 3 months now.

Vi0L0 commented on 2015-06-04 13:23

updated to 15.5-1 - AKA "nothing interesting":
- it doesn't support xserver 1.17
- looks older than ubuntu vivid driver which we are using ie in catalyst-test@AUR
- i've added initial support for 4.1 kernel (using kolasa's patch, tested on 4.1rc5)
- rel notes: http://support.amd.com/en-us/kb-articles/Pages/AMDCatalyst15-5LINReleaseNotes.aspx

Vi0L0 commented on 2015-05-04 18:24

14.12-3:
- 4.0 kernel support (thanks to kolasa for patch)

mcxplode commented on 2015-05-01 17:17

not a big deal catalyst-test supports kernel 4.0
wonder if this package actually needs patch or just dependencies updated.

Vi0L0 commented on 2015-05-01 12:41

I'm traveling, will be back on Sunday/Monday,then will search for solution.
if it's important then maybe check kolasa's github for the patch

mcxplode commented on 2015-04-30 03:04

now needs linux kernel 4.0.1 patch

optomus commented on 2015-04-05 07:28

Would someone be able to provide a more direct reference to "kolasa's patch". I am able to use --ignore xorg-server to bypass anything xorg related though I consistently get hit with "error: failed to prepare transaction (could not satisfy dependencies)
:: catalyst-total: requires linux<3.19"

Vi0L0 commented on 2015-03-08 14:35

oh forget to add: i was testing radeon from lordheavy's [mesa-git] repo

Vi0L0 commented on 2015-03-08 14:33

no problemo ;)
i asked because i could miss something, like new release, but nope.

btw: recent changes on radeon oss side made this driver pretty fast on my 290x, it performs almost like fglrx :) some games - like cs:go - performs even better and cacthes something like ~110 fps on high details @ 2560x1440 with fxaa enabled, blur off (i don't like blur, plus it has negative impact), vsync off, compositing disabled

FadeMind commented on 2015-03-08 14:26

Accidentally. Sorry about that.