Package Details: catalyst-utils 15.9-3

Git Clone URL: https://aur.archlinux.org/catalyst-utils.git (read-only)
Package Base: catalyst-utils
Description: AMD/ATI drivers. Utilities and libraries. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
Upstream URL: http://www.amd.com
Licenses: custom
Conflicts: catalyst-test, catalyst-total, catalyst-total-pxp, catalyst-utils-pxp
Provides: dri, libatical=15.9, libtxc_dxtn
Submitter: Vi0L0
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 57
Popularity: 0.795690
First Submitted: 2013-04-29 09:04
Last Updated: 2016-06-08 17:33

Required by (41)

Sources (12)

Latest Comments

Vi0L0 commented on 2015-10-18 09:37

GNOME 3.18 fix
In [catalyst] and [catalyst-stable] you may find a new package cogl 1.22.0-2. It brings fix for recent problems with new GNOME 3.18 and new GDM (it baheves strange with plasma though, after choosing plasma and entering password I have to switch to tty and then back to X to see plasma desktop, probably another bug).
Source and a patch is here: http://mirror.rts-informatique.fr/archlinux-catalyst/tarball/gnome318-problems/cogl-1.22.0-2.src.tar.gz

Vi0L0 commented on 2015-10-07 20:41

@er***: many users are experiencing freezes here:
https://bbs.archlinux.org/viewtopic.php?pid=1568368#p1568368
I'm gonna paste your story there, maybe it will help someone.
Hope you don't mind, whoever you are ;) (as I can see that your account doesn't exist anymore)

Vi0L0 commented on 2015-09-29 20:29

be aware that I removed linux from dependency array and so it will let linux to update (while it's not supported tongue), if you will not configure bootloader to use kernel older than 4.2, like linux-lts, it will probably boot linux and you will probably gonna see a freeze or blank screen. System should work though, you can ssh to it and config bootloader from here, or use single mode if you can't ssh, or well there's possibility that linux-lts was added before, boot it and config as default kernel to boot.

Vi0L0 commented on 2015-09-29 20:28

updated to 15.9
4.2 kernel is in [core] and we still don't have support for it.
So for now please use linux-lts kernel.

Vi0L0 commented on 2015-07-09 18:59

couple of words about 15.7::
OpenGL is now in 4.5 version, it brings fixes for some titles like borderlands 2 which now works well, still looks like crap smile but at least its fluid. Even warsow seems snappier, but it's not mindblowing. Dota 2 is kinda laggy in some situations, plus it crashed on exit (sic!) and I wasn't able to kill its process (sadface, at least it wasnt eating resources, only ate some ram and sit)...
They fixed vaapi which latelly wasn't working with -va vaapi option.
It does support xserver 1.17, but tty - just like with ubuntu 15.4 version - is all black - another sadpanda.
And ofcourse glitching (on plasma DE) chromium - cherry on the top.


I don't think it deserves [catalyst-stable] or catalyst@AUR...

I will put it into [catalyst] for now, catalyst-test@AUR already is updated

Vi0L0 commented on 2015-06-04 13:22

updated to 15.5-1 - AKA "nothing interesting":
- it doesn't support xserver 1.17
- looks older than ubuntu vivid driver which we are using ie in catalyst-test@AUR
- rel notes: http://support.amd.com/en-us/kb-articles/Pages/AMDCatalyst15-5LINReleaseNotes.aspx

Vi0L0 commented on 2015-02-15 12:04

xserver 1.17 renders nasty segfault.
For now you can use [xorg116] repo:

[xorg116]
# uncomment one server from the list below:
#Server = http://catalyst.wirephire.com/repo/xorg116/$arch
#Server = http://mirror.rts-informatique.fr/archlinux-catalyst/repo/xorg116/$arch
#Server = http://mirror.hactar.bz/Vi0L0/xorg116/$arch

ashwin.vbs commented on 2015-02-15 11:32

Xorg was updated to 1.17 today - this breaks automated dependencies..

Vi0L0 commented on 2014-12-20 19:41

quote from bar and grill:
I can see that git version already have this patch included (as well as other fixes). Can some pxp user check if xf86-video-intel-git works fine on their systems with xserver 1.16 installed? You can get this pkg from AUR or from the [mesa-git] repo or you can use mine if you want[1], i built it minutes ago for x86_64.

[1]http://mirror.rts-informatique.fr/archlinux-catalyst/files/xf86-video-intel-git/

Vi0L0 commented on 2014-12-18 08:12

Thanks Toost_Inc, I will add it to provides array after getting back home

Toost_Inc commented on 2014-12-18 00:07

Just ran into a dependency problem building libva-xvba-drivers which needs catalyst-libgl.

If I'm right in assuming the catalyst-libgl files are all provided with catalyst-total, could you add it to the provides variable?

Vi0L0 commented on 2014-12-11 21:23

what else... xserver 1.16 support, and kernel up to 3.18 (thanks to my noobish patch for 3.17 ;P)

Vi0L0 commented on 2014-12-11 21:22

updated to 14.12-1, "famous" catalyst omega
http://support.amd.com/en-us/kb-articles/Pages/AMDCatalystOmegaLINReleaseNotes.aspx

quick tests showed that this driver is pretty good.
2d rendering was never that fast on 290X (its almost as fluid as on oss radeon)
cs:go works like a charm now ;P.

vaapi does work (but it has problems with osd, including subtitles) here without additional xvba-video packages
if you want to check it just add
export LIBVA_DRIVER_NAME=fglrx
into ~/.bashrc, and if that won't work for all your players you can create something like /etc/profile.d/fglrx-vaapi.sh with lets say:
LIBVA_DRIVER_NAME=fglrx
export LIBVA_DRIVER_NAME
LIBVA_DRIVERS_PATH=/usr/lib/dri/
export LIBVA_DRIVERS_PATH


IMPORTANT
thing is that from now on theres this new symlink:
ln -snf /usr/lib/libXvBAW.so.1.0 ${pkgdir}/usr/lib/dri/fglrx_drv_video.so
which will conflict with xvba-video packages. Thats amd's will, maybe they will do something with it. Feel free to remove this file(symlink) from your system before updating (if you will be touched by a conflict).

averagejoey2000 commented on 2014-12-08 20:35

pacaur and yaourt cannot satisfy the following dependency:
xorg-server (less than)<1.16
that is simultaneously >=(greater than or equal to) 1.7
Do I need to install a specific xorg, modify the PKGBUILD for this(catalystutils), or what?

ShyPixie commented on 2014-10-23 11:54

This package need a patch for amdxdg-su work with xfce.

The script check if environments match with xfce4 (see line 323), but not in final "case" (on lines 566 ~ 587).

Need to edit script on the last case/esac with:

xfce4)
su_gnome
;;

Vi0L0 commented on 2014-10-03 20:55

updated to 14.9-1:
- official, stable release
http://support.amd.com/en-us/kb-articles/Pages/AMDCatalyst14-9LINReleaseNotes.aspx

- it doesn't support xserver 1.16

- I added my fresh patch for kernel 3.17 rc6.
Notes about the patch:
1. it probably wont work on 3.17 kernels older than rc6 because I don't know how to tell preprocessor about rc version :P
2. im unable to test resume/suspend
3. im not the developer, just pressing random keys :P so the patch could be less/more noobish :-)

kamelie1706 commented on 2014-07-30 08:49

Thanks, will use [xorg115] repo for now.

Vi0L0 commented on 2014-07-30 08:13

Right now only one person had enought luck to run newest, beta catalyst on xorg-server 1.16.

I checked it on 2 AMD GPUs, getting X crash with error: libglx.so: undefined symbol: LoadExtension, others also weren't able to run it succesfully.

I think that you can skip checking and simply use [xorg115] repo:
https://wiki.archlinux.org/index.php/AMD_Catalyst#Xorg_repositories

Vi0L0 commented on 2014-07-30 08:08

Right now only one person had enought luck to run newest, beta catalyst on xorg-server 1.16.
I checked it on 2 AMD GPUs, others also weren't able to run it succesfully.
I think that you can skip checking and simply use [xorg115] repo:
https://wiki.archlinux.org/index.php/AMD_Catalyst#Xorg_repositories

kamelie1706 commented on 2014-07-30 07:17

I installed
catalyst-utils
catalyst-libgl
opencl-catalyst

using
* pacman -Sy * for each package - no error

but
* sudo pacman -Syu *
still complains the same

kamelie1706 commented on 2014-07-30 07:09

I probably missed something as I was off for a month.
When trying
* sudo pacman -Syu *
it complains about catalyst-utils requires xorg-server<1.16.0
I use currently X.Org X Server 1.15.2

AlfredoRamos commented on 2014-07-29 20:58

Hi there,

I can't upgrade because I have xorg-server 1.16.0-5 installed, it's still 1.16.0 though.

Does catalyst-utils work with this version of xorg-server? Is there any way to upgrade?

PS: I'm using the unofficial repository.

- https://wiki.archlinux.org/index.php/Unofficial_user_repositories#catalyst

Vi0L0 commented on 2014-07-26 16:51

Thank You NoSuck.
I did a silent update (libgl's install is just the echo, so there was no reason to bump pkgrel) which fixed it.
Also I removed split hack, because for some time aur supports split packages.
(I performed same update on lib32-catalyst-utils)

Vi0L0 commented on 2014-07-26 16:49

Thank You NoSuck.
I did a silent update (libgl's install is just the echo) which fixed it.
Also I removed split hack, because for some time aur supports split packages.
(I performed same update on lib32-catalyst-utils)

NoSuck commented on 2014-07-23 23:36

Thank you for putting this together. Without Catalyst, Arch would not be a viable OS choice for me.

Does anyone else get errors when catalyst-libgl compiles?

cp: `aur/catalyst-utils/catalyst-libgl.install' を stat できません: そのようなファイルやディレクトリはありませ
chmod: `.INSTALL' にアクセスできません: そのようなファイルやディレクトリはありません
bsdtar: .INSTALL: Cannot stat: そのようなファイルやディレクトリはありません
bsdtar: .INSTALL: Cannot stat: そのようなファイルやディレクトリはありません

... It's complaining that "catalyst-libgl.install" and ".INSTALL" don't exist. Otherwise, the build process seems to finish without problems.

NoSuck commented on 2014-07-23 23:34

Thanks for putting this together. Without Catalyst, Arch would not be a viable OS choice for me.

Does anyone else get errors when catalyst-libgl compiles?

cp: `aur/catalyst-utils/catalyst-libgl.install' を stat できません: そのようなファイルやディレクトリはありませ
chmod: `.INSTALL' にアクセスできません: そのようなファイルやディレクトリはありません
bsdtar: .INSTALL: Cannot stat: そのようなファイルやディレクトリはありません
bsdtar: .INSTALL: Cannot stat: そのようなファイルやディレクトリはありません

... It's complaining that "catalyst-libgl.install" and ".INSTALL" don't exist. Otherwise, the build process seems to finish without problems.

Vi0L0 commented on 2014-05-25 11:34

updated to 14.4-20 (catalyst 14.4 rev2):
- which brings some fixes for Witcher 2

Vi0L0 commented on 2014-05-07 17:19

yes, bug with gdm is still present

marmotta commented on 2014-05-07 15:16

Ok, i see -11 un aur but not in pacman...

The bug with gdm is still present?

Vi0L0 commented on 2014-05-07 13:06

you mean that its in -10, not -11 version?:
# pacman -Sl catalyst | grep utils
catalyst catalyst-utils 14.4-10
catalyst catalyst-utils-pxp 14.4-10
catalyst lib32-catalyst-utils 14.4-11
catalyst lib32-catalyst-utils-pxp 14.4-10

in -11 only sub-package catalyst-libgl was updated, and so is in the repo:
# pacman -Sl catalyst | grep libgl
catalyst catalyst-libgl 14.4-11
catalyst lib32-catalyst-libgl 14.4-11

marmotta commented on 2014-05-07 11:54

Please update catalyst-utils in your repo http://catalyst.wirephire.com/

Vi0L0 commented on 2014-04-28 20:31

updated to 14.4-11, catalyst 14.4 stable:
- xserver 1.15 support
(gotjazz wrote: little warning though - if you use xbmc, get sdl-nobackingstore from the AUR or you'll have tearing during video playback with xorg 1.15)
- many fixes here and there

catalyst-utils is now splitted into:
catalyst-utils
catalyst-libgl
opencl-catalyst

catalyst-libgl comes with experimental powerXpress support which is not messing with the system like old -pxp packages are, please test and let me know if its working well

olive commented on 2014-04-28 04:32

@willsiddall The latest stable driver is now 14.4 which should support Xorg 1.15. Probably Vi0l0 will update it soon.

olive commented on 2014-04-28 04:31

The latest stable driver is now 14.4 which should support Xorg 1.15. Probably Vi0l0 will update it soon.

willsiddall commented on 2014-04-27 22:21

current version of xorg-server is now >1.15. Any chance this build will work with the newer versions of xorg-server?

Vi0L0 commented on 2014-03-18 09:35

can you give me more details?

zertyz commented on 2014-03-18 08:44

support for i686 id broken

Vi0L0 commented on 2014-03-16 17:19

13.12-4:
rebuild because of mesa 10.1.0-4 changes

Vi0L0 commented on 2014-03-15 16:57

mesa 10.1.0-4 is in [extra]
i updated main repos and AUR packages: catalyst-test, catalyst-total, catalyst-total-hd234k. I left AUR's catalyst-utils and lib32-catalyst-utils untouched for now because i gotta go. WIll update those later (probably tomorrow)...

Vi0L0 commented on 2014-03-09 22:20

sorry for missuse, let me start again:
updated:
- added mesa to the dependency list
- added symlinks to egl and gles libs of mesa

Vi0L0 commented on 2014-03-09 22:18

updated:
- added mesa and lib32-mesa to the dependencies lists
- added symlinks to egl and gles libs of mesa and lib32-mesa

Vi0L0 commented on 2014-03-09 11:20

Yup, I also wrote about it:
https://bbs.archlinux.org/viewtopic.php?pid=1390293#p1390293

Question is: maybe someone has better idea?

dchusovitin commented on 2014-03-09 10:51

Problems with mesa 10.0.3-1 and catalyst.
https://bugs.archlinux.org/task/39239#comment120261

* best solution: catalyst should provide libEGL, libGLESv1_CM, .....
* only solution available: catalyst should provide symlinks to libEGL, libGLESv1_CM ,... provided by mesa

Vi0L0 commented on 2014-02-16 18:16

updated to 13.12-2:
- added 'lib32-catalyst-utils' to the optdeps
- authatieventsd' patch by solar (patch s/-1/255)
- amd has updated its /etc/ati/ files

dcelasun commented on 2014-02-02 08:21

Catalyst 14.1 with xorg-server 1.15 support has been released.

http://phoronix.com/forums/showthread.php?94994-AMD-Catalyst-14-1-%28v1-3%29-BETA-Driver

Vi0L0 commented on 2014-01-16 16:37

Feel free to ask AMD ;P

onur commented on 2014-01-16 11:59

When estimated are supported?

Vi0L0 commented on 2014-01-16 10:10

catalyst doesn't support xorg-server 1.15.
Use [xorg114] repo:
https://wiki.archlinux.org/index.php/AMD_Catalyst#Xorg_repositories

yanom commented on 2014-01-16 03:17

It's asking for xorg-server<1.15 now.
Needs to be updated?

Vi0L0 commented on 2013-12-19 21:45

13.12-1:
- AMD marked it as stable, so am I...
- http://support.amd.com/en-us/kb-articles/Pages/AMDCatalyst13-12LINReleaseNotes.aspx

Vi0L0 commented on 2013-11-18 19:43

silent update, no pkgrel bump:
- thanks to zoopp and his referer we no longer have to download installer manually :)

Vi0L0 commented on 2013-11-13 18:29

I bumped rel because amd has changed 13.4 a little bit - there's a lot of new entries in amdpcsdb.default file.

+ like said on a top of the PKGBUILD:
NOTE: before building please download amd-driver-installer-catalyst-13-4-linux-x86.x86_64.zip using this site:
http://support.amd.com/en-us/download/desktop?os=Linux%20x86_64
and move it next to this PKGBUILD

Vi0L0 commented on 2013-09-27 13:17

it's not a problem, simply downgrade to [xorg113] repo:
https://wiki.archlinux.org/index.php/AMD_Catalyst#Xorg_repositories

goviedo commented on 2013-09-26 23:28

error: target not found: xorg-server<1.14.0
==> ERROR: 'pacman' failed to install missing

[root@arch Downloads]# Xorg -version

X.Org X Server 1.14.3
Release Date: 2013-09-12

Since the last upgrade to my Arch x64. This is a problem!

Vi0L0 commented on 2013-09-19 19:24

guys, 13.9 has memory leak, it's not stable at all.
AMD could say otherwise but don't listen to them :P

you will find 13.9 at catalyst-test and catalyst-test-pxp @ AUR,
and maybe tomorrow on the [catalyst] repo

Anonymous comment on 2013-09-14 06:34

@Vi0L0
Ok, thx!

Vi0L0 commented on 2013-09-08 14:23

@olive:
looks like you are right, thanks for the fix, I've already included it into catalyst 13.8 beta 2 packages, when time for the update will come I will add it also here

@icebreaker90 && @canatan:
changing dependency won't force this driver to work with xserver 1.14... catalyst 13.4 doesn't support xserver 1.14 and nothing will change it :P.
You can use beta drivers (like catalyst-test) if you need to work on/with xserver 1.14. But beta is beta, it's buggy and unstable - on some hardware it works better, on some it works way worse.
This is the place for stable _catalyst_ release, and latest (in both theoretical and practical point of view) stable release is 13.4.

canatan commented on 2013-08-31 12:46

@icebreaker90 +1

Anonymous comment on 2013-08-27 14:17

Please change dependency for xorg-server because 1.14.2-2 has been moved to stable channel.
Thanks

olive commented on 2013-08-22 14:14

There is a bug /etc/ati/authatieventsd.sh for xdm (not much used anymore, but it is better that all works fine).

The variable XDM_AUTH_MASK (l37)
XDM_AUTH_MASK=/var/lib/xdm/authfiles/A$1*
should be replaced by:
XDM_AUTH_MASK=/var/lib/xdm/authdir/authfiles/A$1*

otherwise the script does not file the auth file and atieventsd cannot access to the Xserver (as can be seen in the system log).

Vi0L0 commented on 2013-06-01 12:27

updated to 13.4-2:
- all bins have been moved to /usr/bin
- added workaround for i/o bug

Vi0L0 commented on 2013-05-27 18:56

It seems to work fine here on 7850,
are you runing those when X serv is running?

cgminer version 3.1.1 - Started: [2013-05-27 20:46:54]
GPU0 | (5s):0.000 (avg):246.0Mh/s | A:12 R:0 HW:0 U:6.8/m I: 5


Are you using ocl_memtest from cuda_memtest package?
using here 1.2.3 version of this package without problems:
$ ocl_memtest
hostname is xaos
CL_PLATFORM_NAME: AMD Accelerated Parallel Processing
CL_PLATFORM_VERSION: OpenCL 1.2 AMD-APP (1124.2)
Device 0 is CL_DEVICE_TYPE_GPU, "Pitcairn"
allocated 512 Mbytes from device 0
[05/27/2013 20:54:36][xaos][0]:Test0 [Walking 1 bit]
[05/27/2013 20:54:36][xaos][0]:Test0: global walk test
[05/27/2013 20:54:36][xaos][0]:Test0: local walk test
[05/27/2013 20:54:36][xaos][0]:Test0 finished in 0.0 seconds
[05/27/2013 20:54:36][xaos][0]:Test1 [Own address test]
... and so on...

unforgiven512 commented on 2013-05-17 06:35

Something seems to be wrong with OpenCL here.

cgminer (and cgminer-git) report:
[2013-05-17 02:34:35] GPU0: invalid nonce - HW error

cuda_memtest reports:
[unforgiven512@dilaudid]:~$ ocl_memtest
hostname is dilaudid
CL_PLATFORM_NAME: AMD Accelerated Parallel Processing
CL_PLATFORM_VERSION: OpenCL 1.2 AMD-APP (1124.2)
Device 0 is CL_DEVICE_TYPE_GPU, "Barts"
ERROR: opencl call failed with rc(-11), line 385, file ocl_memtest.cpp
Error: Program build failure