Package Details: catalyst 15.9-20

Git Clone URL: https://aur.archlinux.org/catalyst.git (read-only)
Package Base: catalyst
Description: AMD/ATI Catalyst drivers for linux. fglrx kernel module only. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
Upstream URL: https://www.amd.com
Licenses: custom
Conflicts: catalyst-test
Submitter: wonder
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 333
Popularity: 0.000153
First Submitted: 2009-08-09 08:02
Last Updated: 2018-04-29 16:26

Dependencies (7)

Required by (3)

Sources (23)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

Vi0L0 commented on 2018-01-21 20:44

@ian57: sorry for delay, I actually thought that nobody is using these old packages ;) I updated pkgs in aur and repos, try now. And thanks for the info about libxfont, I will check and update xorg repo

ian57 commented on 2018-01-17 17:22

[edit] I installed libxfont1 thanks to https://archive.archlinux.org/packages/l/

nedd to test if works now ;) [/edit]

Thx for the great work around ATI cards.

I have a problem, I cannot in install xorg117 on my arch laptop due to libxfont dependency. pacman and aur only find libxfont2 aand the xorg-server refuses to install.

Have you got a workaround?

So I tried to compile catalyst (with yaourt), for that I installed a linux-lts kernel and headers (4.9 < 4.14) but yaourt -S catalyst refuses to compile due to dependency to kernel < 4.14 not found.

have you got an idea?

thanks in advance

Vi0L0 commented on 2017-10-16 20:35

leonekmi: with 4.12.x and 4.13.x kernels - yes
with fresh xserver - no, and it will never happen probably

leonekmi commented on 2017-09-16 15:36

Can i install this with Linux 4.12.13-1 kernel (and also with Xorg 1.19.x) ?

slaecker commented on 2017-04-23 10:47

I get nothing but a black screen with white cursor where, posted on the forum: https://bbs.archlinux.org/viewtopic.php?id=225424

blueberry commented on 2017-04-17 14:47

Yesterday I updated catalyst-test and xorg "broke" in a sense that it refused connections, but Xorg.0.log and journalctl -b didn't have any unusual errors, except a hint that there was some crash dump connected to xorg/fglrx (but this wasn't so obvious to notice, at least for me). I googled and tried all possible and impossible re/installations, but nothing helped.

I have a pretty unusual configuration with 2x R9 290x + Nvidia 1080 + xmonad + startix with xinitrc, but even plugging out nvidia card didn't help.

The solution (in my case) was to ** switch kernel to linux-lts (4.9).**! I didn't try this before because Vi0L0 is using 4.10, but in the end that segfault prompted me to try kernel 4.9, and that was the solution.

I can't post the actual outputs since there were so many things that I tried, but I hope this can help someone...

Crabsi commented on 2016-11-23 16:44

@pavanky what are the right mirrors now? I still can't install catalyst-hook

Edit: nevermind got it now... for anyone wondering you have to add this to /etc/pacman.conf:
[xorg117]
Server = http://mirror.hactar.xyz/Vi0L0/xorg117/$arch
[catalyst]
Server = http://mirror.hactar.xyz/Vi0L0/catalyst/$arch

pavanky commented on 2016-11-22 06:36

Not sure if this is the right place to ask, but did you forget to update the repos on wirephire ? The catalyst-hook package there still wants linux < 4.7

**EDIT:** Nevermind I just noticed that the mirrors changed. It's all good.

mikaelbrun commented on 2016-10-20 13:42

I forgot to give a feedback ViOLO. Never too late, I hope.

It was my mistake. I forgot to put the xorg117 on the top :-)
Repos are alright!

Thanks for the reminder!

Vi0L0 commented on 2016-09-18 19:40

If I would update this dependency and you will start catalyst on xserver 1.18 you will only see black screen of death.
It's because catalyst doesn't support xserver 1.18 and (for 99%) never will.

You can build xorg-server 1.17 from arch's git: https://git.archlinux.org/svntogit/packages.git/snapshot/packages-e02b7fe044e46037ad80325fb9aebe3e7c39fa05.tar.gz

or use [xorg117] repo: https://wiki.archlinux.org/index.php/AMD_Catalyst#Xorg_repositories