Package Details: cb 0.1.0-4

Git Clone URL: https://aur.archlinux.org/cb.git (read-only)
Package Base: cb
Description: Command line interface to manage clipboard
Upstream URL: https://github.com/yaa110/cb
Licenses: MIT
Conflicts: cb-bin, cb-git
Provides: cb
Submitter: asm0dey
Maintainer: asm0dey
Last Packager: asm0dey
Votes: 0
Popularity: 0.000000
First Submitted: 2019-06-05 18:01
Last Updated: 2019-06-13 07:43

Latest Comments

Kr1ss commented on 2019-06-13 12:21

Thx for fixing. The package can now be built inside a (ch)root without pre-installed python. I have also tested if the command would run when python is not installed, which it does. So it is actually just a make-dependency.

I would suggest to makedepends=([..] "python") though, as this is the actual name of the package, rather than python3. Anyways, thank you for the quick response.

Cheers !

asm0dey commented on 2019-06-13 07:49

Check again pls

asm0dey commented on 2019-06-12 21:54

Thanks guys, I'll try hard to fix it tomorrow

Kr1ss commented on 2019-06-12 21:32

FWIW, I can confirm that as I'm getting the same error message as @sekret.

sekret commented on 2019-06-12 20:57

I build in a clean chroot, so I detect such things. Now with version 0.1.0-3 I get the following:

http://www.unstucc.de/build_error-cb-0.1.0-3

So python is in fact required!

asm0dey commented on 2019-06-12 20:43

@sekret I didn't add python because application is written in rust and I can't imagine what common it has with rust, but I've added libxcb

sekret commented on 2019-06-12 20:30

Hi, I had to add 'python' and 'libxcb' to makedepends for it to build successfully. I'm not sure if they are only required for building or for running aswell. At least namcap identifies libxcb as a runtime dependency.

So please fix it :-)