Package Details: cegui 0.8.7-9

Git Clone URL: https://aur.archlinux.org/cegui.git (read-only)
Package Base: cegui
Description: A free library providing windowing and widgets for graphics APIs/engines
Upstream URL: http://cegui.org.uk
Licenses: MIT
Submitter: Svenstaro
Maintainer: None
Last Packager: osvein
Votes: 1
Popularity: 0.017066
First Submitted: 2017-05-23 17:39
Last Updated: 2017-09-17 17:14

Latest Comments

namkhaib commented on 2017-11-23 01:51

I want to install cegui for Rigs Of Rods, and I can't:

[ 30%] Linking CXX shared library ../../../../lib/libCEGUIOgreRenderer-0.so
[ 30%] Built target CEGUIOgreRenderer-0
make: *** [Makefile:152: all] Error 2

FabioLolix commented on 2017-11-02 13:53

Fail to build

[ 29%] Linking CXX shared library ../../../../lib/libCEGUIOgreRenderer-0.so
[ 29%] Built target CEGUIOgreRenderer-0
make: *** [Makefile:152: all] Error 2
==> ERRORE: Si è verificato un errore in build().

rafaelff commented on 2017-10-16 14:51

I filed a bug report for this issue:
https://bitbucket.org/cegui/cegui/issues/1153/undeclared-uchar-and-char16_t-types

rafaelff commented on 2017-10-12 12:41

@osvein: icu 59.1-2 - sorry for the delay, package notifications now enabled.

osvein commented on 2017-10-05 14:55

@Jeanbon @rafaelff what does `pacman -Qo /usr/include/unicode/umachine.h` say?

rafaelff commented on 2017-09-26 21:56

Same problem as @jeanbon reported in the last message. Here is my build full log: https://ptpb.pw/RdMh

Jeanbon commented on 2017-09-19 12:02

@osvein Thanks :) I've got another error during the compilation. A lot of lines like :
/usr/include/unicode/umachine.h:347:13: error: 'char16_t' does not name a type; did you mean 'wchar_t'?
/usr/include/unicode/ucnv.h:226:27: error: 'UChar' does not name a type; did you mean 'UChar32'?
The option CEGUI_BUILD_XMLPARSER_LIBXML2=OFF seems working. Is it ok ?

osvein commented on 2017-09-17 17:27

Yeah, that's a known issue with tolua++. I wanted to submit a bug report to the Arch Linux package as upstream seemed dead, but I figured I'd try submitting a pull request to upstream first anyway. I eventually forgot about it, but it's been 3 months now so I guess I was right it was dead. I don't want to mess with Arch bug reports right now (or ever tbh, so feel free to do it yourself), so I've updated the PKGBUILD with the workaround I was using.

http://www.cegui.org.uk/forum/viewtopic.php?f=10&t=7195#p34902
https://github.com/LuaDist/toluapp/pull/2

Jeanbon commented on 2017-09-17 13:13

I can't build it. The linker can't find reference to lua_*. Logs :
[ 1%] Linking C executable ../../../../../../bin/toluappcegui-0.8
CMakeFiles/toluappcegui-0.8.dir/tolua.c.o: In function `main':
tolua.c:(.text.startup+0x3e): undefined reference to `lua_setglobal'
tolua.c:(.text.startup+0x5c): undefined reference to `lua_setglobal'
tolua.c:(.text.startup+0x81): undefined reference to `lua_setglobal'
tolua.c:(.text.startup+0xa9): undefined reference to `lua_setglobal'
tolua.c:(.text.startup+0x1ff): undefined reference to `lua_getglobal'
tolua.c:(.text.startup+0x20a): undefined reference to `lua_rawlen'
collect2: error: ld returned 1 exit status
make[2]: *** [cegui/src/ScriptModules/Lua/support/tolua++bin/CMakeFiles/toluappcegui-0.8.dir/build.make:124: bin/toluappcegui-0.8] Error 1
make[1]: *** [CMakeFiles/Makefile2:837: cegui/src/ScriptModules/Lua/support/tolua++bin/CMakeFiles/toluappcegui-0.8.dir/all] Error 2