Package Details: cellprofiler-git 2.2.0.PR.1.r1148.gd30878ec3-1

Git Clone URL: https://aur.archlinux.org/cellprofiler-git.git (read-only)
Package Base: cellprofiler-git
Description: Analysis software for cellular images
Upstream URL: http://www.cellprofiler.org/
Licenses: GPL
Provides: cellprofiler
Submitter: mschu
Maintainer: radioxoma
Last Packager: radioxoma
Votes: 1
Popularity: 0.000000
First Submitted: 2012-09-03 16:25
Last Updated: 2017-05-04 15:46

Latest Comments

radioxoma commented on 2017-05-04 12:32

Due to changes in matplotlib 2 API (https://github.com/CellProfiler/CellProfiler/issues/2581) leading to impossibility to run stable Cellprofiler 2.2.0 on current Archlinux, I decided to create PKGBUILD for Cellprofiler 3.0.0rc1 - latest commit at 2017-05-03. Never mind about specified above version 2.2.0.PR.1.r1148.gd30878ec3, 3.0.0rc1 will be built. CP guys didn't changed version tag in source repo for now.

bradgy commented on 2017-05-01 16:37

Thanks @radioxoma. That helped! But I'm now seeing an error here https://aur.archlinux.org/pkgbase/python2-libtiff-svn/?comments=all

radioxoma commented on 2017-03-31 20:30

@bradgy, please install subversion to use subversion: `sudo pacman -S subversion`.

bradgy commented on 2017-03-31 16:40

getting "Error: cannot find the subversion package needed to handle svn sources" when building python2-libtiff-svn.

Malambo commented on 2016-01-15 13:24

Seems that still working! thanks!

mschu commented on 2014-07-25 12:11

Updated, thanks.

alex.forencich commented on 2014-07-24 08:24

Seems like there is something wrong with the setup.py part. I managed to get this working; here is what you need to do:

delete the entire prepare() section

delete everything in build() except for the first and last line (cd and the call to CellProfiler.py)

add

export LD_LIBRARY_PATH=$JAVA_HOME/jre/lib/amd64:$JAVA_HOME/jre/lib/amd64/server

to cellprofiler.sh

run makepkg -g to regenerate the hashes, paste them in. Then build and install.

shugoshin commented on 2014-05-13 21:14

I am also getting the same error:
distutils.errors.DistutilsError: Setup script exited with error: This distribution is only supported on MacOSX

any help please?

alex.forencich commented on 2014-04-04 00:52

I'm getting the following error when I try to install this:

distutils.errors.DistutilsError: Setup script exited with error: This distribution is only supported on MacOSX

mschu commented on 2013-10-26 13:09

Updated, thanks for the patches!

All comments