Package Details: cgal-ipelets 4.10-1

Git Clone URL: https://aur.archlinux.org/cgal-ipelets.git (read-only)
Package Base: cgal-ipelets
Description: Ipelets from CGAL
Upstream URL: http://www.cgal.org
Licenses: GPL
Submitter: foxcub
Maintainer: foxcub
Last Packager: foxcub
Votes: 2
Popularity: 0.000000
First Submitted: 2008-03-12 17:41
Last Updated: 2017-07-15 17:39

Dependencies (6)

Required by (0)

Sources (1)

Latest Comments

calegria commented on 2017-07-20 02:20

Thx for updating the package.

- I found the license type in the CGAL package overview page (http://doc.cgal.org/latest/Manual/packages.html). The CGAL Ipelets package is released under the LGPL license.

- I am getting this error when executing the "Simple Triangulation" Ipelet. Will try to find the cause:
----------
Lua error

Data may have been corrupted.
Save your file!

[string "/usr/lib/ipe/7.2.7/ipelets/libCGAL_simple_tri..."]:15: Error loading Ipelet '/usr/lib/ipe/7.2.7/ipelets/libCGAL_simple_triangulation.so': /usr/lib/ipe/7.2.7/ipelets/libCGAL_simple_triangulation.so: cannot open shared object file: No such file or directory
stack traceback:
[C]: in function 'assert'
[string "/usr/lib/ipe/7.2.7/ipelets/libCGAL_simple_tri..."]:15: in field 'run'
/usr/share/ipe/7.2.7/lua/actions.lua:606: in method 'action_ipelet'
/usr/share/ipe/7.2.7/lua/actions.lua:80: in method 'paction'
/usr/share/ipe/7.2.7/lua/actions.lua:37: in function </usr/share/ipe/7.2.7/lua/actions.lua:37>
[C]: in function 'xpcall'
/usr/share/ipe/7.2.7/lua/actions.lua:37: in function </usr/share/ipe/7.2.7/lua/actions.lua:36>
[C]: in function 'mainloop'
/usr/share/ipe/7.2.7/lua/main.lua:467: in main chunk
[C]: in function 'require'
[string "require "main""]:1: in main chunk
----------

foxcub commented on 2017-07-15 17:39

I've updated the package, using your PKGBUILD verbatim, except that I changed the license back to GPL. I'm not sure where you got LGPL from, but these ipelets link against plenty of CGAL packages that are licensed under GPL.

calegria commented on 2017-07-15 02:22

Marked the package as outdated. Current version of CGAL is 4.10. I have confirmed that the package can be built by just changing pkgver variable to 4.10.

Here is my PKGBUILD: https://gist.github.com/calegria/821cf0081d749ced617180396b1249cf

I changed some other things to conform with the Arch packaging standards (used namcap command to look for things to change).

foxcub commented on 2015-02-24 02:48

Updated. Not quite sure why there is a mismatch in _pkgid between your and my version of PKGBUILD.

calegria commented on 2015-02-23 18:28

Confirmed that the package can be built by just changing CGAL version to 4.5.1, (tha latest on community repository), and Ipe version to 7.1.7 (the latest available).

Here is my PKGBUILD: https://gist.github.com/calegria/81b46658b7aa3676dacf#file-pkgbuild-cgal-ipelets-4-5-1

foxcub commented on 2014-10-22 15:23

Thanks, and done.

calegria commented on 2014-10-18 23:57

Need to add boost as a building dependency. boost-libs gets included by cgal, but building the ipelets requires also the development headers.

Thanks

Anonymous comment on 2012-04-20 23:24

The cgal/ipe version bumped to 4.0/7.1.2, please update

pkgver=4.0
_pkgid=30385
ipever=7.1.2

Thanks.

foxcub commented on 2011-08-31 15:31

Done. Thanks for the reminder.

Anonymous comment on 2011-08-31 08:26

The ipe package on AUR has been updated, please change $ipever to 7.1.0.

Anonymous comment on 2010-12-06 06:42

I am a robot. You have accidentally tarred up some dotfiles. Examples:
.hg_archival.txt
Suggestion: use "makepkg --source". This robot will not bother you again.