Package Details: cgns 3.3.1-4

Git Clone URL: https://aur.archlinux.org/cgns.git (read-only)
Package Base: cgns
Description: Standard for recording and recovering computer data associated with the numerical solution of fluid dynamics equations
Upstream URL: http://www.cgns.org
Licenses: custom
Submitter: eolianoe
Maintainer: eolianoe
Last Packager: eolianoe
Votes: 31
Popularity: 0.242388
First Submitted: 2015-07-12 17:15
Last Updated: 2017-08-15 10:30

Latest Comments

eolianoe commented on 2017-05-12 08:50

@ycl: building and checking nicely in a clean-chroot, you may have some special config.

ycl commented on 2017-05-11 21:56

In 3.3.0-3, it fails to compile and I add -lz. It works. But the test fails.

ycl commented on 2017-05-11 21:54

I also got this in 3.3.0-3

The following tests FAILED:
2 - elemtest (Failed)
3 - test_exts (Failed)
4 - test_goto (Failed)
5 - test_partial (Failed)
6 - test_ver31 (Failed)
7 - test_multifam (Failed)
8 - write_array (Failed)
9 - write_bcdata (Failed)
10 - write_links (Failed)
11 - write_rind (Failed)
12 - write_test (Failed)
13 - write_zones (Failed)
15 - cgwrite (Failed)
16 - cgread (Failed)
17 - cgzconn (Failed)
18 - cgsubreg (Failed)

GloW commented on 2017-01-19 08:12

Or we could have two version of cgns, no?

eolianoe commented on 2016-11-24 19:03

@elvenbone: I'm more in favor of building paraview against hdf-1.10 rather than using hdf-1.8 in CGNS. I'll try do that and in case of failure, I'll "downgrade" CGNS to use the old hdf5

elvenbone commented on 2016-11-16 23:40

Paraview does not compile with CGNS, although CGNS itself compiles fine.
Apparently paraview cannot handle HDF5-1.10 yet.
When I change the PKGBUILD of CGNS locally to depend on hdf5_18-cpp-fortran (HDF5-1.8) instead of hdf5-cpp-fortran (1.10), everything works as it should.

@eolianoe: Can you please make CGNS depend on either of the hdf5-versions/packages, so that it does not break paraview with cgns?
Since this package provides libcgns-paraview with its HDF5 linking, this can probably not be done on the paraview package itself.

eolianoe commented on 2016-09-22 08:09

@Xwang: CGNS needs an hdf5 package with fortran support so extra/hdf5-cpp-fortran and AUR/hdf5-fortran-openmpi are ok but they do not provide the same thing. I'll try to see if I can get a generic solution

Xwang commented on 2016-09-21 06:26

Can you please modify the pkgbuild to use or at least to accept as a valid hdf5 provider hdf5-fortran-openmpi instead of hdf5-cpp-fortran?

eolianoe commented on 2016-09-20 16:42

@muon: I reproduced the bug, it should be fixed in 3.3.0-2. Tested in i686 and x86_64 clean chroots

muon commented on 2016-09-20 16:10

I get a build error that looks to be related to hdf5 (cgns-3.3.0-1):
https://gist.github.com/raybsmith/95432f2d8f40892f0c847ed21bcfa13f
edit: I should clarify, I have both hdf5 and hdf5_18 from the official repos installed.

All comments