Package Details: chatty 0.12-1

Git Clone URL: https://aur.archlinux.org/chatty.git (read-only, click to copy)
Package Base: chatty
Description: Twitch Chat Client for Desktop
Upstream URL: https://chatty.github.io/
Licenses: GPL3
Submitter: c-korn
Maintainer: Freso
Last Packager: Freso
Votes: 27
Popularity: 0.020086
First Submitted: 2015-03-23 00:17
Last Updated: 2020-05-15 11:22

Required by (0)

Sources (4)

Pinned Comments

Freso commented on 2018-07-15 16:02

For users who have used this PKGBUILD on version earlier than 0.9.x, note that from PKGBUILD 0.9.1-1 onwards, the PKGBUILD will not include as many patches as <0.9 PKGBUILDs did. One of the things this means is that the configuration will now be read from $HOME/.chatty instead of $HOME/.config/chatty. I'd recommend to either create a symlink (cd $HOME && ln -s .config/chatty .chatty) or move (or copy) the directory (cd $HOME && mv .config/chatty .chatty) prior to running version 0.9.x+ the first time.

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

bennyhillthebes commented on 2018-07-17 16:19

i am just a noob, but why do the package need gradle now and why the PKGBUILD fails? Isn't Chatty just a .jar file? Simply pasting over the old .jar is not an option?

morningpee commented on 2018-07-17 01:47

Freso: please commit this patch to fix the path issue Stebs mentioned.

https://gitlab.com/morningpee/chatty/commit/ba467a95.patch

Stebs commented on 2018-07-16 09:52

Checksum of chatty-0.9.1.tar.gz is wrong. After manually correcting this, install fails with: /home/user/.cache/pacaur/chatty/PKGBUILD: line24: cd: chatty-0.9.1: file or folder not found

Freso commented on 2018-07-15 16:02

For users who have used this PKGBUILD on version earlier than 0.9.x, note that from PKGBUILD 0.9.1-1 onwards, the PKGBUILD will not include as many patches as <0.9 PKGBUILDs did. One of the things this means is that the configuration will now be read from $HOME/.chatty instead of $HOME/.config/chatty. I'd recommend to either create a symlink (cd $HOME && ln -s .config/chatty .chatty) or move (or copy) the directory (cd $HOME && mv .config/chatty .chatty) prior to running version 0.9.x+ the first time.

Freso commented on 2018-07-15 14:28

Remove the disable_version_check.patch please.

Not going to happen. If the package is outdated (like now), the version check will do nothing towards updating it, other than be in your way while you're running the program. You can install the upstream version in your $HOME if you wish to do that rather than using your package manager to install it system-wide. The changes from chatty 0.8 to 0.9 are too many that updating the PKGBUILD is as easy as updating the $pkgver, which is why it's taking a while.

daren commented on 2018-06-11 07:10

Remove the disable_version_check.patch please.

I was using this for months without realizing it is an old version. Wouldn't display FFZ emotes anymore since a couple of weeks and I tried to find the cause.

Freso commented on 2018-06-10 22:03

I'm cleaning up the PKGBUILD a bit now, before updating to 0.9.1, but none of the patches from the current PKGBUILD seem to apply outright and 0.9.1 doesn't seem to build without the patches either. I need to look into it some more and probably switch to using the tools used by upstream (ie., gradle).

If anyone wants to discuss how to handle the package going forward, please feel free to contact me.

gim commented on 2017-03-19 18:06

Why Chatty tries to find sounds in /usr/share/chatty/sounds/ instead of /usr/share/chatty/assets/sounds/?

gim commented on 2016-07-05 07:01

PKGBUILD should not depend on any specific version or implementation of JDK as well, it's just not necessary. What if someone's using proprietary implementation by Oracle? Also if you believe that application works only with Java 8 and later, you should set 'java-environment>=8' as dependency.

gim commented on 2016-07-03 19:27

Hi. Is there a reason you replaced 'java-environment' dependency with 'jre7-openjdk' and 'jdk7-openjdk'? It doesn't make sense, since in Java the most recent versions of JDK and JRE are backward compatible with previous versions. Also it will break the build for people using patched versions of openjdk:
* https://aur.archlinux.org/packages/jre7-openjdk-infinality
* https://aur.archlinux.org/packages/jre8-openjdk-infinality/