Package Details: cheat-git 2.4.2-1

Git Clone URL: https://aur.archlinux.org/cheat-git.git (read-only, click to copy)
Package Base: cheat-git
Description: Cheat allows you to create and view interactive cheatsheets on the command-line
Upstream URL: https://github.com/chrisallenlane/cheat
Licenses: GPL3
Conflicts: cheat-bash-git, python-cheat
Submitter: askurihin
Maintainer: guotsuan
Last Packager: guotsuan
Votes: 40
Popularity: 0.141703
First Submitted: 2013-08-29 13:59
Last Updated: 2019-01-30 10:04

Required by (0)

Sources (1)

Latest Comments

1 2 Next › Last »

yochananmarqos commented on 2019-11-03 15:29

New stable version: cheat

MagicAndWires commented on 2019-11-02 22:30

Updated my gist to include a second patch for the latest release (3.0.3).

The rest still applies.

MagicAndWires commented on 2019-10-22 12:54

@yochananmarqos

Yeah, the deps.sh script misses two dependencies : >

Already made an issue for it on GitHub though.

yochananmarqos commented on 2019-10-21 21:16

@MagicAndWires: I was working on a similar PKGBUILD, but it errors out during build:

==> Starting build()...
# command-line-arguments
loadinternal: cannot find runtime/cgo
../gopath/src/github.com/alecthomas/chroma/lexers/internal/api.go:9:2: cannot find package "github.com/danwakefield/fnmatch" in any of:
    /usr/lib/go/src/github.com/danwakefield/fnmatch (from $GOROOT)
    /home/yochanan/Documents/pkgbuilds/cheat/src/gopath/src/github.com/danwakefield/fnmatch (from $GOPATH)
../gopath/src/github.com/cheat/cheat/internal/config/config.go:11:2: cannot find package "gopkg.in/yaml.v2" in any of:
    /usr/lib/go/src/gopkg.in/yaml.v2 (from $GOROOT)
    /home/yochanan/Documents/pkgbuilds/cheat/src/gopath/src/gopkg.in/yaml.v2 (from $GOPATH)
==> ERROR: A failure occurred in build().
    Aborting...

MagicAndWires commented on 2019-10-21 20:30

I made a patch for the PKGBUILD that works with the new release; you can find it here.

Also note that this package now needs the files from: https://github.com/cheat/cheatsheets to work. I might write a split package for that on a later date.

fedex_cain commented on 2019-10-21 10:22

Hey, version 3.0.0 was just released and has been reimplemented in golang, so this package will need to be adapted for this change.

Github Release: https://github.com/cheat/cheat/releases/tag/3.0.0

guotsuan commented on 2019-01-30 10:06

The package has been updated. Thanks @yochananmarqos.

yochananmarqos commented on 2019-01-28 22:19

If you're going to install the bash autocompletion file, why not also install the zsh & fish versions as well? See my PKGBUILD.

guotsuan commented on 2018-06-18 14:20

Thanks @yochananmarqos, the package has been updated.

yochananmarqos commented on 2018-06-06 17:48

The optional dependency should be python2-pygments. Also, bash-completion should be added as optional as well. See Enabling Command line Autocompletion.

$ wget https://github.com/chrisallenlane/cheat/raw/master/cheat/autocompletion/cheat.bash
$ mv cheat.bash cheat
# mv cheat /usr/share/bash-completion/completions

EDIT: cheat-bash-git and python-cheat need to be added as conflicts.