Package Details: checkbashisms 20160203-4

Git Clone URL: https://aur.archlinux.org/checkbashisms.git (read-only)
Package Base: checkbashisms
Description: Debian script that checks for bashisms
Upstream URL: http://packages.qa.debian.org/d/devscripts.html
Licenses: GPL
Conflicts: devscripts
Submitter: None
Maintainer: severach
Last Packager: severach
Votes: 55
Popularity: 0.774904
First Submitted: 2010-05-21 04:37
Last Updated: 2016-09-22 15:00

Latest Comments

severach commented on 2016-01-08 18:38

The SHA mismatch means there's an update which will always be a problem for first responders. Flag out of date instead of reporting. I've fixed the download name so that upgrading won't be so much of a hassle.

Freso commented on 2016-01-08 12:50

Perhaps include scripts/checkbashisms.bash_completion as well? Also, I'm getting SHA256 sum mismatch on .pl (the man page verifies fine).

severach commented on 2015-10-21 16:19

Build and install here just fine in yaourt. Try cower -u to list out of date AUR packages.

stooj commented on 2015-10-21 01:51

lahwaacz: This fails when I'm using yaourt, but if I build it using makepkg it works fine.

severach commented on 2015-09-18 16:21

I erased my two files and it builds fine. The sums in my file match the ones published here.

View your files to make sure they look like perl and man pages. Check your sums against the AUR PKGBUILD.

lahwaacz commented on 2015-09-18 10:47

Still got wrong SHA sums:

==> Validating source files with sha256sums...
checkbashisms.1 ... Passed
checkbashisms.pl ... FAILED
==> ERROR: One or more files did not pass the validity check!

valr commented on 2015-02-27 19:36

It's failing the sha1sums validation for checkbashisms.pl
Can you fix it?

RunningDroid commented on 2015-02-24 22:48

Updated checkbashisms.pl: changes a link from http:// to https://

Updated PKGBUILD: I switched the pkgver from using the latest release version to using the date of the last change.

RunningDroid commented on 2014-09-27 18:55

This isn't out of date, upstream hasn't changed the checkbashisms script since Nov 21, 2013.

RunningDroid commented on 2014-05-30 00:18

Updated, this fixes the files 404'ing and reduces the download time.

xanc commented on 2013-12-16 12:49

For fix it:

change pkgver=2.13.8
sha1sums=('40f5b1050bf0d01dca58c2563a90aee30bb21813')

(the 2.13.4 is out of date and removed from web server)
(for new versions, download the latest .tar.gz from debian server, change sha1sums after running sha1sum file.tar.gz and change version)

That's all.

notizblock commented on 2012-12-12 09:30

can't build the package.

curl: (22) The requested URL returned error: 404 Not Found

taurgal commented on 2012-10-08 10:13

# Maintainer: Daniel Micay <danielmicay@gmail.com>
# Contributor: Soup <soup a.t soultrap d.o.t n.e.t>
# Contributor: Andres Perera <aepd87@gmail.com>

pkgname=checkbashisms
pkgver=2.12.4
pkgrel=1
pkgdesc="Debian script that checks for bashisms"
arch=('any')
url="http://packages.qa.debian.org/d/devscripts.html"
license=('GPL')
depends=('perl')
conflicts=('devscripts')
source=("http://ftp.de.debian.org/debian/pool/main/d/devscripts/devscripts_$pkgver.tar.gz")
sha1sums=('825e08524264627dad9ecbddcd1f865121d9a40a')

package() {
cd "$pkgdir"
install -Dm755 "$srcdir/devscripts-$pkgver/scripts/checkbashisms.pl" usr/bin/checkbashisms
sed -i s,"###VERSION###","$pkgver", usr/bin/checkbashisms
install -Dm644 "$srcdir/devscripts-$pkgver/scripts/checkbashisms.1" usr/share/man/man1/checkbashisms.1
}

Anonymous comment on 2012-09-11 09:25

Version bump needed to 2.12.2 (2.12.1 gives 404 error).
sha1sums=('1fc06a997dbac1f2047be19174cfe7c8ca692449')

TheRealSoup commented on 2011-06-13 07:18

Thanks for the info. My page2rss feed of the Debian QA page included the version lenny so I didn't see the updates.

Anonymous comment on 2011-06-12 22:36

The url returns a 404 Not Found response.

Using pkgver="2.11.0" and md5sums=('2687a8b5986233b29e84fdeca9a10097') did the trick, the new version seems to work fine.

TheRealSoup commented on 2010-11-17 15:16

-pkgver="2.10.68"
+pkgver="2.10.69"

TheRealSoup commented on 2010-10-01 09:23

-pkgver="2.10.35lenny7"
+pkgver="2.10.68"