Package Details: cherrymusic-devel-git 20160210-1

Git Clone URL: https://aur.archlinux.org/cherrymusic-devel-git.git (read-only)
Package Base: cherrymusic-devel-git
Description: A standalone HTML5 (with Flash fallback) music streaming server based on CherryPy and jPlayer. Git devel-branch.
Upstream URL: http://fomori.org/cherrymusic
Keywords: cherrymusic music server streaming
Licenses: GPL3
Conflicts: cherrymusic
Provides: cherrymusic
Submitter: 6arms1leg
Maintainer: 6arms1leg
Last Packager: 6arms1leg
Votes: 3
Popularity: 0.005160
First Submitted: 2012-09-19 13:30
Last Updated: 2016-02-10 12:01

Latest Comments

tilx commented on 2016-07-03 13:20

I think python-six should be a dependency of the python-cherrypy package. I filed a bug report with community packages: https://bugs.archlinux.org/task/49925.

Until this gets fixed, the workaround is to install python-six manually, as mentioned by @svalo.

svalo commented on 2016-07-01 17:34

I updated my system today and was unable to build with error
Traceback (most recent call last):
File "setup.py", line 10, in <module>
import cherrymusicserver
File "/home/svalo/tmp/makepkg/cherrymusic-devel-git/src/cherrymusic-devel-git/cherrymusicserver/__init__.py", line 69, in <module>
import cherrypy
File "/usr/lib/python3.5/site-packages/cherrypy/__init__.py", line 64, in <module>
from cherrypy._cperror import HTTPError, HTTPRedirect, InternalRedirect
File "/usr/lib/python3.5/site-packages/cherrypy/_cperror.py", line 122, in <module>
import six
ImportError: No module named 'six'

I installed python-six and was able to build and use, should it be a dependency?

6arms1leg commented on 2016-03-31 17:57

I forgot to mention here, that there has been a security issue which has been fixed back in 2015, November 21st.
The AUR packages (this Git version and the regular AUR version) have since been updated, so that the regular AUR package for CherryMusic also includes the security fixes.
In case you have not upgraded this AUR package (or the regular one) ever since, I strongly recommend to do so. Sorry for the late notice!

Just for the record – here is the security issue on GitHub:
https://github.com/devsnd/cherrymusic/issues/598

6arms1leg commented on 2013-04-08 21:50

this PKGBUILD now requires pacman >= 4.1!

6arms1leg commented on 2013-04-03 23:11

if you are looking for a systemd service file for cherrymusic, please have a look at the comments on the regular cherrymusic pkgbuild:

https://aur.archlinux.org/packages/cherrymusic

or the arch wiki:

https://wiki.archlinux.org/index.php/CherryMusic#Systemd_service_file

6arms1leg commented on 2013-04-01 01:04

if you are looking for a systemd service file for cherrymusic, please have a look at the comments on the regular cherrymusic pkgbuild:

https://aur.archlinux.org/packages/cherrymusic

6arms1leg commented on 2012-09-20 15:56

please choose this git version over the stable one, if you are not dependent on a 100 percent stable version. you get all the new features and can help the developers testing the newest version. from the website:

"You've found a bug in CherryMusic? That's awesome. Tell us about it! You can open an issue in the issue tracker of github [https://github.com/devsnd/cherrymusic/issues] and we'll take care of it."