Package Details: chirp-hg-py3 r3248.1da5155c5504-1

Git Clone URL: https://aur.archlinux.org/chirp-hg-py3.git (read-only, click to copy)
Package Base: chirp-hg-py3
Description: GUI tool for programming ham radios, built from unstable python3 branch
Upstream URL: http://chirp.danplanet.com/
Licenses: GPL3
Conflicts: chirp
Provides: chirp
Submitter: keenerd
Maintainer: keenerd
Last Packager: keenerd
Votes: 2
Popularity: 0.010929
First Submitted: 2019-08-27 11:43 (UTC)
Last Updated: 2019-09-05 10:12 (UTC)

Latest Comments

maximalist commented on 2021-09-12 19:04 (UTC) (edited on 2021-09-12 19:06 (UTC) by maximalist)

Failed to import /usr/lib/python3.9/site-packages/chirp/drivers/ft70: module 'string' has no attribute 'uppercase'

Failed to import /usr/lib/python3.9/site-packages/chirp/drivers/ft90: module 'string' has no attribute 'uppercase'

Failed to import /usr/lib/python3.9/site-packages/chirp/drivers/tk760g: 'float' object cannot be interpreted as an integer

Failed to import /usr/lib/python3.9/site-packages/chirp/drivers/tk270: 'float' object cannot be interpreted as an integer

Failed to import /usr/lib/python3.9/site-packages/chirp/drivers/tk760: 'float' object cannot be interpreted as an integer

(chirpw:20371): Gtk-CRITICAL **: 22:03:36.732: gtk_widget_grab_default: assertion 'gtk_widget_get_can_default (widget)' failed

ERROR: -- Exception: --

ERROR: Traceback (most recent call last):

File "/usr/lib/python3.9/site-packages/chirp/drivers/uv5r.py", line 816, in sync_in

self._mmap = _do_download(self)

File "/usr/lib/python3.9/site-packages/chirp/drivers/uv5r.py", line 590, in _do_download

data += radio.MODEL.ljust(8)

TypeError: can't concat str to bytes

During handling of the above exception, another exception occurred:

Traceback (most recent call last):

File "/usr/lib/python3.9/site-packages/chirp/ui/clone.py", line 256, in run

self.__radio.sync_in()

File "/usr/lib/python3.9/site-packages/chirp/drivers/uv5r.py", line 820, in sync_in

raise errors.RadioError("Failed to communicate with radio: %s" % e)

chirp.errors.RadioError: Failed to communicate with radio: can't concat str to bytes

ERROR: ----------------

ERROR: Clone failed: Failed to communicate with radio: can't concat str to bytes

ERROR: --- Exception Dialog: Failed to communicate with radio: can't concat str to bytes ---

ERROR: NoneType: None

ERROR: ----------------------------

ganthore commented on 2021-07-14 19:01 (UTC)

I built the package today since chirp-hg and chirp-daily are broken due to python2-pyserial being removed.

The py3 code has a silly bug where a print statement is using py2 syntax:

File "/usr/lib/python3.9/site-packages/chirp/ui/mainapp.py", line 1140 print query

Works fine after I manually changed it.

For the PKGBUILD... Perhaps add a sed command to swap that out for the correct use of print during the prepare phase?

sed -i "s/print\ query/print(query)/g" chirp/ui/mainapp.py

keenerd commented on 2019-09-05 10:10 (UTC)

Please never run "sudo pip" ever. It is terrible advice.

BADGumby commented on 2019-09-04 12:10 (UTC)

If you have issues installing with the message:

ModuleNotFoundError: No module named 'future'

Run 'sudo pip install -U future'