Package Details: chroma 1.17-1

Git Clone URL: https://aur.archlinux.org/chroma.git (read-only, click to copy)
Package Base: chroma
Description: Abstract puzzle game.
Upstream URL: http://www.level7.org.uk/chroma/
Licenses: GPL
Submitter: danym
Maintainer: None
Last Packager: FredBezies
Votes: 12
Popularity: 0.000000
First Submitted: 2010-01-27 18:12
Last Updated: 2019-12-09 22:10

Latest Comments

FredBezies commented on 2020-01-07 12:39

@vikits: I was using a "modified" freetype2 package.

Looks like this software is broken because developer did not updated it.

Orphaning it.

vikits commented on 2020-01-06 05:22

The configure script needs some tweaking. There are references to deprecated freetype-config in configure and configure.ac files. I did try to change them myself. By replacing "freetype-config" with "pkg-config", "freetypeconf_args --cflags" with "freetypeconf_args --cflags freetype2" and "freetypeconf_args --libs" with "freetypeconf_args --libs freetype2". But still the compilation fails at config. configure: error: *** Unable to find FreeType2 library (http://www.freetype.org/)

dreieck commented on 2019-11-04 21:23

I get an error building the package

configure: error: *** Unable to find FreeType2 library (http://www.freetype.org/)

(package freetype2 is installed.)

ozderi commented on 2019-06-11 07:01

Sorry I didn't realized I was still the maintainer. The package is now orphaned, so you can adopt it :)

Anonymous comment on 2019-06-08 10:03

Fix the build: cd chroma-1.17 sed -i 's/inline//g' sdlshadowdisplay.c ./configure make

and all is happiness ;)

ozderi commented on 2019-02-08 09:54

The game is now playable in a browser : http://www.level7.org.uk/chroma/chroma.html

So I won't consider adopting the package, which loses its interest :/ (in my case at least)

schuay commented on 2019-02-04 16:28

The configure script will need some tweaking for 1.16; it looks for freetype-config which has been removed from upstream for a while apparently. What it should do is use pkgconfig instead. I don't have time to fix this, orphaning.

Anonymous comment on 2012-01-15 11:27

Here's a PKGBUILD for 1.14: http://pastebin.com/hzSte4Bk