Package Details: chromeos-vboot-reference-git r20221126105520.e952b90-3

Git Clone URL: https://aur.archlinux.org/chromeos-vboot-reference-git.git (read-only, click to copy)
Package Base: chromeos-vboot-reference-git
Description: ChromeOS vbutil tools: futility (vbutil_kernel) cgpt from git.
Upstream URL: https://chromium.googlesource.com/chromiumos/platform/vboot_reference
Licenses: GPL
Conflicts: vboot-utils
Provides: vboot-utils
Submitter: ericwoud
Maintainer: ericwoud
Last Packager: ericwoud
Votes: 0
Popularity: 0.000000
First Submitted: 2022-07-09 18:48 (UTC)
Last Updated: 2023-06-21 14:56 (UTC)

Required by (5)

Sources (0)

Latest Comments

ericwoud commented on 2023-11-08 08:44 (UTC) (edited on 2023-11-08 08:44 (UTC) by ericwoud)

@dwlsalmeida

I have added 'chromeos-flashrom-git' as depends and makedepends before.

What do you suggest for a fix?

dwlsalmeida commented on 2023-11-07 13:23 (UTC) (edited on 2023-11-07 13:25 (UTC) by dwlsalmeida)

@ericwoud FYI, this package is still broken for the same reason I outlined previously:

host/lib/flashrom_drv.c: In function ‘flashrom_get_info’:
host/lib/flashrom_drv.c:407:9: error: implicit declaration of function ‘flashrom_flash_getinfo’; did you mean ‘flashrom_flash_getsize’? [-Werror=implicit-function-declaration]
  407 |         flashrom_flash_getinfo(flashctx, &info);
      |         ^~~~~~~~~~~~~~~~~~~~~~
      |         flashrom_flash_getsize
host/lib/flashrom_drv.c:411:20: error: ‘struct flashrom_flashchip_info’ has no member named ‘manufacture_id’
  411 |         *vid = info.manufacture_id;
      |                    ^
host/lib/flashrom_drv.c:412:20: error: ‘struct flashrom_flashchip_info’ has no member named ‘model_id’
  412 |         *pid = info.model_id;
      |                    ^
At top level:
cc1: note: unrecognized command-line option ‘-Wno-unknown-warning’ may have been intended to silence earlier diagnostics
cc1: all warnings being treated as errors

ericwoud commented on 2023-06-21 14:57 (UTC)

@amstan: Thanks, it is added.

amstan commented on 2023-06-20 23:35 (UTC) (edited on 2023-06-20 23:46 (UTC) by amstan)

doc/meson.build:2:9: ERROR: Program 'sphinx-build' not found or not executable

pacman -S python-sphinx does the trick, so perhaps add it as a dependency.

ericwoud commented on 2023-02-26 17:25 (UTC) (edited on 2023-02-26 17:29 (UTC) by ericwoud)

But it already is in the depends=

I see now, I will add it...

CurtisLeeBolin commented on 2023-02-26 17:07 (UTC)

ericwoud, as dwlsalmeida stated before, this package will NOT build with flashrom installed. I had to removed flashrom and install chromeos-flashrom-git to get this package to build. Please update 'makedepends' to reflect this.

ericwoud commented on 2023-01-31 15:29 (UTC)

@dwlsalmeida Yes indeed, the crossystem utility uses ChromeOS modified flashrom libraries. That is why it is included as dependancy.

dwlsalmeida commented on 2023-01-31 14:28 (UTC)

I had to install "chromeos-flashrom-git" to get this to build. Apparently incompatible with "flashrom"

ericwoud commented on 2022-11-28 13:58 (UTC)

Thanks for reporting. I've added the following, so the build will continue anyway:

  export CFLAGS+=" -Wno-error=deprecated-declarations"  # Skip deprecated: Since OpenSSL 3.0

TheCycoONE commented on 2022-11-27 22:11 (UTC)

Appears to be incompatible with openssl 3 currently.

host/lib/host_key2.c:119:17: warning: ‘RSA_free’ is deprecated: Since OpenSSL 3.0 [-Wdeprecated-declarations]