Package Details: chromium-vaapi-bin 80.0.3987.100-1

Git Clone URL: https://aur.archlinux.org/chromium-vaapi-bin.git (read-only, click to copy)
Package Base: chromium-vaapi-bin
Description: Chromium with VA-API support to enable hardware acceleration, pre-compiled
Upstream URL: https://www.chromium.org/Home
Licenses: BSD
Conflicts: chromium, chromium-vaapi
Provides: chromium, chromium-vaapi
Submitter: maximbaz
Maintainer: kureta
Last Packager: kureta
Votes: 86
Popularity: 4.33
First Submitted: 2017-06-17 14:26
Last Updated: 2020-02-14 10:59

Dependencies (40)

Required by (62)

Sources (2)

Pinned Comments

kureta commented on 2019-01-29 11:07

Please add this gpg key to install this package

gpg --recv-keys EB4F9E5A60D32232BB52150C12C87A28FEAC6B20

You can also add keyserver-options auto-key-retrieve to your ~/.gnupg/gpg.conf file.

If you have problems connecting to a Chromecast, just enable the following flag:

chrome://flags/#load-media-router-component-extension

and restart Chromium.

Thanks to maximbaz for providing pre-compiled binaries, and thanks to niklaszantner for the tip about Chromecast.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

my_archlinux commented on 2019-11-03 16:05

Hi Kureta,

I am using Pacman on Manjaro. Tried both sudo pacman -Sc and sudo pacman -Scc, but still not work.

kureta commented on 2019-11-03 15:53

clean your aur cache and try again. if you're using yay, delete ~/.cache/yay/chromium-vaapi-bin

my_archlinux commented on 2019-11-03 15:47

Error when upgrading to a new version.

Building chromium-vaapi-bin... ==> Making package: chromium-vaapi-bin 78.0.3904.87-1 (Sun 03 Nov 2019 04:46:57 PM CET) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Downloading chromium-vaapi-78.0.3904.87-1-x86_64.pkg.tar.xz... ** Resuming transfer from byte position 72336888 % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0 0 197 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0 curl: (22) The requested URL returned error: 416 ==> ERROR: Failure while downloading https://pkgbuild.com/~maximbaz/repo/chromium-vaapi-78.0.3904.87-1-x86_64.pkg.tar.xz Aborting...

maximbaz commented on 2019-10-27 16:58

raphi011: as far as I understand, another good way to check if HW acceleration is working for you (besides looking at CPU load) is to play a video and go to chrome://media-internals to see the video decoder. MojoVideoDecoder for example is playing on GPU. I also invite you to visit our forum thread, once the forum comes back from maintenance :)

digitalone commented on 2019-10-27 14:53

If you set persistent flags, relative options are not showed under flag page, but they are enabled from command line. If hardware acceleration is enabled, you should notice a reduction in cpu usage during playback.

raphi011 commented on 2019-10-27 13:57

Hi unfortunately hardware acceleration is not working for me even though vaapi is supported on my system:

vainfo
vainfo: VA-API version: 1.5 (libva 2.5.0)
vainfo: Driver version: Intel iHD driver - 1.0.0
vainfo: Supported profile and entrypoints
      VAProfileNone                   : VAEntrypointVideoProc
      VAProfileNone                   : VAEntrypointStats
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Simple            : VAEntrypointEncSlice
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointEncSlice
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointEncSlice
      VAProfileH264Main               : VAEntrypointFEI
      VAProfileH264Main               : VAEntrypointEncSliceLP
      VAProfileH264High               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointEncSlice
      VAProfileH264High               : VAEntrypointFEI
      VAProfileH264High               : VAEntrypointEncSliceLP
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
      VAProfileJPEGBaseline           : VAEntrypointVLD
      VAProfileJPEGBaseline           : VAEntrypointEncPicture
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline: VAEntrypointFEI
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSliceLP
      VAProfileVP8Version0_3          : VAEntrypointVLD
      VAProfileVP8Version0_3          : VAEntrypointEncSlice
      VAProfileHEVCMain               : VAEntrypointVLD
      VAProfileHEVCMain               : VAEntrypointEncSlice
      VAProfileHEVCMain               : VAEntrypointFEI
      VAProfileHEVCMain10             : VAEntrypointVLD
      VAProfileHEVCMain10             : VAEntrypointEncSlice
      VAProfileVP9Profile0            : VAEntrypointVLD
      VAProfileVP9Profile2            : VAEntrypointVLD
lspci -vnnn | perl -lne 'print if /^\d+\:.+(\[\S+\:\S+\])/' | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 630 (Mobile) [8086:3e9b] (prog-if 00 [VGA controller])
local/chromium-vaapi-bin 78.0.3904.70-1
    Chromium with VA-API support to enable hardware acceleration, pre-compiled

Any ideas?

UPDATE After following this wiki: https://wiki.archlinux.org/index.php/Chromium#Hardware_video_acceleration I now get Video Decode: Hardware accelerated in chrome://gpu, but chrome://flags still tells me Hardware-accelerated video decode, which is weird.

kureta commented on 2019-10-14 23:32

@freefreeno updated the PKGBUILD just now. Sorry for the delay.

digitalone commented on 2019-10-14 22:51

The pkgbuild is set to download a build not available anymore on maximbaz repository. Wait kureta to update or use chromium-vaapi from archlinuxcn repository.

maximbaz commented on 2019-10-14 22:51

Hehe I had to compile many chromium-vaapi builds today and garbage collector cleaned up the old builds including .90-1 one :D Update to the latest 120-2, it has new better VA-API patch! :)

https://pkgbuild.com/~maximbaz/repo/chromium-vaapi-77.0.3865.120-2-x86_64.pkg.tar.xz

freefreeno commented on 2019-10-14 22:47

When trying to install this package from pamac in manjaro it is trying to download the normal chromium-vaapi. Here is what I get. Maybe it is supposed to do that but the errors I know are wrong and I use this package all the time.Hope to see it get fixed soon. Also tried it manually and recieved the same errors.

ERROR: Failure while downloading https://pkgbuild.com/~maximbaz/repo/chromium-vaapi-77.0.3865.90-1-x86_64.pkg.tar.xz Aborting...